[PATCH 0/1] gnu: Add cl-clog

  • Done
  • quality assurance status badge
Details
3 participants
  • Guillaume Le Vaillant
  • Aurora
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 20 May 2022 22:05
(address . guix-patches@gnu.org)
CAO+9K5rHtE8htmeZHL8EtU4C2FRQ3zBSRZ3qO4QhDjCc1C7osA@mail.gmail.com
Sharlatan Hellseher (1):
gnu: Add cl-clog
gnu/packages/lisp-xyz.scm | 50 ++++++++++++++++++++++++++++++++++++++-
1 file changed, 49 insertions(+), 1 deletion(-)
base-commit: 31a9003d4f47fe54df61d2313728bc09a21f20d0
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
S
S
Sharlatan Hellseher wrote on 20 May 2022 22:07
[PATCH 1/1] gnu: Add cl-clog
(address . 55546@debbugs.gnu.org)
CAO+9K5o=o8ykV6ScMn=0PC3RbcisQ4U1Gnj2JFJyj16cNNj74g@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 901c42b7c0d0e3fd5f910e0350268d75ffebe7ff Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 20 May 2022 21:02:08 +0100
Subject: [PATCH 1/1] gnu: Add cl-clog

* gnu/packages/lisp-xyz.scm (sbcl-clog, ecl-clog, cl-clog): New variables.
---
gnu/packages/lisp-xyz.scm | 50 ++++++++++++++++++++++++++++++++++++++-
1 file changed, 49 insertions(+), 1 deletion(-)

Toggle diff (67 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 7fa0db59f9..0fd7b618a0 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20,7 +20,7 @@
;;; Copyright © 2020 Dimakis Dimakakos <me@bendersteed.tech>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020, 2021, 2022 Adam Kandur <rndd@tuta.io>
-;;; Copyright © 2020, 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2020, 2021, 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021, 2022 Aurora <rind38@disroot.org>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021, 2022 André A. Gomes <andremegafone@gmail.com>
@@ -21350,3 +21350,51 @@ (define-public cl-listopia
(define-public ecl-listopia
(sbcl-package->ecl-package sbcl-listopia))
+
+(define-public sbcl-clog
+ (package
+ (name "sbcl-clog")
+ (version "1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rabbibotton/clog")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "clog" version))
+ (sha256
+ (base32 "0f4i6571nm0j704zgnh60sc9slifs11byb2gs8gamqjcfh931dap"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-3bmd
+ sbcl-alexandria
+ sbcl-bordeaux-threads
+ sbcl-cl-ppcre
+ sbcl-cl-sqlite
+ sbcl-cl-template
+ sbcl-clack
+ sbcl-closer-mop
+ sbcl-colorize
+ sbcl-dbi
+ sbcl-hunchentoot
+ sbcl-lack
+ sbcl-mgl-pax
+ sbcl-parse-float
+ sbcl-quri
+ sbcl-trivial-open-browser
+ sbcl-websocket-driver))
+ (home-page "https://github.com/rabbibotton/clog")
+ (synopsis "Common Lisp Omnificent GUI")
+ (description
+ "This package provides the Common Lisp web framefork for building GUI
+applications. CLOG can take the place, or work along side, most cross platform
+GUI frameworks and website frameworks. The CLOG package starts up the
+connectivity to the browser or other websocket client (often a browser embedded
+in a native template application.")
+ (license license:bsd-3)))
+
+(define-public cl-clog
+ (sbcl-package->cl-source-package sbcl-clog))
+
+(define-public ecl-clog
+ (sbcl-package->ecl-package sbcl-clog))
--
2.36.0
G
G
Guillaume Le Vaillant wrote on 21 May 2022 10:45
Re: [bug#55546] [PATCH 0/1] gnu: Add cl-clog
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 55546-done@debbugs.gnu.org)
875ylz6znm.fsf@kitej
I added "clog/docs" and "clog/tools" to the 'asd-systems' parameter and
pushed the patch as 624eac9a6ecffefdaed04aa5678cab06627517af.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYoim/Q8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/qygD6A0rQeUzcQLoIRgudclbEh7o4ihZw3XI7ee1V
OI8C+z8A/Rff0lL0rQ/vHn26TAx+ZsVwb2Qeuu1iWwp6i5r7z08P
=XWBW
-----END PGP SIGNATURE-----

Closed
A
A
Aurora wrote on 29 May 2022 03:32
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
87wne5xgwj.fsf@disp3269
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (9 lines)
> Sharlatan Hellseher (1):
> gnu: Add cl-clog
>
> gnu/packages/lisp-xyz.scm | 50 ++++++++++++++++++++++++++++++++++++++-
> 1 file changed, 49 insertions(+), 1 deletion(-)
>
>
> base-commit: 31a9003d4f47fe54df61d2313728bc09a21f20d0

I have a concern regarding the inclusion of this package, namely that
the way cl-clog currently uses jquery as a dependency involves vendoring
the code into its own repository.

Isn't that contrary to our general guidelines?

- Aurora
S
S
Sharlatan Hellseher wrote on 29 May 2022 13:48
(name . Aurora)(address . rind38@disroot.org)
CAO+9K5o07DBGzmvJp19-2AtZ=z-Cg5-itGXWvhM=yN6Tti4Hpw@mail.gmail.com
Hi Aurora,
I see you nearly packed cl-clog in March and was stopped by jQuery as
It's seam to me that my patch was accepted by chance, it needs to be
reverted due to the same reason as yours.
jQuery is a huge JavaScript package nearly non of it's part is packed
in Guix yet. I would be nice have it on board but not in
a nearly future, but I can schedule it on my backing list
Regards,
On Sun, 29 May 2022 at 02:32, Aurora <rind38@disroot.org> wrote:
Toggle quote (20 lines)
>
>
> Sharlatan Hellseher <sharlatanus@gmail.com> writes:
>
> > Sharlatan Hellseher (1):
> > gnu: Add cl-clog
> >
> > gnu/packages/lisp-xyz.scm | 50 ++++++++++++++++++++++++++++++++++++++-
> > 1 file changed, 49 insertions(+), 1 deletion(-)
> >
> >
> > base-commit: 31a9003d4f47fe54df61d2313728bc09a21f20d0
>
> I have a concern regarding the inclusion of this package, namely that
> the way cl-clog currently uses jquery as a dependency involves vendoring
> the code into its own repository.
>
> Isn't that contrary to our general guidelines?
>
> - Aurora
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
A
A
Aurora wrote on 29 May 2022 22:16
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
87pmjwrt64.fsf@disp3269
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (7 lines)
> Hi Aurora,
>
> I see you nearly packed cl-clog in March and was stopped by jQuery as
> well https://issues.guix.gnu.org/54268.
> It's seam to me that my patch was accepted by chance, it needs to be
> reverted due to the same reason as yours.

That is correct, indeed. And that is unfortunately what I expected.

Toggle quote (5 lines)
> jQuery is a huge JavaScript package nearly non of it's part is packed
> in Guix yet. I would be nice have it on board but not in
> a nearly future, but I can schedule it on my backing list
> https://git.sr.ht/~hellseher/ffab/tree/main/item/TODO

That however would be very nice indeed. In mid-longterm we really do
want jQuery & Bootstrap in Guix, if only because of the sheer number of
projects that depend on them in some way or another.

Unfortunately they also themselves have quite a hefty dependency list.

In any case, thanks for work and for your response.

- Aurora
?