[PATCH] gnu: Add apricots.

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 20 May 2022 06:15
(address . guix-patches@gnu.org)
PU1PR01MB215527084F9B3FFE1C3F10A48DD39@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/games.scm (apricots): New variable.
---
gnu/packages/games.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 37a245c570..32c8c27597 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12679,6 +12679,33 @@ Magic II (aka HOMM2) game engine. It requires assets and game resources to
play; it will look for them at @file{~/.local/share/fheroes2} folder.")
(license license:gpl2)))
+(define-public apricots
+ (package
+ (name "apricots")
+ (version "0.2.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/moggers87/apricots")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0vis217hhnb9fbs9sf8mmcm71qp44kr3xqmffc1gdiixvi90c781"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf ; autom4te used in ./bootstrap
+ automake ; aclocal used in ./bootstrap
+ cppcheck))
+ (inputs (list freealut
+ openal
+ sdl2))
+ (home-page "https://github.com/moggers87/apricots")
+ (synopsis "Arcade airplane game")
+ (description "@code {apricots} is a game where you fly a little plane around
+the screen and shoot things and drop bombs on enemy targets, and it's meant to
+be quick and fun.")
+ (license license:gpl2+)))
+
(define-public liquidwar6
(package
(name "liquidwar6")

base-commit: cf17cbbc1b16dd15c8ec2e637d240de7ae5c3a44
--
2.25.1
M
M
Mathieu Othacehe wrote on 5 Jun 2022 21:25
(address . 55535-done@debbugs.gnu.org)
875ylenc9u.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> * gnu/packages/games.scm (apricots): New variable.

Pushed with the following diff:

Toggle snippet (25 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ca2c56a038..c011622f8e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12696,14 +12696,12 @@ (define-public apricots
(native-inputs (list autoconf ; autom4te used in ./bootstrap
automake ; aclocal used in ./bootstrap
cppcheck))
- (inputs (list freealut
- openal
- sdl2))
+ (inputs (list freealut openal sdl2))
(home-page "https://github.com/moggers87/apricots")
(synopsis "Arcade airplane game")
- (description "@code {apricots} is a game where you fly a little plane around
-the screen and shoot things and drop bombs on enemy targets, and it's meant to
-be quick and fun.")
+ (description "@code{apricots} is a game where you fly a little plane
+around the screen and shoot things and drop bombs on enemy targets. It's
+meant to be quick and fun.")
(license license:gpl2+)))
(define-public liquidwar6

Thanks,

Mathieu
Closed
?