[PATCH 0/5] Use new package style for Emacs variants.

DoneSubmitted by Liliana Marie Prikler.
Details
2 participants
  • Liliana Marie Prikler
  • Maxime Devos
Owner
unassigned
Severity
normal
L
L
Liliana Marie Prikler wrote on 15 May 00:14 +0200
(address . guix-patches@gnu.org)
e972aff8517c1050d8352bfc928cd1d1649ae0c8.camel@gmail.com
Hi Guix,

earlier "today" (or yesterday depending on your timezones), I pushed a
bunch of patches that update Emacs to 28.1 and also uses the new package
style. Sadly this was not reflected in most Emacs variants leading to a
lot of failing builds. The most important one – emacs-minimal – was
already fixed silently, this series ought to take care of the rest.

I'm currently building these locally, but chances are that for some of
you these changes will arrive too late by the time I'll be able to push
them, so I'm sharing them here for those with a faster machine or access
to the CI :)

Cheers

Liliana Marie Prikler (5):
gnu: emacs-next-pgtk: Use new package style.
gnu: emacs-xwidgets: Use new package style.
gnu: emacs-no-x: Use new package style.
gnu: emacs-no-x-toolkit: Use new package style.
gnu: emacs-wide-int: Use new package style.

gnu/packages/emacs.scm | 60 ++++++++++++++++++++----------------------
1 file changed, 29 insertions(+), 31 deletions(-)

--
2.36.0
L
L
Liliana Marie Prikler wrote on 15 May 00:07 +0200
[PATCH 1/5] gnu: emacs-next-pgtk: Use new package style.
(address . 55419@debbugs.gnu.org)
c03df7b3aa80d39ab4b21dd5a94aa2b7d0707baa.camel@gmail.com
* gnu/packages/emacs.scm (emacs-next-pgtk)[arguments]: Convert to list of
G-Expressions.
[inputs]: Use modify-inputs.
---
gnu/packages/emacs.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9649334e45..af902ac9f9 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -348,13 +348,13 @@ (define-public emacs-next-pgtk
     (name "emacs-next-pgtk")
     (arguments
      (substitute-keyword-arguments (package-arguments emacs-next)
-       ((#:configure-flags flags ''())
-        `(cons* "--with-pgtk" "--with-xwidgets" ,flags))))
+       ((#:configure-flags flags #~'())
+        #~(cons* "--with-pgtk" "--with-xwidgets" #$flags))))
     (propagated-inputs
      (list gsettings-desktop-schemas glib-networking))
     (inputs
-     `(("webkitgtk" ,webkitgtk-with-libsoup2)
-       ,@(package-inputs emacs-next)))
+     (modify-inputs (package-inputs emacs-next)
+       (prepend webkitgtk-with-libsoup2)))
     (home-page "https://github.com/masm11/emacs")
     (synopsis "Emacs text editor with @code{pgtk} and @code{xwidgets} support")
     (description "This Emacs build implements graphical UI purely in terms of
-- 
2.36.0
L
L
Liliana Marie Prikler wrote on 15 May 00:10 +0200
[PATCH 2/5] gnu: emacs-xwidgets: Use new package style.
(address . 55419@debbugs.gnu.org)
1ebe47f9ebc26746dce56d7b71094b067f98b0c4.camel@gmail.com
* gnu/packages/emacs.scm (emacs-xwidgets)[arguments]: Convert to list of
G-Expressions.
[inputs]: Use modify-inputs.
---
gnu/packages/emacs.scm | 15 +++++++--------
1 file changed, 7 insertions(+), 8 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index af902ac9f9..e3eba851ff 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -391,16 +391,15 @@ (define-public emacs-xwidgets
     (build-system gnu-build-system)
     (arguments
      (substitute-keyword-arguments (package-arguments emacs)
-       ((#:configure-flags flags ''())
-        `(cons "--with-xwidgets" ,flags))
+       ((#:configure-flags flags #~'())
+        #~(cons "--with-xwidgets" #$flags))
        ((#:phases phases)
-        `(modify-phases ,phases
-           (delete 'restore-emacs-pdmp)
-           (delete 'strip-double-wrap)))))
+        #~(modify-phases #$phases
+            (delete 'restore-emacs-pdmp)
+            (delete 'strip-double-wrap)))))
     (inputs
-     `(("webkitgtk" ,webkitgtk-with-libsoup2)
-       ("libxcomposite" ,libxcomposite)
-       ,@(package-inputs emacs)))))
+     (modify-inputs (package-inputs emacs)
+       (prepend webkitgtk-with-libsoup2 libxcomposite)))))
 
 (define-public emacs-no-x
   (package/inherit emacs
-- 
2.36.0
L
L
Liliana Marie Prikler wrote on 15 May 00:10 +0200
[PATCH 3/5] gnu: emacs-no-x: Use new package style.
(address . 55419@debbugs.gnu.org)
45ccc5b1953f1388438d774e9de63b8ec6e4b6ee.camel@gmail.com
* gnu/packages/emacs.scm (emacs-no-x)[arguments]: Convert to list of
G-Expressions.
[inputs]: Use modify-inputs.
---
gnu/packages/emacs.scm | 24 +++++++++++-------------
1 file changed, 11 insertions(+), 13 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index e3eba851ff..027afc811a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -407,22 +407,20 @@ (define-public emacs-no-x
     (synopsis "The extensible, customizable, self-documenting text
 editor (console only)")
     (build-system gnu-build-system)
-    (inputs (fold alist-delete
-                  (package-inputs emacs)
-                  '("libx11" "gtk+" "libxft" "libtiff" "giflib" "libjpeg"
-                    "imagemagick" "libpng" "librsvg" "libxpm" "libice"
-                    "libsm" "cairo" "pango" "harfbuzz"
-
-                    ;; These depend on libx11, so remove them as well.
-                    "libotf" "m17n-lib" "dbus")))
+    (inputs (modify-inputs (package-inputs emacs)
+              (delete "libx11" "gtk+" "libxft" "libtiff" "giflib" "libjpeg"
+                      "imagemagick" "libpng" "librsvg" "libxpm" "libice"
+                      "libsm" "cairo" "pango" "harfbuzz"
+                      ;; These depend on libx11, so remove them as well.
+                      "libotf" "m17n-lib" "dbus")))
     (arguments
      (substitute-keyword-arguments (package-arguments emacs)
-       ((#:configure-flags flags ''())
-        `(delete "--with-cairo" ,flags))
+       ((#:configure-flags flags #~'())
+        #~(delete "--with-cairo" #$flags))
        ((#:phases phases)
-        `(modify-phases ,phases
-           (delete 'restore-emacs-pdmp)
-           (delete 'strip-double-wrap)))))))
+        #~(modify-phases #$phases
+            (delete 'restore-emacs-pdmp)
+            (delete 'strip-double-wrap)))))))
 
 (define-public emacs-no-x-toolkit
   (package/inherit emacs
-- 
2.36.0
L
L
Liliana Marie Prikler wrote on 15 May 00:11 +0200
[PATCH 4/5] gnu: emacs-no-x-toolkit: Use new package style.
(address . 55419@debbugs.gnu.org)
d4ca5b68c1c596770debd56bfe4cc100ff4e0a94.camel@gmail.com
* gnu/packages/emacs.scm (emacs-no-x-toolkit)[arguments]: Convert to list of
G-Expressions.
[inputs]: Use modify-inputs.
---
gnu/packages/emacs.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 027afc811a..392b3297b0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -428,14 +428,15 @@ (define-public emacs-no-x-toolkit
     (synopsis "The extensible, customizable, self-documenting text
 editor (without an X toolkit)" )
     (build-system gnu-build-system)
-    (inputs (append `(("inotify-tools" ,inotify-tools))
-                    (alist-delete "gtk+" (package-inputs emacs))))
+    (inputs (modify-inputs (package-inputs emacs)
+              (delete "gtk+")
+              (prepend inotify-tools)))
     (arguments
      (substitute-keyword-arguments (package-arguments emacs)
-       ((#:configure-flags flags ''())
-        `(cons "--with-x-toolkit=no" ,flags))
+       ((#:configure-flags flags #~'())
+        #~(cons "--with-x-toolkit=no" #$flags))
        ((#:phases phases)
-        `(modify-phases ,phases
+        #~(modify-phases #$phases
            (delete 'restore-emacs-pdmp)
            (delete 'strip-double-wrap)))))))
 
-- 
2.36.0
L
L
Liliana Marie Prikler wrote on 15 May 00:11 +0200
[PATCH 5/5] gnu: emacs-wide-int: Use new package style.
(address . 55419@debbugs.gnu.org)
220a63dc235f44310ac1ca789beabdd09f7fbdb9.camel@gmail.com
* gnu/packages/emacs.scm (emacs-wide-int)[arguments]: Convert to list of
G-Expressions.
[inputs]: Use modify-inputs.
---
gnu/packages/emacs.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 392b3297b0..25dab7ef59 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -448,7 +448,7 @@ (define-public emacs-wide-int
     (arguments
      (substitute-keyword-arguments (package-arguments emacs)
        ((#:configure-flags flags)
-        `(cons "--with-wide-int" ,flags))))))
+        #~(cons "--with-wide-int" #$flags))))))
 
 (define-public guile-emacs
   (let ((commit "41120e0f595b16387eebfbf731fff70481de1b4b")
-- 
2.36.0
M
M
Maxime Devos wrote on 15 May 10:43 +0200
Re: [bug#55419] [PATCH 0/5] Use new package style for Emacs variants.
0b818dcdcfad4637e5f0898a270365e697702e3f.camel@telenet.be
The patches theirselves LGTM, but I did not build the packages.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYoC9TxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7me4AP9pujL9Dy/4124Cj3p9WJmOy1dm
jT1CGcQ89zGoBJlsogD/Vs1CnQADghpPfq8rAPKhIMl6G1dvLTLgrCATlEclEg8=
=4k/M
-----END PGP SIGNATURE-----


L
L
Liliana Marie Prikler wrote on 15 May 13:14 +0200
f76bc8cd3586bd7e78f2f7e4f4ce3b388a7b38e4.camel@gmail.com
Am Sonntag, dem 15.05.2022 um 10:43 +0200 schrieb Maxime Devos:
Toggle quote (1 lines)
> The patches theirselves LGTM, but I did not build the packages.
Thanks. The packages all built locally, so I pushed them.

Cheers
Closed
?