Image API produces incorrect images

  • Done
  • quality assurance status badge
Details
3 participants
  • Maxime Devos
  • Tobias Geerinckx-Rice
  • Pavel Shlyak
Owner
unassigned
Submitted by
Pavel Shlyak
Severity
normal
Merged with
P
P
Pavel Shlyak wrote on 13 May 2022 23:19
(address . bug-guix@gnu.org)
BD91003D-0D78-4B7A-924D-35FEEC7A4BFD@gmail.com
I have a scheme code like

(define rpi-boot-partition
(partition
(size (* 128 (expt 2 20)))
(label "BOOT")
(file-system "vfat")
(flags '())
(initializer (gexp initialize-efi-partition))))

(define rpi-root-partition
(partition
(size 'guess)
(label "RASPIROOT")
(file-system "ext4")
(flags '(boot))
(initializer (gexp initialize-root-partition))))

(define raspberry-pi-image
(image
(format 'disk-image)
(partitions (list rpi-boot-partition rpi-root-partition))))

The output is like that:
$ fdisk -l /gnu/store/hnsfs5a161f5hvymg7ar541qrml62yvv-raspberry-pi-barebones-raw-image
Device Boot Start End Sectors Size Id Type
/gnu/store/hnsfs5a161f5hvymg7ar541qrml62yvv-raspberry-pi-barebones-raw-image1 1 262144 262144 128M 83 Linux
/gnu/store/hnsfs5a161f5hvymg7ar541qrml62yvv-raspberry-pi-barebones-raw-image2 262145 3583688 3321544 1.6G 83 Linux

No boot flag is set on the first partition. The file system seems to be incorrect (ext* instead of vfat)
T
T
Tobias Geerinckx-Rice wrote on 14 May 2022 10:27
(no subject)
(address . control@debbugs.gnu.org)
47933e2c0cfb127ecbfb0cc1be7eba9b@tobias.gr
merge 55405 55406
M
M
Maxime Devos wrote on 14 May 2022 11:16
Re: bug#55405: Image API produces incorrect images
(address . control@debbugs.gnu.org)
d00ae27ced4aef7096ab1403a17dab563a6d7d4c.camel@telenet.be
merge 55405 55406
thanks

(duplicate)
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYn9zXBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7k93AQC0OBNW0Oa7RseBKpPWALNCRsn0
e19BMBlLuuxTm7WOqgD8DrBHiwhTsYHDV+i+XrwkDd3Yln8VbmFw79MWhSfbAgM=
=i/Sn
-----END PGP SIGNATURE-----


?