[PATCH] gnu: recutils: Make it cross-compilable.

  • Open
  • quality assurance status badge
Details
One participant
  • Maxime Devos
Owner
unassigned
Submitted by
Maxime Devos
Severity
normal
M
M
Maxime Devos wrote on 11 May 2022 23:25
(address . guix-patches@gnu.org)
bccc99666315ff908c93a4cedb128002bfcec9cb.camel@telenet.be
TBD:

* [ ] Commit message
* [ ] Testing beyond ‘it builds’
* [ ] Proper usage of "git format-patch"
* [ ] 'guix style'
* [ ] "guix refresh --list-dependents" and such

Just sending it now such that it doesn't disappear, intend to make it a
proper patch submission later ...

Toggle diff (32 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 4472677ab3..ffadb1312b 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1569,18 +1569,17 @@ (define-public recutils
"14xiln4immfsw8isnvwvq0h23f6z0wilpgsc4qzabnrzb5lsx3nz"))))
(build-system gnu-build-system)
- (arguments '(#:configure-flags
- (list (string-append "--with-bash-headers="
- (assoc-ref %build-inputs
"bash:include")
- "/include/bash"))))
-
+ (arguments
+ (list #:configure-flags
+ #~(list (string-append "--with-bash-headers="
+ (search-input-directory %build-
inputs "/include/bash")))))
(native-inputs `(("bc" ,bc)
- ("bash:include" ,bash "include")
("check" ,check-0.14)
("pkg-config" ,pkg-config)))
;; TODO: Add more optional inputs.
- (inputs `(("curl" ,curl)
+ (inputs `(("bash:include" ,bash "include")
+ ("curl" ,curl)
("libgcrypt" ,libgcrypt)
("libuuid" ,util-linux "lib")))
(synopsis "Manipulate plain text files as databases")
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYnwp3hccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7iP2AQC2ukXXMQVhbUJXFAhqeBu+2qsZ
miHbK2RMPGHaI+8IIAD/aMNABY4nbV4Od3yZxzVwKn38NBln5G7x1VtjNnIhuwo=
=rgKO
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 12 May 2022 09:07
(address . 55377@debbugs.gnu.org)(address . control@debbugs.gnu.org)
9c0ce674d842fc9c5f8ec2895797b2d1164b08be.camel@telenet.be
tags 55377 + moreinfo
thanks

Maxime Devos schreef op wo 11-05-2022 om 23:25 [+0200]:
Toggle quote (8 lines)
> TBD:
>
>   * [ ] Commit message
>   * [ ] Testing beyond ‘it builds’
>   * [ ] Proper usage of "git format-patch"
>   * [ ] 'guix style'
>   * [ ] "guix refresh --list-dependents" and such

Needs a rebase because of
Still, a bash:include in native-inputs doesn't seem correct to me even
if it happens to work here -- e.g., what if the include headers are
architecture-dependent?

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYnyyQhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7kh0AQCRIyLFiCXNgm2nEvnEOM4q8uBv
AVcNRx/l5ruf58ZBUQEAwsAteDZQzLeMk0EbmQ5kh78fMWQ4VF5M+QT0NgzqCAk=
=+GZT
-----END PGP SIGNATURE-----


?