[PATCH] gnu: python-slixmpp: Update to 1.8.1.

  • Done
  • quality assurance status badge
Details
4 participants
  • jgart
  • Maxim Cournoyer
  • Maxime Devos
  • Vagrant Cascadian
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220326182743.23277-1-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-slixmpp): Update to 1.8.1.
[arguments]: Remove trailing boolean and use new style.
---
gnu/packages/python-xyz.scm | 19 +++++++++----------
1 file changed, 9 insertions(+), 10 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ae335cc83f..bebd931bb1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -688,7 +688,7 @@ (define-public python-mkdocs-material
(define-public python-slixmpp
(package
(name "python-slixmpp")
- (version "1.5.2")
+ (version "1.8.1")
(source
(origin
(method git-fetch)
@@ -700,17 +700,16 @@ (define-public python-slixmpp
(file-name
(git-file-name name version))
(sha256
- (base32 "15mqxcws14bjvh5jcfwl86zsvrymkdw3ya07vb44md7vfnsnclwx"))))
+ (base32 "0723m7pbyf4xnsy381drni3kr8wm60637gn6d7fbf4i5m04jy9iy"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch
- (lambda _
- (substitute* "setup.py"
- (("'CC', 'cc'")
- "'CC', 'gcc'"))
- #t)))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "setup.py"
+ (("'CC', 'cc'")
+ "'CC', 'gcc'")))))))
(native-inputs
`(("cython" ,python-cython)
("gnupg" ,gnupg)
--
2.34.0
M
M
Maxime Devos wrote on 26 Mar 2022 22:16
1d1a29f4ca78a4f3c70ddf3773d4b9d06803239f.camel@telenet.be
jgart via Guix-patches via schreef op za 26-03-2022 om 14:27 [-0400]:
Toggle quote (8 lines)
> +      (list #:phases
> +            #~(modify-phases %standard-phases
> +                (add-after 'unpack 'patch
> +                  (lambda _
> +                    (substitute* "setup.py"
> +                      (("'CC', 'cc'")
> +                       "'CC', 'gcc'")))))))

I now this was present in the original code, but this is most likely
completely broken when cross-compiling. Use cc-for-target instead.
Additionally, you can try removing input labels from 'native-inputs'.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYj+CoxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7tqcAQCN9Z/BWWaG0J8Fe1bkQzHmJAJw
9nerX5nFbk2AbPzKPwEAmCnPGbdCPi0KGIqfMBMD9yW8jd5INeDIlCPSljjGbgY=
=cd5p
-----END PGP SIGNATURE-----


J
[PATCH v2] gnu: python-slixmpp: Update to 1.8.1.
(address . 54584@debbugs.gnu.org)
20220416142609.11144-1-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-slixmpp): Update to 1.8.1.
[arguments]: Remove trailing boolean, use new style, and use
cc-for-target.
[native-inputs]: Use new style.

Hi Maxim,

Here is the second version of this patch.

I think this adds what you suggested in the code review.

thanks,

jgart

---
gnu/packages/python-xyz.scm | 25 ++++++++++++-------------
1 file changed, 12 insertions(+), 13 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 219a0d9213..1654fc2894 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -688,7 +688,7 @@ (define-public python-mkdocs-material
(define-public python-slixmpp
(package
(name "python-slixmpp")
- (version "1.5.2")
+ (version "1.8.1")
(source
(origin
(method git-fetch)
@@ -700,21 +700,20 @@ (define-public python-slixmpp
(file-name
(git-file-name name version))
(sha256
- (base32 "15mqxcws14bjvh5jcfwl86zsvrymkdw3ya07vb44md7vfnsnclwx"))))
+ (base32 "0723m7pbyf4xnsy381drni3kr8wm60637gn6d7fbf4i5m04jy9iy"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch
- (lambda _
- (substitute* "setup.py"
- (("'CC', 'cc'")
- "'CC', 'gcc'"))
- #t)))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "setup.py"
+ (((string-append "'CC', " #$(cc-for-target)))
+ ((string-append "'CC', " #$(cc-for-target))))))))))
(native-inputs
- `(("cython" ,python-cython)
- ("gnupg" ,gnupg)
- ("pkg-config" ,pkg-config)))
+ (list python-cython
+ gnupg
+ pkg-config))
(propagated-inputs
(list python-aiodns python-aiohttp python-pyasn1
python-pyasn1-modules))
--
2.35.1
M
M
Maxime Devos wrote on 16 Apr 2022 17:25
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
fe3f1ab95fb1bbb2a6e2bed73df653c822d97948.camel@telenet.be
jgart via Guix-patches via schreef op za 16-04-2022 om 10:26 [-0400]:
Toggle quote (11 lines)
> * gnu/packages/python-xyz.scm (python-slixmpp): Update to 1.8.1.
> [arguments]: Remove trailing boolean, use new style, and use
> cc-for-target.
> [native-inputs]: Use new style.
>
> Hi Maxim,
>
> Here is the second version of this patch.
>
> I think this adds what you suggested in the code review.

I haven't looked at the upstream 1.5.2->1.8.1 diff, but the CC->cc-for-
target and delabelisation LGTM.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYlrf0RccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7n3xAP9RladQA30DuXuuX5l1Piz3icQ0
TQyeoHOvTXBmSJgCIAD7B08ngsc+2wD+8+XhseNwT6IS2r6iW8SHDCY5VHczkA8=
=LCm5
-----END PGP SIGNATURE-----


M
M
Maxim Cournoyer wrote on 24 Apr 2022 05:32
Re: [PATCH v2] gnu: python-slixmpp: Update to 1.8.1.
(name . jgart)(address . jgart@dismail.de)(address . 54584@debbugs.gnu.org)
87tuaj2m1m.fsf@gmail.com
Hi jgart,

jgart <jgart@dismail.de> writes:

Toggle quote (56 lines)
> * gnu/packages/python-xyz.scm (python-slixmpp): Update to 1.8.1.
> [arguments]: Remove trailing boolean, use new style, and use
> cc-for-target.
> [native-inputs]: Use new style.
>
> Hi Maxim,
>
> Here is the second version of this patch.
>
> I think this adds what you suggested in the code review.
>
> thanks,
>
> jgart
>
> ---
> gnu/packages/python-xyz.scm | 25 ++++++++++++-------------
> 1 file changed, 12 insertions(+), 13 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 219a0d9213..1654fc2894 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -688,7 +688,7 @@ (define-public python-mkdocs-material
> (define-public python-slixmpp
> (package
> (name "python-slixmpp")
> - (version "1.5.2")
> + (version "1.8.1")
> (source
> (origin
> (method git-fetch)
> @@ -700,21 +700,20 @@ (define-public python-slixmpp
> (file-name
> (git-file-name name version))
> (sha256
> - (base32 "15mqxcws14bjvh5jcfwl86zsvrymkdw3ya07vb44md7vfnsnclwx"))))
> + (base32 "0723m7pbyf4xnsy381drni3kr8wm60637gn6d7fbf4i5m04jy9iy"))))
> (build-system python-build-system)
> (arguments
> - `(#:phases
> - (modify-phases %standard-phases
> - (add-after 'unpack 'patch
> - (lambda _
> - (substitute* "setup.py"
> - (("'CC', 'cc'")
> - "'CC', 'gcc'"))
> - #t)))))
> + (list #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'unpack 'patch
> + (lambda _
> + (substitute* "setup.py"
> + (((string-append "'CC', " #$(cc-for-target)))
> + ((string-append "'CC', " #$(cc-for-target))))))))))

This doesn't look right; the matched pattern is replaced by... the same
thing?

Toggle quote (8 lines)
> (native-inputs
> - `(("cython" ,python-cython)
> - ("gnupg" ,gnupg)
> - ("pkg-config" ,pkg-config)))
> + (list python-cython
> + gnupg
> + pkg-config))

Are you sure pkg-config is needed? That's unusual in Python packages.

Thanks,

Maxim
J
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 54584@debbugs.gnu.org)
20220424021551.GD18799@gac.attlocal.net
On Sat, 23 Apr 2022 23:32:53 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
Toggle quote (11 lines)
> > + (list #:phases
> > + #~(modify-phases %standard-phases
> > + (add-after 'unpack 'patch
> > + (lambda _
> > + (substitute* "setup.py"
> > + (((string-append "'CC', " #$(cc-for-target)))
> > + ((string-append "'CC', " #$(cc-for-target))))))))))
>
> This doesn't look right; the matched pattern is replaced by... the same
> thing?

Oh yes, that was definitely a blunder. I'll send a patch fixing that soon.

Toggle quote (11 lines)
>
> > (native-inputs
> > - `(("cython" ,python-cython)
> > - ("gnupg" ,gnupg)
> > - ("pkg-config" ,pkg-config)))
> > + (list python-cython
> > + gnupg
> > + pkg-config))
>
> Are you sure pkg-config is needed? That's unusual in Python packages.

I'll check that. That was there from the previous commit on the package.
M
M
Maxim Cournoyer wrote on 22 May 2022 07:08
Re: bug#54584: [PATCH] gnu: python-slixmpp: Update to 1.8.1.
(name . jgart)(address . jgart@dismail.de)(address . 54584@debbugs.gnu.org)
871qwm6tnf.fsf_-_@gmail.com
Hi jgart,

jgart <jgart@dismail.de> writes:

Toggle quote (14 lines)
> On Sat, 23 Apr 2022 23:32:53 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>> > + (list #:phases
>> > + #~(modify-phases %standard-phases
>> > + (add-after 'unpack 'patch
>> > + (lambda _
>> > + (substitute* "setup.py"
>> > + (((string-append "'CC', " #$(cc-for-target)))
>> > + ((string-append "'CC', " #$(cc-for-target))))))))))
>>
>> This doesn't look right; the matched pattern is replaced by... the same
>> thing?
>
> Oh yes, that was definitely a blunder. I'll send a patch fixing that soon.

Now sure if soon is now, but... ping :-)

Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 22 May 2022 07:09
control message for bug #54584
(address . control@debbugs.gnu.org)
87zgja5f27.fsf@gmail.com
tags 54584 + moreinfo
quit
J
Re: bug#54584: [PATCH] gnu: python-slixmpp: Update to 1.8.1.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 54584@debbugs.gnu.org)
20220522143533.GB9107@gac
On Sun, 22 May 2022 01:08:52 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
Toggle quote (20 lines)
> Hi jgart,
>
> jgart <jgart@dismail.de> writes:
>
> > On Sat, 23 Apr 2022 23:32:53 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
> >> > + (list #:phases
> >> > + #~(modify-phases %standard-phases
> >> > + (add-after 'unpack 'patch
> >> > + (lambda _
> >> > + (substitute* "setup.py"
> >> > + (((string-append "'CC', " #$(cc-for-target)))
> >> > + ((string-append "'CC', " #$(cc-for-target))))))))))
> >>
> >> This doesn't look right; the matched pattern is replaced by... the same
> >> thing?
> >
> > Oh yes, that was definitely a blunder. I'll send a patch fixing that soon.
>
> Now sure if soon is now, but... ping :-)

Sorry, I probably won't be able to get to this for atleast another week.

I'll let you know sooner if that changes otherwise feel free to fix it and add yourself as author to push this through.

all best,

jgart
V
V
Vagrant Cascadian wrote on 2 Sep 2023 01:41
Re: [bug#54584] [PATCH] gnu: python-slixmpp: Update to 1.8.1.
87fs3xqx51.fsf@wireframe
On 2022-03-26, jgart wrote:
Toggle quote (3 lines)
> * gnu/packages/python-xyz.scm (python-slixmpp): Update to 1.8.1.
> [arguments]: Remove trailing boolean and use new style.

This was updated to a newer version in:

3b57f25f55c52c97428106de285d3cf2746554dc gnu: python-slixmpp: Update to 1.8.3.

Marking as done.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPJ2ugAKCRDcUY/If5cW
qv50AP92kr+uTYu23k3kKR6cBLTt8vOJnlST7ZHaohqNVS9ZyAEAzdancjarN/wY
SCzsAbqe4UEbOr/2wE87MtLwDt1srwE=
=u3C5
-----END PGP SIGNATURE-----

Closed
?