[PATCH] gnu: Add rofi-wayland.

  • Done
  • quality assurance status badge
Details
4 participants
  • Andrew Tropin
  • Ludovic Courtès
  • Xinglu Chen
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Andrew Tropin
Severity
normal
A
A
Andrew Tropin wrote on 1 Feb 2022 09:40
(address . guix-patches@gnu.org)
878rutss0n.fsf@trop.in
Tested on sway session.

* gnu/packages/xdisorg.scm (rofi-wayland): New variable.
---
gnu/packages/xdisorg.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index ec995c3496..c2bd1d1d5c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -53,6 +53,7 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1742,6 +1743,40 @@ (define-public rofi
by name.")
(license license:expat)))
+(define-public rofi-wayland
+ (package
+ (inherit rofi)
+ (name "rofi-wayland")
+ (version "1.7.2+wayland1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lbonn/rofi"
+ "/releases/download/"
+ version "/rofi-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1smrxjq693z48c7n5pcfrvb0m0vsn6pxn7qpn8bm68j942n8rg3x"))))
+ (build-system meson-build-system)
+ (arguments
+ (substitute-keyword-arguments (package-arguments rofi)
+ ((#:configure-flags flags '())
+ #~(list "-Dxcb=disabled"))))
+ (inputs
+ (list cairo
+ glib
+ libjpeg-turbo
+ librsvg
+ libxkbcommon
+ wayland
+ wayland-protocols
+ pango
+ startup-notification))
+ (description "Rofi is a minimalist application launcher. It memorizes which
+applications you regularly use and also allows you to search for an application
+by name.
+
+This is a fork with added support for Wayland via layer shell protocol.")))
+
(define-public rofi-calc
(package
(name "rofi-calc")
--
2.34.0
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmH6JCkPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6w1ngP/jbw0rES6pKmxpqYhUkyUgihmk0qXFETCONv
iijR4J9WVWhrF2W3IstAPbR8RniW20ECGgkpzonoT7Jbw90D6Z56S2+++/WTvvHO
RJ4DYlIVgmONutfopNvvmmNqI8FVIjI3CLJFWjUECyzdUY5tgU2L3UGhPUhD8QFL
aZO9yW7NV07VDrzIaTDlApsGrRGWmo/0WTVpPIuTwlt/f9hdyeMHhYXq6K+V/KxV
ikVsjrMEMwg9HydjD5mQfmBHeE2Jk6zOJ6CbRQG4KFMdnTVx4cZaahqxfacSVTHB
pyN+lJ4+oKZWT9lYc8871L8/8gceRJ7Y6UtrDzRxF0SJPaRE324HHaKC52KxJCSP
yVkvidU1o8JWVZ/3sHOD+ORGKM6KWnMx4uWI9q5Ye/uOw8Ltz8HBFInZYwgQA7IK
ZsuRHt2xTrGbnrwyoSNP1aOYLH0BaGeXEQDMMOlaLrxoXwdhQrM7sXZKk3PLSZ2v
dc74SyQPLksqQSJ6uObjB1O5VI4W2VRZkez8UAKMyiAyrflOdNa2hNemjtFD+bjr
1BEZWl9w33kRkaos6eCBDx2fA6Baa/lqmY1PYa1HCaRl72cunQIJ/nFXJ/SDZK3O
lAvp8xVj0krMVJVsQSwVj8lCI6zi3n+Dbg2l7DIG1rtsCzJ5Ot8hgMj26O5w0Lh3
8ouFHc1G
=3Bqk
-----END PGP SIGNATURE-----

X
X
Xinglu Chen wrote on 10 Feb 2022 17:20
87fsoqwv64.fsf@yoctocell.xyz
Andrew schrieb am Dienstag der 01. Februar 2022 um 11:40 +03:

Toggle quote (29 lines)
> Tested on sway session.
>
> * gnu/packages/xdisorg.scm (rofi-wayland): New variable.
> ---
> gnu/packages/xdisorg.scm | 35 +++++++++++++++++++++++++++++++++++
> 1 file changed, 35 insertions(+)
>
> diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
> index ec995c3496..c2bd1d1d5c 100644
> --- a/gnu/packages/xdisorg.scm
> +++ b/gnu/packages/xdisorg.scm
> @@ -53,6 +53,7 @@
> ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
> ;;; Copyright © 2021 jgart <jgart@dismail.de>
> ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
> +;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -1742,6 +1743,40 @@ (define-public rofi
> by name.")
> (license license:expat)))
>
> +(define-public rofi-wayland
> + (package
> + (inherit rofi)
> + (name "rofi-wayland")
> + (version "1.7.2+wayland1")

We usually strip away prefixes and suffixes. FWIW, version 1.7.3 seems
to be available as well.

Toggle quote (29 lines)
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/lbonn/rofi"
> + "/releases/download/"
> + version "/rofi-" version ".tar.xz"))
> + (sha256
> + (base32
> + "1smrxjq693z48c7n5pcfrvb0m0vsn6pxn7qpn8bm68j942n8rg3x"))))
> + (build-system meson-build-system)
> + (arguments
> + (substitute-keyword-arguments (package-arguments rofi)
> + ((#:configure-flags flags '())
> + #~(list "-Dxcb=disabled"))))
> + (inputs
> + (list cairo
> + glib
> + libjpeg-turbo
> + librsvg
> + libxkbcommon
> + wayland
> + wayland-protocols
> + pango
> + startup-notification))
> + (description "Rofi is a minimalist application launcher. It memorizes which
> +applications you regularly use and also allows you to search for an application
> +by name.
> +
> +This is a fork with added support for Wayland via layer shell protocol.")))

The home-page should also be changed to point to the fork.

Otherwise, LGTM!
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmIFOzMVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x52kUP/0GiOHY+di6ORpqdW/iGtoms5OLh
+s0CJlQxpH7v3PQZgNxQK9e3qYugIa1icAZvg3P+jnZ8biiCqH/aF3EU5VIco4Dy
Y79hxMhxQPoNRzuzW6TkUzKIV34a+ulnlAdo6sg66zIHt0oEts8+3qDlZymZJolP
E3M15XSKSPndQtrcROQAet8sLxF5JF2gbHrUGMhGt3VasRZdmjmwdQ9qIa9Ekqgu
wTAUNr21DRFRJL9/7LKwRwKV9PfXas2PVP2FSY3sHGF9HsuV6wLBPsSSv7s2Myzu
uZiBqqgTQPYJqLsT8pg567psIPqmdkzJDC0KlGJlaBf/9Mzf5ACC+qGewFv+6/1U
Ke4JBFKaFSoH2EXdzu742TDwzI5Rk5XYKc/7gaB8MS+2L6jL5CBKVldnlWmRjY8G
2SthFnjj2jmiqSf3TrVBuvsbU2YCwlUYSlhvnQHTBbOveBnaLmrMvCE/Vva/L/RC
7yAmfotEFtsVwOm/d+julGQ09dDKu9Gki4LsYB9tKnOlKjXDQ7QQq0RMkiY5g3Zv
cm01Q2cL4sUG8KNj4AFDzTe8jzRg7NBACNBGZMU4sBqRmvB1t5yicwTnOfFu6ChR
lu6oZ37FKRubYxIlTXu1yk09GBZ+5yoESqUN1Aq49dPR5BzHldDilHm/8n7rcpUn
yio2Ia/cpNVHyHZv
=BZDq
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 14 Feb 2022 15:43
control message for bug #53717
(address . control@debbugs.gnu.org)
874k51y0dt.fsf@gnu.org
tags 53717 + moreinfo
quit
A
A
Andrew Tropin wrote on 26 Feb 2022 08:56
Re: [bug#53717] [PATCH] gnu: Add rofi-wayland.
87czjadpsp.fsf@trop.in
On 2022-02-10 17:20, Xinglu Chen wrote:

Toggle quote (34 lines)
> Andrew schrieb am Dienstag der 01. Februar 2022 um 11:40 +03:
>
>> Tested on sway session.
>>
>> * gnu/packages/xdisorg.scm (rofi-wayland): New variable.
>> ---
>> gnu/packages/xdisorg.scm | 35 +++++++++++++++++++++++++++++++++++
>> 1 file changed, 35 insertions(+)
>>
>> diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
>> index ec995c3496..c2bd1d1d5c 100644
>> --- a/gnu/packages/xdisorg.scm
>> +++ b/gnu/packages/xdisorg.scm
>> @@ -53,6 +53,7 @@
>> ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
>> ;;; Copyright © 2021 jgart <jgart@dismail.de>
>> ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
>> +;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
>> ;;;
>> ;;; This file is part of GNU Guix.
>> ;;;
>> @@ -1742,6 +1743,40 @@ (define-public rofi
>> by name.")
>> (license license:expat)))
>>
>> +(define-public rofi-wayland
>> + (package
>> + (inherit rofi)
>> + (name "rofi-wayland")
>> + (version "1.7.2+wayland1")
>
> We usually strip away prefixes and suffixes. FWIW, version 1.7.3 seems
> to be available as well.

AFAIU, it's a part of a version, it can potentially be +wayland2,
+wayland3 if it will be necessary to make another intermediate release,
which is related to wayland/wlroots changes, while upstream version
still the same (1.7.3 for example).

Toggle quote (33 lines)
>> + (source (origin
>> + (method url-fetch)
>> + (uri (string-append "https://github.com/lbonn/rofi"
>> + "/releases/download/"
>> + version "/rofi-" version ".tar.xz"))
>> + (sha256
>> + (base32
>> + "1smrxjq693z48c7n5pcfrvb0m0vsn6pxn7qpn8bm68j942n8rg3x"))))
>> + (build-system meson-build-system)
>> + (arguments
>> + (substitute-keyword-arguments (package-arguments rofi)
>> + ((#:configure-flags flags '())
>> + #~(list "-Dxcb=disabled"))))
>> + (inputs
>> + (list cairo
>> + glib
>> + libjpeg-turbo
>> + librsvg
>> + libxkbcommon
>> + wayland
>> + wayland-protocols
>> + pango
>> + startup-notification))
>> + (description "Rofi is a minimalist application launcher. It memorizes which
>> +applications you regularly use and also allows you to search for an application
>> +by name.
>> +
>> +This is a fork with added support for Wayland via layer shell protocol.")))
>
> The home-page should also be changed to point to the fork.
>
> Otherwise, LGTM!

Thank you for the pointing out, updated version, home-page.
From f470b6f6a6b4ec1ef789a302af3ee98d562462d8 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Tue, 1 Feb 2022 11:40:08 +0300
Subject: [PATCH] gnu: Add rofi-wayland.

Tested on sway session.

* gnu/packages/xdisorg.scm (rofi-wayland): New variable.
---
gnu/packages/xdisorg.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 42452d0721..c43a5fbd44 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1743,6 +1744,41 @@ (define-public rofi
by name.")
(license license:expat)))
+(define-public rofi-wayland
+ (package
+ (inherit rofi)
+ (name "rofi-wayland")
+ (version "1.7.3+wayland1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lbonn/rofi"
+ "/releases/download/"
+ version "/rofi-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1gfs13zfqg9f4prx8yylxvv93yr6j74nmhlm3wabr6jljbbr7jc8"))))
+ (build-system meson-build-system)
+ (arguments
+ (substitute-keyword-arguments (package-arguments rofi)
+ ((#:configure-flags flags '())
+ #~(list "-Dxcb=disabled"))))
+ (inputs
+ (list cairo
+ glib
+ libjpeg-turbo
+ librsvg
+ libxkbcommon
+ wayland
+ wayland-protocols
+ pango
+ startup-notification))
+ (home-page "https://github.com/lbonn/rofi")
+ (description "Rofi is a minimalist application launcher. It memorizes which
+applications you regularly use and also allows you to search for an application
+by name.
+
+This is a fork with added support for Wayland via layer shell protocol.")))
+
(define-public rofi-calc
(package
(name "rofi-calc")
--
2.34.0
--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmIZ3SYPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wpscP/1Vo/Kh8BlU8q0gHfp55mXp7iHOL0q4/earv
/WYYqOg7SQ8AlACTkTb7v6uSMWyUTit+QoxJ2dMvJETYmng2MGPBDoLgExCyU6Da
fFJ5nP3X3lQXwrq/65IN369dV9mYZ0oPnfMDikMpJ9ze2O6LUgz7aNqbvkp8/WcU
mbJecgQhmAZPaytGa/K7KLMRcHIBvKGAtlpSL9lFZ/0WSCdGtH1yEkJnXD01NKTB
p5UkBJAZk215AKImdcgLb+v81nVTSL+i5070wmRqgm6VNbh0vkmGarwEu8JASv+G
tE7I4FYP0scY4Os/+xOKWpjOmx96Jj/eii+9T84tmuEfxg3fLxcOJ3SXGSocNDUa
n0Te5zOAcudjbQ/m+J8Nr6CxW9dqm547JTARveQKJceX2w0UkyeDNKUTCAnDJ9oU
AkTZ4wM4uzy1WITP8AW+G+5Ci2SuT0JgTcpuAc0G0x0ac4qhICBIa0gyt5wiokIs
nvpdQlU4S1/2RRwMec73gm8QH3oxB1srXlUbbbBhMLu4YsiWCgebX8Dmr+GEtkR0
oaUZE7dwi/SrtdCL266vvAwZuz2Cuzd744lyS4Q/EgFKBb/Ig+HnCU4UvJxrGcY4
PWYxTt88YLsvZSSGqCk8JOJC6pYSuhaKQ7qHnVNegQVoeqjCIo3BBpd23updx/GA
xv1wsG76
=S03H
-----END PGP SIGNATURE-----

A
A
Andrew Tropin wrote on 18 Apr 2022 10:26
[PATCH v2] gnu: Add rofi-wayland.
(address . guix-patches@gnu.org)
87fsma23w6.fsf@trop.in
* gnu/packages/xdisorg.scm (rofi-wayland): New variable.
---
Tested on sway session.

gnu/packages/xdisorg.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d2caee85ec..3ba79e178b 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1742,6 +1743,41 @@ (define-public rofi
by name.")
(license license:expat)))
+(define-public rofi-wayland
+ (package
+ (inherit rofi)
+ (name "rofi-wayland")
+ (version "1.7.3+wayland1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lbonn/rofi"
+ "/releases/download/"
+ version "/rofi-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1gfs13zfqg9f4prx8yylxvv93yr6j74nmhlm3wabr6jljbbr7jc8"))))
+ (build-system meson-build-system)
+ (arguments
+ (substitute-keyword-arguments (package-arguments rofi)
+ ((#:configure-flags flags '())
+ #~(list "-Dxcb=disabled"))))
+ (inputs
+ (list cairo
+ glib
+ libjpeg-turbo
+ librsvg
+ libxkbcommon
+ wayland
+ wayland-protocols
+ pango
+ startup-notification))
+ (home-page "https://github.com/lbonn/rofi")
+ (description "Rofi is a minimalist application launcher. It memorizes which
+applications you regularly use and also allows you to search for an application
+by name.
+
+This is a fork with added support for Wayland via layer shell protocol.")))
+
(define-public rofi-calc
(package
(name "rofi-calc")
--
2.35.1
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmJdIMoPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6w7FgP/RqtZNEyvrNfvEdFszDMnLb21nSUoijnmARW
nvOAPrbawyZTjg5mnypB58Msd+UxA6+cLZ1Z6vKP0+a3Hr8CFCNqQ72x76uWTi3f
kVSTyq4pAV1DDqpjPNESvgZ6S0fCi+r4w3kB4hPQ/oA2QQFO1LSNui/TIFTokFB4
LKohy/rNO+Kdi7uC9A1m+zy0FqqCehXNMh4+KVN2U1TqReuVDnpK9dgJv5Jq3pmH
JEu1I6zovYYfgZk5AbghKofL1uBziBXzwIsfq4Ds6pupDbbfELbwZA9ycHj8XJ0U
+p1QcxapZTutRrfodE3ePFQ3DcfL7zcEiV7zyMyfEbdnM3awQ09Tb/V37Pp6+aUr
IWJYFU/D8EqdAZ8jitllyvqdLQMqRpklLCCYHYZDdDr7w88pXzcYw2/zIzKOwfaf
w7z7nJcOsE02QeELAUQ8s50gtKK3fGpFDSiC6/ysbon32JKgD72q746UPnCJGmEC
NZWE7Ngm5nNhMe7NwhJDNzazpTHhq2zW1FbkXf38DkmRxK/qO/olXeIcFc7bXXzO
yMzC9XXQ/qX9aY81zaLZlGzIchuuL85jdHzL2zoF6DIqTazFl4I9mqqD+xD+PjC8
8fyDgck5JO0W9zriARVSbCLUI6QrB9nPvcn83IuQ+f6832l1C/GlCFR8yUmp/Kbk
PjBTrWOK
=7Xq/
-----END PGP SIGNATURE-----

A
A
Andrew Tropin wrote on 4 Aug 2022 13:50
Re: [PATCH] gnu: Add rofi-wayland.
(address . guix-patches@gnu.org)
877d3okz2f.fsf@trop.in
Just a gentle reminder.

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmLrsngACgkQIgjSCVjB
3rCUWQ/7BTtSQgsl4+RkMB7otx/9cxE+ye1PG8NrcUpcPcelZB8QhbPpXx9467kj
FgGondB5mVKahlD+z6mtY2KyO08vKjPcGrCAUTeXN42tFx/Vh82c0ttKKuIlCccp
SNmA4iHMXJC4VtVajIxQyx/d49RhCE+cjilR5o7CTbVeuzulDYtqmRFTVk1uM3QI
9r+0FweyxU8unqhsssxZhmNCQx0K4ijaVibhNIxrDNvAPSezqHXZErFhVnbSYu9S
Z9c/ke94rE6GnKQDIpo2HaQNP1z74sonGB75s8XiSYJEaYs3uy2x1R8wf7Ayh8gw
bJiidkpM7Hfq5SSZVOmuRhxki8KpH6XfVYZ4Y+Q1P0GiQl17BUAYzJmIfK2nMZ4m
cyyoQtxFBm+z0hGErLo/0DXVd4bt5E8x5rwePjiYAm9QWdQbINeSgvPh5IRsoUEp
uNpZz4RWRaMpU05cRny3soSOqjCC5mhIuBDPyRHlIIGMBuPUVtzCS/RIJE48gdmG
JxuoPQM4Og2ivE2XL183egmpabFc9kmsPzasabHGWVHWLic8oTZkHdPIy8IgP2ir
6ZUBiJKb/YVBBEjdOVERm71LHlNy1wJxefaFrdzTC0Uy0/CmZzUaHm0gR3xSJjl6
n8BqAagnCRi1dqNvz73kyNs+0ADlOEd7J5PN/8pNS3YStePrl6A=
=DzF5
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 2 Sep 2023 00:28
Re: [bug#53717] [PATCH] gnu: Add rofi-wayland.
87zg25r0id.fsf@wireframe
On 2022-02-01, Andrew Tropin wrote:
Toggle quote (2 lines)
> * gnu/packages/xdisorg.scm (rofi-wayland): New variable.

rofi-wayland was added in:

04b5450ad852735dfa50961d3afc789b2e52b407 gnu: Add rofi-wayland.

And updated to a newer version in:

19c042ddf80533ba7a615b424dedf9647ca65b0f gnu: rofi-wayland: Update to 1.7.5+wayland2.

Marking as done.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPJlqwAKCRDcUY/If5cW
qhmnAP9KY321hcAa19dVGOGfVtN1gljmoIy3npfzLGAUZSfXWQD/bt/cax307oYf
3pQIvNDQ8IlAQXK8MZuWd0lP26b6qQw=
=FZdk
-----END PGP SIGNATURE-----

Closed
?