[PATCH] gnu: networking: Add arp-scan

  • Done
  • quality assurance status badge
Details
5 participants
  • Leo Famulari
  • Ludovic Courtès
  • Christopher Baines
  • manolis837
  • (
Owner
unassigned
Submitted by
manolis837
Severity
normal
M
M
manolis837 wrote on 4 Jan 2022 16:34
(address . guix-patches@gnu.org)(name . Manolis Ragkousis)(address . manolis837@gmail.com)
20220104153415.5822-1-manolis837@gmail.com
From: Manolis Ragkousis <manolis837@gmail.com>

* gnu/packages/networking.scm (arp-scan): New variable.
---
gnu/packages/networking.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index cc9cc61164..ac67d58541 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2021 Milkey Mouse <milkeymouse@meme.institute>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4143,3 +4144,32 @@ (define-public putty
implementations.")
(home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
(license license:expat)))
+
+(define-public arp-scan
+ (package
+ (name "arp-scan")
+ (version "1.9.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/royhills/arp-scan/"
+ "archive/refs/tags/" version ".tar.gz"))
+ (sha256
+ (base32 "0ff0c43rw1b4cm52rx7s6q0wsix3ahjjfhd8wk85nr9wjgj3cg70"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "autoreconf" "-vfi"))))))
+ (inputs
+ (list libpcap))
+ (native-inputs
+ (list autoconf automake libtool pkg-config))
+ (propagated-inputs
+ (list perl-libwww))
+ (home-page "https://github.com/royhills/arp-scan")
+ (synopsis "Dscover and fingerprint IP hosts on the local network using ARP")
+ (description "A tool that uses ARP to discover and fingerprint IP hosts on the local network")
+ (license license:gpl3)))
--
2.33.1
M
M
Manolis Ragkousis wrote on 4 Jan 2022 16:40
(address . 53007@debbugs.gnu.org)
CAFtzXzPqBgCzNmpN1iJo+_Q+4QfqdpHAB6kCLFrSV8hkAosRFw@mail.gmail.com
This is the correct version. :)

On Tue, 4 Jan 2022, 17:34 , <manolis837@gmail.com> wrote:

Toggle quote (58 lines)
> From: Manolis Ragkousis <manolis837@gmail.com>
>
> * gnu/packages/networking.scm (arp-scan): New variable.
> ---
> gnu/packages/networking.scm | 30 ++++++++++++++++++++++++++++++
> 1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> index cc9cc61164..ac67d58541 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -47,6 +47,7 @@
> ;;; Copyright © 2021 Milkey Mouse <milkeymouse@meme.institute>
> ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
> ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
> +;;; Copyright © 2022 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -4143,3 +4144,32 @@ (define-public putty
> implementations.")
> (home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
> (license license:expat)))
> +
> +(define-public arp-scan
> + (package
> + (name "arp-scan")
> + (version "1.9.7")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/royhills/arp-scan/"
> + "archive/refs/tags/" version ".tar.gz"))
> + (sha256
> + (base32 "0ff0c43rw1b4cm52rx7s6q0wsix3ahjjfhd8wk85nr9wjgj3cg70"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (replace 'bootstrap
> + (lambda _
> + (invoke "autoreconf" "-vfi"))))))
> + (inputs
> + (list libpcap))
> + (native-inputs
> + (list autoconf automake libtool pkg-config))
> + (propagated-inputs
> + (list perl-libwww))
> + (home-page "https://github.com/royhills/arp-scan")
> + (synopsis "Dscover and fingerprint IP hosts on the local network
> using ARP")
> + (description "A tool that uses ARP to discover and fingerprint IP
> hosts on the local network")
> + (license license:gpl3)))
> --
> 2.33.1
>
>
Attachment: file
M
M
Manolis Ragkousis wrote on 6 Jan 2022 12:18
(address . 53007@debbugs.gnu.org)
6c99e8de-fdcf-1068-167b-1e3f53e7b357@gmail.com
Did anyone have some time to check this?

On 1/4/22 17:40, Manolis Ragkousis wrote:
Toggle quote (71 lines)
> This is the correct version. :)
>
> On Tue, 4 Jan 2022, 17:34 , <manolis837@gmail.com
> <mailto:manolis837@gmail.com>> wrote:
>
> From: Manolis Ragkousis <manolis837@gmail.com
> <mailto:manolis837@gmail.com>>
>
> * gnu/packages/networking.scm (arp-scan): New variable.
> ---
>  gnu/packages/networking.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> index cc9cc61164..ac67d58541 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -47,6 +47,7 @@
>  ;;; Copyright © 2021 Milkey Mouse <milkeymouse@meme.institute>
>  ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net
> <mailto:glv@posteo.net>>
>  ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be
> <mailto:maximedevos@telenet.be>>
> +;;; Copyright © 2022 Manolis Fragkiskos Ragkousis
> <manolis837@gmail.com <mailto:manolis837@gmail.com>>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -4143,3 +4144,32 @@ (define-public putty
>  implementations.")
>      (home-page
> "https://www.chiark.greenend.org.uk/~sgtatham/putty/
> <https://www.chiark.greenend.org.uk/~sgtatham/putty/>")
>      (license license:expat)))
> +
> +(define-public arp-scan
> +  (package
> +    (name "arp-scan")
> +    (version "1.9.7")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://github.com/royhills/arp-scan/
> <https://github.com/royhills/arp-scan/>"
> +                           "archive/refs/tags/" version ".tar.gz"))
> +       (sha256
> +        (base32
> "0ff0c43rw1b4cm52rx7s6q0wsix3ahjjfhd8wk85nr9wjgj3cg70"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (replace 'bootstrap
> +           (lambda _
> +             (invoke "autoreconf" "-vfi"))))))
> +    (inputs
> +     (list libpcap))
> +    (native-inputs
> +     (list autoconf automake libtool pkg-config))
> +    (propagated-inputs
> +     (list perl-libwww))
> +    (home-page "https://github.com/royhills/arp-scan
> <https://github.com/royhills/arp-scan>")
> +    (synopsis "Dscover and fingerprint IP hosts on the local
> network using ARP")
> +    (description "A tool that uses ARP to discover and fingerprint
> IP hosts on the local network")
> +    (license license:gpl3)))
> --
> 2.33.1
>
L
L
Leo Famulari wrote on 11 Jan 2022 19:54
Re: [bug#53007] [PATCH] gnu: networking: Add arp-scan
(address . manolis837@gmail.com)(address . 53007@debbugs.gnu.org)
Yd3SWhI6FAeuNd1y@jasmine.lan
Thanks for the patch!

On Tue, Jan 04, 2022 at 05:34:15PM +0200, manolis837@gmail.com wrote:
Toggle quote (7 lines)
> + (version "1.9.7")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/royhills/arp-scan/"
> + "archive/refs/tags/" version ".tar.gz"))

This type of tarball is automatically generated by Git / Github based on
the Git tag. However, whenever Github updates their software, the
generated tarballs may change, invalidating our hash. [0]

For that reason, we either use tarballs created by the upstream
developers, or the git-fetch method. For this program, the developers
stopped making tarballs after version 1.9, so we have to use git-fetch
to package 1.9.7.

Toggle quote (8 lines)
> + (build-system gnu-build-system)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (replace 'bootstrap
> + (lambda _
> + (invoke "autoreconf" "-vfi"))))))

The bootstrap phase of gnu-build-system runs autoreconf when 'configure'
is missing. I'm guessing this package was written before
gnu-build-system learned to do that, because the package does build
successfully without this replacement.

Toggle quote (8 lines)
> + (inputs
> + (list libpcap))
> + (native-inputs
> + (list autoconf automake libtool pkg-config))
> + (propagated-inputs
> + (list perl-libwww))
> + (home-page "https://github.com/royhills/arp-scan")
> + (synopsis "Dscover and fingerprint IP hosts on the local network using ARP")
^
Typo here --------|

Toggle quote (2 lines)
> + (description "A tool that uses ARP to discover and fingerprint IP hosts on the local network")

Descriptions should be written in "complete" sentences. How about the
following?

"Arp-scan is a tool that uses ARP to discover and fingerprint IP hosts
on the local network."

Toggle quote (2 lines)
> + (license license:gpl3)))

The source headers of 'arp-scan.c' say that the program can be
distributed "either version 3 of the License, or (at your option) any
later version." So I think it's gpl3+.

Can you send a revised patch?

L
L
Ludovic Courtès wrote on 17 Jan 2022 19:05
control message for bug #53007
(address . control@debbugs.gnu.org)
87o84akzl5.fsf@gnu.org
tags 53007 + moreinfo
quit
M
M
manolis837 wrote on 20 Jun 2022 23:41
[PATCH] gnu: networking: Add arp-scan
(address . 53007@debbugs.gnu.org)(name . Manolis Ragkousis)(address . manolis837@gmail.com)
20220620214129.11815-1-manolis837@gmail.com
From: Manolis Ragkousis <manolis837@gmail.com>

* gnu/packages/networking.scm (arp-scan): New variable.
---
gnu/packages/networking.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 065a190321..cb384f23bb 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 Simon South <simon@simonsouth.net>
;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4259,3 +4260,31 @@ (define-public putty
implementations.")
(home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
(license license:expat)))
+
+(define-public arp-scan
+ (package
+ (name "arp-scan")
+ (version "1.9.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/royhills/arp-scan/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mf7a4f9vzvnkiavc87aqyciswggsb4fpy7j05jxnvjyyxv3l7gp"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list libpcap))
+ (native-inputs
+ (list autoconf automake libtool pkg-config))
+ (propagated-inputs
+ (list perl-libwww))
+ (home-page "https://github.com/royhills/arp-scan")
+ (synopsis "Discover and fingerprint IP hosts on the local network
+ using ARP")
+ (description "Arp-scan is a tool that uses ARP to discover and fingerprint IP hosts
+on the local network.")
+ (license license:gpl3+)))
--
2.33.1
C
C
Christopher Baines wrote on 21 Jun 2022 13:41
(address . manolis837@gmail.com)(address . 53007-done@debbugs.gnu.org)
87r13i1bw6.fsf@cbaines.net
manolis837@gmail.com writes:

Toggle quote (7 lines)
> From: Manolis Ragkousis <manolis837@gmail.com>
>
> * gnu/packages/networking.scm (arp-scan): New variable.
> ---
> gnu/packages/networking.scm | 29 +++++++++++++++++++++++++++++
> 1 file changed, 29 insertions(+)

I moved this new package off the bottom of the file, and pushed this as
0fe0c739f53bbb635eb5c4a3b172f4be45293c82.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmKxrolfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xfhpg//cSYIYWu8Wkip3FOmjjZsfhYMEkdd3Rcl
9zvOz3EscQGQvbb+Pk658IWxGaBbOzECYG2j2QSsKINlBtckjOWTZ2Agbn8/ezDT
rcEWCEDb/+g90oyRulBdJfVqq9jMsQh23qcDGRQUye9VNKPJQiBlCb8QC/bUjvyz
uG8JscBPs33IVpOoRCPb4flCms17fdjUwERyR7roxiXrh/458UJ051IubcOuY9wG
YQGRKi1XG00xB8J5ywkDm1zfYljs5N+7pGp6ReRTWnxhR8EvkJcTeghjgAyy9j//
OPzaZDz3mnFwAD48AzMXgivVNgPcLtv2zTSbq/HFsXfR4WAfhPaxMgaExgr6FiH7
6j2izZpNEWnyGUO6zw5B96meanPZrfcYh/RWYRsHGgIDm/CEQRfLr+CDGnkZAcT0
YtMEpKtsIZON8Pbc2bw/BOyx8eZ36MourQni0ZwzIC9hmJYi7ZNKqsVmDgpBCZiM
Bd1HPtovWHl2NOAyTopk78vfVDkJjhMOAphA/HYAqfO5onjGqnAZ6s/1NfOChphk
3PyjzLuvEyszlDvOi7wu/wp8Id/NoAHwg9P8owR6VeyvR1Tk5W/wxdU/6q41VdHk
eVgRNBvq2mzin16S7UJTQLNW/TXZN4pRa9iQA3SciB/xIAxZgMaZMbZc3nTaMsbf
LCtcOjuOXRE=
=PQl2
-----END PGP SIGNATURE-----

Closed
(
CKZ5E5FCEE5C.2V3M2XVVLIM61@guix-aspire
LGTM. I was going to raise the point that 1.9.7 was in 2019, and the
latest commit at the time of writing was made on 2022-06-16, but it
looks like there's not been too many commits between 7f88dc0 "Increment
version to 1.9.7 in preparation for next release." and 840373f "Updated
changelog and IEEE IAB and OUI files."

-- (
?