[PATCH 1/2] gnu: Add python-pyphotonfile.

  • Open
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 3 Oct 2021 09:41
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
wWL2JJwgAO2nHCWccvc6EdD_PbUvZYevHcUC9W6DZijZ2zf1x4GTxMR9PFFcEWDRSUONBwqotcUdBMvCJ3MxpfPEXFAJtGCz9jWQPOKchgE=@protonmail.com
* gnu/packages/python-xyz.scm (python-pyphotonfile): New variable.

Toggle diff (36 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 14f5fdef54..5f4df4c7fb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23237,6 +23237,31 @@ qvarious formats: PDF, PostScript, PNG and even SVG.")
existing Hunspell hyphenation dictionaries.")
(license (list license:gpl2 license:lgpl2.1 license:mpl1.1))))

+(define-public python-pyphotonfile
+ (package
+ (name "python-pyphotonfile")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fookatchu/pyphotonfile")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hh1fcn7q3kyk2413pjs18xnxvzrchrisbpj2cd59jrdp0qzgv2s"))))
+ (build-system python-build-system)
+ (inputs `(("python-numpy" ,python-numpy)
+ ("python-pillow" ,python-pillow)))
+ (home-page "https://github.com/fookatchu/pyphotonfile")
+ (synopsis "Library for Anycubic Photon 3D-Printer")
+ (description "This package provides library used for manipulating Photon-
+and cbddlp-files created for the Anycubic Photon 3D-Printer and compatibles
+(e.g. Elegoo Mars, etc.). Currently it supports removing and adding new
+layers as well as changing global parameters like the exposure time, etc.")
+ (license license:gpl3)))
+
(define-public python-intelhex
(package
(name "python-intelhex")
--
2.32.0
P
P
phodina wrote on 3 Oct 2021 09:43
[PATCH 2/2] gnu: Add python-sl1tophoton.
(name . 50987@debbugs.gnu.org)(address . 50987@debbugs.gnu.org)
4Ru7g6bih3h2SgDG2izfiqmCEcySJ3xMOcvEtcn7fGoeBhTPYjYvgW8wnK77o7nrGnaILCrMu949HnZwEpEmGsw0UWtmOCHIlYFMJA0OIkg=@protonmail.com
* gnu/packages/python-xyz.scm (python-sl1tophoton): New variable.

Toggle diff (48 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5f4df4c7fb..0c56c61946 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -547,6 +547,43 @@ Markdown. All extensions are found under the module namespace of pymdownx.")
generator MkDocs.")
(license license:expat)))

+(define-public python-sl1tophoton
+ (package
+ (name "python-sl1tophoton")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fookatchu/SL1toPhoton")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hmb74rcky3nax4lxn7pw6lcd5a66fdbwrm11c84zb31xb51bakw"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-binary
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (mkdir-p bin)
+ (install-file "SL1_to_Photon_gui.py" bin)
+ (install-file "SL1_to_Photon.py" bin)
+ (chmod (string-append bin "/SL1_to_Photon_gui.py") #o555)
+ (chmod (string-append bin "/SL1_to_Photon.py") #o555)))))))
+ (inputs `(("python-pyphotonfile", python-pyphotonfile)
+ ("python-numpy" ,python-numpy)
+ ("python-pyside-2" ,python-pyside-2)
+ ("python-pillow" ,python-pillow)))
+ (home-page "https://github.com/fookatchu/SL1toPhoton")
+ (synopsis "Converter for SL1 to Photon files")
+ (description "SL1toPhoton is a tool for converting PrusaSlicer's SL1 files
+to Photon files for the Anycubic Photon 3D-Printer. Other cbddlp-files should
+also work (e.G. Elegoo Mars).")
+ (license license:gpl3)))
+
(define-public python-slixmpp
(package
(name "python-slixmpp")
--
2.32.0
P
P
phodina wrote on 3 Oct 2021 09:48
(name . 50987@debbugs.gnu.org)(address . 50987@debbugs.gnu.org)
D0_dyXueQuCOKYukS0rrfgN0czIHYVwBYqDMHwsdG6Pq4puk7lmDSahJJHSqYewEB7v63AIe9JnUJqk8zvKLxzm6Eq9sFxakgRft2YLafdQ=@protonmail.com
Hi Guix,

these patches allow users to use Prusa Slicer to slice the model and convert it to the format for the appropriate HW instead of using proprietary software.

However, there is one issue with the patch in python-sl1tophoton. In the install phase it crates the executables in gnu/store/xxxxx/bin but it attempts to launch them as a shell script instead of python.

Do you know how to fix that?
L
L
Ludovic Courtès wrote on 26 Oct 2021 12:40
control message for bug #50987
(address . control@debbugs.gnu.org)
871r48jcgu.fsf@gnu.org
tags 50987 + moreinfo
quit
?