[PATCH] gnu: tesseract-ocr: update to 4.1.1

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • zimoun
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 8 Feb 2021 07:32
(address . guix-patches@gnu.org)
CAJsg1E9NGwyu0WP=qdtLPVP=y+Z2UgBZzn02G+8SoudTLBz=hw@mail.gmail.com
* gnu/packages/ocr.scm (tesseract-ocr): update to 4.1.1
---
gnu/packages/ocr.scm | 38 +++++++++++++++++++++++++++++++-------
1 file changed, 31 insertions(+), 7 deletions(-)

Toggle diff (87 lines)
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index dc4930918a..7fc3929684 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,7 +27,12 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages icu4c)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages image))

@@ -52,25 +58,43 @@ it produces text in 8-bit or UTF-8 formats.")
(license license:gpl3+)))

(define-public tesseract-ocr
+ ;; some useful commits beyond last official stable release in release branch
+ (let ((commit "97079fa353557af6df86fd20b5d2e0dff5d8d5df"))
(package
(name "tesseract-ocr")
- (version "3.04.01")
+ (version "4.1.1")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/tesseract-ocr/tesseract")
- (commit version)))
- (file-name (git-file-name name version))
+ (commit commit)
+ ;; Fetch git submodules otherwise typeshed is not fetched.
+ ;; Typeshed is a collection of Python sources type annotation
+ ;; (data) files.
+ (recursive? #t)))
+ (file-name (string-append name "-" version "-" commit "-checkout"))
(sha256
- (base32 "0h1x4z1h86n2gwknd0wck6gykkp99bmm02lg4a47a698g4az6ybv"))))
+ (base32 "0axwla82fpzp86lc553wp3hk0fz5dylw4as0jbf4hkqcyajlbzp4"))))
(build-system gnu-build-system)
(inputs
- `(("leptonica" ,leptonica)))
+ `( ("cairo" ,cairo)
+ ("icu" ,icu4c)
+ ("leptonica" ,leptonica)
+ ("pango" ,pango)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
+ ("automake" ,automake)
+ ("googletest" ,googletest)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(arguments
'(#:configure-flags
(let ((leptonica (assoc-ref %build-inputs "leptonica")))
- (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
+ (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))
+ ;; some test, applybox_test fails to build
+ #:tests? #f))
(home-page "https://github.com/tesseract-ocr/tesseract")
(synopsis "Optical character recognition engine")
(description
@@ -79,7 +103,7 @@ high accuracy. It supports many languages, output
text formatting, hOCR
positional information and page layout analysis. Several image formats are
supported through the Leptonica library. It can also detect whether text is
monospaced or proportional.")
- (license license:asl2.0)))
+ (license license:asl2.0))))

(define-public zinnia
(let* ((commit "581faa8f6f15e4a7b21964be3a5ec36265c80e5b")
--
2.30.0
A
Z
Z
zimoun wrote on 9 Feb 2021 01:08
control message for bug #46377
(address . control@debbugs.gnu.org)
865z32ksqd.fsf@gmail.com
tags 46377 fixed
close 46377
quit
?