[PATCH] gnu: Add emacs-glsl-mode

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Fredrik Salomonsson
Owner
unassigned
Submitted by
Fredrik Salomonsson
Severity
normal
F
F
Fredrik Salomonsson wrote on 2 Jun 2020 21:41
(address . guix-patches@gnu.org)(name . Fredrik Salomonsson)(address . plattfot@gmail.com)
20200602194137.30412-1-plattfot@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-glsl-mode): New variable
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5f0a0184f9..94fd5cb1c8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22693,6 +22693,34 @@ sense in the @samp{To} and @samp{Cc} headers). When in the message body, this
executes a different function (default: @code{indent-relative}).")
(license license:gpl2+))))
+(define-public emacs-glsl-mode
+ ;; No tag, version grabbed from source .el file.
+ (let ((commit "b07112016436d9634cd4ef747f9af6b01366d136")
+ (revision "0"))
+ (package
+ (name "emacs-glsl-mode")
+ (version (git-version "2.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jimhourihan/glsl-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bav9ipfm0vy26n74ngsmjzc7fsyqz6xmriadzx55s44h8p5dn1s"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/jimhourihan/glsl-mode")
+ (synopsis
+ "Major mode for Open GLSL shader files")
+ (description
+ "Major mode for editing OpenGLSL grammar files, usually files ending with
+`.vert', `.frag', `.glsl', `.geom'. Is is based on c-mode plus some
+features and pre-specified fontifications.")
+ (license license:gpl3+))))
+
(define-public emacs-gnus-harvest
(let ((commit "feda071a87b799bd5d23cacde3ee71f0b166e75d")
(revision "0"))
--
2.26.2
N
N
Nicolas Goaziou wrote on 2 Jun 2020 22:04
(name . Fredrik Salomonsson)(address . plattfot@gmail.com)(address . 41671@debbugs.gnu.org)
878sh5dykv.fsf@nicolasgoaziou.fr
Hello,

Fredrik Salomonsson <plattfot@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-glsl-mode): New variable

Thank you. Some comments follow.

Nitpick: you need full stops at the end of each sentence in the commit
message.

Toggle quote (4 lines)
> + (sha256
> + (base32
> + "0bav9ipfm0vy26n74ngsmjzc7fsyqz6xmriadzx55s44h8p5dn1s"))))

Nitpick: could you move the hash on the same line as `base32'?

Toggle quote (4 lines)
> + (build-system emacs-build-system)
> + (home-page
> + "https://github.com/jimhourihan/glsl-mode")

Nitpick: could you move the URL on the same line as `home-page'?

Toggle quote (3 lines)
> + (synopsis
> + "Major mode for Open GLSL shader files")

Nitpick: … guess what… ;)

Toggle quote (4 lines)
> + (description
> + "Major mode for editing OpenGLSL grammar files, usually files ending with
> +`.vert', `.frag', `.glsl', `.geom'.

This should be a complete sentence, e.g.,

The library provides a major mode…

Note that Texinfo syntax for file extensions is @file, so the rest of
the sentence ought to be:

files ending with @file{.vert}, @file{.frag}…

Toggle quote (2 lines)
> Is is based on c-mode plus some

Typo and nitpick: "It is based on C mode"

Could you send an updated patch?

Regards,

--
Nicolas Goaziou
F
F
Fredrik Salomonsson wrote on 2 Jun 2020 23:02
[PATCH] gnu: Add emacs-glsl-mode.
(address . 41671@debbugs.gnu.org)(name . Fredrik Salomonsson)(address . plattfot@gmail.com)
20200602210249.36527-1-plattfot@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-glsl-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5f0a0184f9..2701081b9c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22693,6 +22693,32 @@ sense in the @samp{To} and @samp{Cc} headers). When in the message body, this
executes a different function (default: @code{indent-relative}).")
(license license:gpl2+))))
+(define-public emacs-glsl-mode
+ ;; No tag, version grabbed from source .el file.
+ (let ((commit "b07112016436d9634cd4ef747f9af6b01366d136")
+ (revision "0"))
+ (package
+ (name "emacs-glsl-mode")
+ (version (git-version "2.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jimhourihan/glsl-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bav9ipfm0vy26n74ngsmjzc7fsyqz6xmriadzx55s44h8p5dn1s"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/jimhourihan/glsl-mode")
+ (synopsis "Major mode for Open GLSL shader files")
+ (description
+ "This package provides a major mode for editing OpenGLSL grammar files,
+usually files ending with @file{.vert}, @file{.frag}, @file{.glsl} or
+@file{.geom}. It is based on C mode plus some features and pre-specified
+fontifications.")
+ (license license:gpl3+))))
+
(define-public emacs-gnus-harvest
(let ((commit "feda071a87b799bd5d23cacde3ee71f0b166e75d")
(revision "0"))
--
2.26.2
F
F
Fredrik Salomonsson wrote on 2 Jun 2020 23:08
Re: [bug#41671] [PATCH] gnu: Add emacs-glsl-mode
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 41671@debbugs.gnu.org)
CABZcOASQamWoC++p1gQJ7FnbpqTojHomptObZmf=j3GYFiiQ3w@mail.gmail.com
Hi Nicolas,

Den tis 2 juni 2020 kl 13:04 skrev Nicolas Goaziou <mail@nicolasgoaziou.fr>:

Toggle quote (41 lines)
> Nitpick: you need full stops at the end of each sentence in the commit
> message.
>
> > + (sha256
> > + (base32
> > + "0bav9ipfm0vy26n74ngsmjzc7fsyqz6xmriadzx55s44h8p5dn1s"))))
>
> Nitpick: could you move the hash on the same line as `base32'?
>
> > + (build-system emacs-build-system)
> > + (home-page
> > + "https://github.com/jimhourihan/glsl-mode")
>
> Nitpick: could you move the URL on the same line as `home-page'?
>
> > + (synopsis
> > + "Major mode for Open GLSL shader files")
>
> Nitpick: … guess what… ;)
>
> > + (description
> > + "Major mode for editing OpenGLSL grammar files, usually files
> ending with
> > +`.vert', `.frag', `.glsl', `.geom'.
>
> This should be a complete sentence, e.g.,
>
> The library provides a major mode…
>
> Note that Texinfo syntax for file extensions is @file, so the rest of
> the sentence ought to be:
>
> files ending with @file{.vert}, @file{.frag}…
>
> > Is is based on c-mode plus some
>
> Typo and nitpick: "It is based on C mode"
>
> Could you send an updated patch?
>

Thank you for the speedy response. I sent in a new patch, which should fix
all the things mentioned above.
Let me know if it ended up in the right place. I'm pretty new with the git
send-email workflow.

--
s/Fred[re]+i[ck]+/Fredrik/g
Attachment: file
N
N
Nicolas Goaziou wrote on 4 Jun 2020 14:59
Re: [bug#41671] [PATCH] gnu: Add emacs-glsl-mode.
(name . Fredrik Salomonsson)(address . plattfot@gmail.com)(address . 41671-done@debbugs.gnu.org)
87k10nrnq5.fsf@nicolasgoaziou.fr
This is a duplicate of 41673. I'm closing it, too.
Closed
?