[PATCH] gnu: Add emacs-buffer-move

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Fredrik Salomonsson
Owner
unassigned
Submitted by
Fredrik Salomonsson
Severity
normal
F
F
Fredrik Salomonsson wrote on 30 May 2020 03:35
(address . guix-patches@gnu.org)(name . Fredrik Salomonsson)(address . plattfot@gmail.com)
20200530013555.80463-1-plattfot@gmail.com
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4f7b4cf6cc..268780ce3d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -73,6 +73,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
+;;; Copyright © 2020 Fredrik Salomonsson <plattfot@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23110,3 +23111,28 @@ files.")
sources. It features syntax highlighting, autocompletion, preview of buffer
or region and use of locally installed binaries.")
(license license:gpl3+)))
+
+(define-public emacs-buffer-move
+ (package
+ (name "emacs-buffer-move")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://stable.melpa.org/packages/buffer-move-"
+ version
+ ".el"))
+ (sha256
+ (base32
+ "0d977g88ca3k1v5psikgrg4sb9q0jiw21g633r8a06dvn4n0ca3h"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/lukhas/buffer-move")
+ (synopsis "Functions for moving emacs' buffers around")
+ (description
+ "This package define functions for swapping buffers between windows
+contained in the same frame. An alternate behavior is to have the current
+window switch to the previous buffer instead of swapping with the other
+window.")
+ (license license:gpl3+)))
--
2.26.2
N
N
Nicolas Goaziou wrote on 31 May 2020 23:34
(name . Fredrik Salomonsson)(address . plattfot@gmail.com)(address . 41611-done@debbugs.gnu.org)
87zh9ng55m.fsf@nicolasgoaziou.fr
Hello,

Fredrik Salomonsson <plattfot@gmail.com> writes:

Toggle quote (3 lines)
> ---
> gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++

Thank you. I applied your patch with the following changes:

- I added a proper commit message,
- I fixed indentation
- I used GitHub repository instead of MELPA
- I moved the definition elsewhere than at the end the file.

Regards,

--
Nicolas Goaziou
Closed
?