[PATCH] build: substitute*: Fix typo in example.

  • Done
  • quality assurance status badge
Details
One participant
  • Efraim Flashner
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 25 May 2020 09:47
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20200525074744.13164-1-efraim@flashner.co.il
* guix/build/utils.scm (substitute*): Fix typo in example in docstring,
use consistent variable names.
---

The variable is 'letters' on the line above, so it should be 'letters'
on the replacement line too.

---
guix/build/utils.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/guix/build/utils.scm b/guix/build/utils.scm
index 419c10195b..bcae0f758a 100644
--- a/guix/build/utils.scm
+++ b/guix/build/utils.scm
@@ -800,7 +800,7 @@ sub-expression. For example:
((\"hello\")
\"good morning\\n\")
((\"foo([a-z]+)bar(.*)$\" all letters end)
- (string-append \"baz\" letter end)))
+ (string-append \"baz\" letters end)))
Here, anytime a line of FILE contains \"hello\", it is replaced by \"good
morning\". Anytime a line of FILE matches the second regexp, ALL is bound to
--
2.26.2
E
E
Efraim Flashner wrote on 25 May 2020 09:55
(address . 41521-done@debbugs.gnu.org)
20200525075530.GC3698@E5400
Patch pushed to core-updates


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl7LefIACgkQQarn3Mo9
g1HZ7A/5Ae3UnFjhscKBtiuVUA1c0p3ZYdTFVyBR0/26WGMPCRr3YjZequFQrBy0
mh8SmiTD4t2vlmnsoNK3YvIENZIhg2wHMdPrsKg3Vi0ZDTVGhAo/h2mN4goJykaG
thW3rQ38VrpKppaClsgYaY/glqinV5Zn74/M2xlob/WiHsDBq0ns5419JeFEyeFs
1pqeZT36f6gy9Qtz+UqfO+NhsYDc4xx/zw0J7+lp2yaZZc4u8ODYlCSUerAg2xmh
coqK7eDyZjf+VlPVzs5F6UDMc9hKHmkho8/X6oDuuNgGuZSfKS0B3MtErMBz4Bnu
E1KkBfVE/DZyfs3pRQcMuVkB96eN8K7Aue4RIJRbMGtID67ihTrtafV35YlrXGXh
17cYC/HwvYrtLmssikwl6HgVzGMBxBWfuYbwM5YY7kX12aDe5/FHgTKJgeWA98q9
vraCtl+YeEU/3bX5cI/Jc4Bney+6P7BUVcpV6MMNRchJMBTj3onFhym3EEsBfgjy
pesLRvWeaxeuNcPEZ+pSEdnTXkkEUOaLuY2fe4SHLzQnNMAXC/3gz5krZa4KBoIV
HGaY/f1WDw3CZI3KkgTL+lUq1dsticgsvuuwa48DxSomKZYA4bg0HSsycYd1tCxE
8bQwhJYRMScTjXbKt3/nrgRDyMafUESOXbmXer6AcnXeA5ba6EM=
=8HiL
-----END PGP SIGNATURE-----


Closed
?