[PATCH 0/3] Update go-github-com-stretchr-testify

  • Done
  • quality assurance status badge
Details
2 participants
  • Jakub K?dzio?ka
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jakub K?dzio?ka
Severity
normal
J
J
Jakub K?dzio?ka wrote on 22 May 2020 18:04
(address . guix-patches@gnu.org)
20200522160449.10580-1-kuba@kadziolka.net
While debugging a test failure of a package I was adding, I have guessed
that the old version of testify is to blame. I was wrong, but since it
takes a bit more than a version bump, perhaps we should upgrade it
anyway?

I have tested building all dependent packages and haven't encountered
any issues.

Jakub K?dzio?ka (3):
gnu: Add go-github-com-stretchr-objx.
gnu: go-github-com-davecgh-go-spew: Update to 1.1.1.
gnu: go-github-com-stretchr-testify: Update to 1.5.1.

gnu/packages/golang.scm | 114 ++++++++++++++++++++++++----------------
1 file changed, 68 insertions(+), 46 deletions(-)

--
2.26.2
J
J
Jakub K?dzio?ka wrote on 22 May 2020 18:16
[PATCH 3/3] gnu: go-github-com-stretchr-testify: Update to 1.5.1.
(address . 41461@debbugs.gnu.org)
20200522161615.14502-3-kuba@kadziolka.net
* gnu/packages/golang.scm (go-github-com-stretchr-testify):
Update to 1.5.1.
---
gnu/packages/golang.scm | 48 +++++++++++++++++++++--------------------
1 file changed, 25 insertions(+), 23 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f3b121a69b..cfab23608d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -940,28 +940,30 @@ Go.")
(license license:expat)))
(define-public go-github-com-stretchr-testify
- (let ((commit
- "b1f989447a57594c728884458a39abf3a73447f7")
- (revision "0"))
- (package
- (name "go-github-com-stretchr-testify")
- (version (git-version "1.1.4" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stretchr/testify.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0p0gkqzh2p8r5g0rxm885ljl7ghih7h7hx9w562imx5ka0vdgixv"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/stretchr/testify"))
- (home-page "https://github.com/stretchr/testify")
- (synopsis "Go helper library for tests and invariant checking")
- (description "This package provide many tools for testifying that your
+ (package
+ (name "go-github-com-stretchr-testify")
+ (version "1.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stretchr/testify.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09r89m1wy4cjv2nps1ykp00qjpi0531r07q3s34hr7m6njk4srkl"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/stretchr/testify"))
+ (propagated-inputs
+ `(("github.com/davecgh/go-spew" ,go-github-com-davecgh-go-spew)
+ ("github.com/pmezard/go-difflib" ,go-github-com-pmezard-go-difflib)
+ ("github.com/stretchr/objx" ,go-github-com-stretchr-objx)
+ ("gopkg.in/yaml.v2" ,go-gopkg-in-yaml-v2)))
+ (home-page "https://github.com/stretchr/testify")
+ (synopsis "Go helper library for tests and invariant checking")
+ (description "This package provide many tools for testifying that your
code will behave as you intend.
Features include:
@@ -971,7 +973,7 @@ Features include:
@item HTTP response trapping
@item Testing suite interfaces and functions.
@end itemize")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-tevino-abool
(let ((commit
--
2.26.2
J
J
Jakub K?dzio?ka wrote on 22 May 2020 18:16
[PATCH 2/3] gnu: go-github-com-davecgh-go-spew: Update to 1.1.1.
(address . 41461@debbugs.gnu.org)
20200522161615.14502-2-kuba@kadziolka.net
* gnu/packages/golang.scm (go-github-com-davecgh-go-spew):
Update to 1.1.1.
---
gnu/packages/golang.scm | 44 ++++++++++++++++++++---------------------
1 file changed, 21 insertions(+), 23 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ccd43cc104..f3b121a69b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1930,28 +1930,26 @@ that's a lot faster (and only does simple bandwidth metrics).")
(license license:expat))))
(define-public go-github-com-davecgh-go-spew
- (let ((commit "d8f796af33cc11cb798c1aaeb27a4ebc5099927d")
- (revision "0"))
- (package
- (name "go-github-com-davecgh-go-spew")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/davecgh/go-spew.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "19z27f306fpsrjdvkzd61w1bdazcdbczjyjck177g33iklinhpvx"))))
- (build-system go-build-system)
- (arguments
- '(#:unpack-path "github.com/davecgh/go-spew"
- #:import-path "github.com/davecgh/go-spew/spew"))
- (home-page "https://github.com/davecgh/go-spew")
- (synopsis "Deep pretty printer for Go data structures to aid in debugging")
- (description "Package @command{spew} implements a deep pretty printer
+ (package
+ (name "go-github-com-davecgh-go-spew")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/davecgh/go-spew.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hka6hmyvp701adzag2g26cxdj47g21x6jz4sc6jjz1mn59d474y"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/davecgh/go-spew"
+ #:import-path "github.com/davecgh/go-spew/spew"))
+ (home-page "https://github.com/davecgh/go-spew")
+ (synopsis "Deep pretty printer for Go data structures to aid in debugging")
+ (description "Package @command{spew} implements a deep pretty printer
for Go data structures to aid in debugging.
A quick overview of the additional features spew provides over the built-in printing facilities for Go data types are as follows:
@@ -1967,7 +1965,7 @@ pointer receiver are optionally invoked when passing non-pointer variables.
includes offsets, byte values in hex, and ASCII output (only when using Dump
style).
@end itemize\n")
- (license license:isc))))
+ (license license:isc)))
(define-public go-github-com-btcsuite-btclog
(let ((commit "84c8d2346e9fc8c7b947e243b9c24e6df9fd206a")
--
2.26.2
J
J
Jakub K?dzio?ka wrote on 22 May 2020 18:16
[PATCH 1/3] gnu: Add go-github-com-stretchr-objx.
(address . 41461@debbugs.gnu.org)
20200522161615.14502-1-kuba@kadziolka.net
* gnu/packages/golang.scm (go-github-com-stretchr-objx): New variable.
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 69f46df743..ccd43cc104 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -917,6 +917,28 @@ increment versions.")
Go.")
(license license:expat))))
+(define-public go-github-com-stretchr-objx
+ (package
+ (name "go-github-com-stretchr-objx")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stretchr/objx.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pcdvakxgddaiwcdj73ra4da05a3q4cgwbpm2w75ycq4kzv8ij8k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/stretchr/objx"))
+ (home-page "https://github.com/stretchr/objx")
+ (synopsis "Go package for dealing with maps, slices, JSON and other data")
+ (description "Go package for dealing with maps, slices, JSON and other data")
+ (license license:expat)))
+
(define-public go-github-com-stretchr-testify
(let ((commit
"b1f989447a57594c728884458a39abf3a73447f7")
--
2.26.2
L
L
Ludovic Courtès wrote on 3 Jun 2020 17:53
(name . Jakub K?dzio?ka)(address . kuba@kadziolka.net)(address . 41461@debbugs.gnu.org)
87d06gkuwi.fsf@gnu.org
Hello,

Jakub K?dzio?ka <kuba@kadziolka.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/golang.scm (go-github-com-stretchr-objx): New variable.

[...]

Toggle quote (3 lines)
> + (synopsis "Go package for dealing with maps, slices, JSON and other data")
> + (description "Go package for dealing with maps, slices, JSON and other data")

Please write a full sentence (or two :-)) for the description (info
"(guix) Synopses and Descriptions").

Otherwise the three patches LGTM!

Ludo’.
J
J
Jakub K?dzio?ka wrote on 7 Jun 2020 21:55
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 41461-done@debbugs.gnu.org)
20200607195527.jrowt2mebx6gimgj@gravity
On Wed, Jun 03, 2020 at 05:53:49PM +0200, Ludovic Courtès wrote:
Toggle quote (16 lines)
> Hello,
>
> Jakub K?dzio?ka <kuba@kadziolka.net> skribis:
>
> > * gnu/packages/golang.scm (go-github-com-stretchr-objx): New variable.
>
> [...]
>
> > + (synopsis "Go package for dealing with maps, slices, JSON and other data")
> > + (description "Go package for dealing with maps, slices, JSON and other data")
>
> Please write a full sentence (or two :-)) for the description (info
> "(guix) Synopses and Descriptions").
>
> Otherwise the three patches LGTM!

Thanks for your review! I wrote a fuller description and pushed the
patches.

Regards,
Jakub K?dzio?ka
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl7dRi4ACgkQ4xWnWEYT
FWTtsw/9HIPpXi72ijffhnoYgoO3vUdIOHwMifAlYGApXYtyQR8T1Cmj6m4zR9uj
fGUQ2O1mFzo88NYve5ibyUymkiF8cGb6eV1nj6wpn4Z4qCp4eXTerUobD0enjQWl
QEFB2l655cgssRwQQBJsjxUQbpewoxAdxR6Eg08j5lOQdJ/0k/kNQOTNNSlh1upW
x2JPNXXj6hn2Behy8d7MsVShFvK9dLoLs6XiZ2OdKVM+9tuFgzWrqc+jA14eUtgA
4bK0H34AIsEJjlG4JPXj67dST5UujQ/YFCc1+Z6MwM0dIhumCPcEwL8ptk90sZcd
R7WEDpbIVZlCZUV45B9m77sveokXKH0RF0SPweiR393/rJOJH9Pr9BRHiyFDf4Jj
tejNgIMx7IyX3IdldAv1Guhrs91NVrksPdYFLPHb+9+sxw//zxN4hcm558jiTbtR
ASCeSlIFykYP711PE4M7mIUuw8AOymT2gGRn3hXD0pXA3rQ3Pc2BEAiMDGDOTFJP
qGXZ7c4JM9Orq3UhYyFa2C+5Ka15S2h6oB+e3HwY7iyj6XCCq7n92ag96OZqMCBu
pvM3KqMKbOdnKTL+xfBOvv/943BWcu31TpWxjuFJQ4B403Y4qRgq37fa5VyWzl5C
/GglsPAWXNHwjFmb1CLgYnq8O9a3aOWGFF4/NIQ9pUp3k1YIF4Y=
=7hds
-----END PGP SIGNATURE-----


Closed
?