[PATCH v2] gnu: Add glabels.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 21 May 2020 05:02
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200521030211.11696-1-monego@posteo.net
* gnu/packages/gnome.scm (glabels): New variable.
---
gnu/packages/gnome.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d5a2032ccf..f7e4a4f348 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10216,3 +10217,34 @@ communicating using the GVariant serialization format instead of JSON when
both peers support it. You might want that when communicating on a single
host to avoid parser overhead and memory-allocator fragmentation.")
(license license:lgpl2.1+)))
+
+(define-public glabels
+ (package
+ (name "glabels")
+ (version "3.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ "glabels-" version ".tar.xz"))
+ (sha256
+ (base32 "0f2rki8i27pkd9r0gz03cdl1g4vnmvp0j49nhxqn275vi8lmgr0q"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("librsvg" ,librsvg)
+ ("libxml2" ,libxml2)))
+ (home-page "https://glabels.org/")
+ (synopsis "Program for creating labels and business cards")
+ (description
+ "gLabels is a program for creating labels and business cards. It is
+designed to work with various laser/ink-jet peel-off label and business
+card sheets that you’ll find at most office supply stores.")
+ (license license:gpl3+)))
--
2.20.1
N
N
Nicolas Goaziou wrote on 22 May 2020 17:45
(name . Vinicius Monego)(address . monego@posteo.net)(address . 41430-done@debbugs.gnu.org)
878shkdlcg.fsf@nicolasgoaziou.fr
Hello,

Vinicius Monego <monego@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (glabels): New variable.

Applied. Thank you!

Regards,

--
Nicolas Goaziou
Closed
?