[PATCH v2] gnu: Add dump.

  • Done
  • quality assurance status badge
Details
3 participants
  • Marius Bakke
  • Marius Bakke
  • Marcin Karpezo
Owner
unassigned
Submitted by
Marcin Karpezo
Severity
normal
M
M
Marcin Karpezo wrote on 16 May 2020 15:56
(address . guix-patches@gnu.org)(name . Marcin Karpezo)(address . sirmacik@wioo.waw.pl)
20200516135639.26959-1-sirmacik@wioo.waw.pl
* gnu/packages/backup.scm (dump): New variable.
---
gnu/packages/backup.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 6a5080bcf8..2157b349dd 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1026,6 +1027,44 @@ stored previously can be read back in full at any time. The program
is format-agnostic, so you can feed virtually any files to it.")
(license license:gpl2+)))
+(define-public dump
+ (package
+ (name "dump")
+ (version "0.4b46")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://downloads.sourceforge.net/project/" name "/"
+ name "/" version "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15rg5y15ak0ppqlhcih78layvg7cwp6hc16p3c58xs8svlkxjqc0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ `("--sysconfdir=/etc"
+ "--disable-readline"
+ "--disable-rmt")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("zlib" ,zlib)
+ ("util-linux" ,util-linux "lib")
+ ("e2fsprogs" ,e2fsprogs)
+ ("automake" ,automake)))
+ (inputs
+ `(("openssl" ,openssl-1.0)))
+ (home-page "https://dump.sourceforge.io/")
+ (synopsis "Linux Ext2/3/4 filesystem dump/restore utilities")
+ (description "Dump examines files in a filesystem, determines which ones
+need to be backed up, and copies those files to a specified disk, tape or
+other storage medium. Subsequent incremental backups can then be layered on
+top of the full backup. The restore command performs the inverse function of
+dump; it can restore a full backup of a filesystem. Single files and
+directory subtrees may also be restored from full or partial backups in
+interractive mode.")
+ (license license:bsd-3)))
+
(define-public burp
(package
(name "burp")
--
2.26.2
M
M
Marcin Karpezo wrote on 16 May 2020 15:58
(address . 41324@debbugs.gnu.org)(name . Marcin Karpezo)(address . sirmacik@wioo.waw.pl)
20200516135831.27246-1-sirmacik@wioo.waw.pl
* gnu/packages/backup.scm (dump): New variable.
---
gnu/packages/backup.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 6a5080bcf8..2157b349dd 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1026,6 +1027,44 @@ stored previously can be read back in full at any time. The program
is format-agnostic, so you can feed virtually any files to it.")
(license license:gpl2+)))
+(define-public dump
+ (package
+ (name "dump")
+ (version "0.4b46")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://downloads.sourceforge.net/project/" name "/"
+ name "/" version "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15rg5y15ak0ppqlhcih78layvg7cwp6hc16p3c58xs8svlkxjqc0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ `("--sysconfdir=/etc"
+ "--disable-readline"
+ "--disable-rmt")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("zlib" ,zlib)
+ ("util-linux" ,util-linux "lib")
+ ("e2fsprogs" ,e2fsprogs)
+ ("automake" ,automake)))
+ (inputs
+ `(("openssl" ,openssl-1.0)))
+ (home-page "https://dump.sourceforge.io/")
+ (synopsis "Linux Ext2/3/4 filesystem dump/restore utilities")
+ (description "Dump examines files in a filesystem, determines which ones
+need to be backed up, and copies those files to a specified disk, tape or
+other storage medium. Subsequent incremental backups can then be layered on
+top of the full backup. The restore command performs the inverse function of
+dump; it can restore a full backup of a filesystem. Single files and
+directory subtrees may also be restored from full or partial backups in
+interractive mode.")
+ (license license:bsd-3)))
+
(define-public burp
(package
(name "burp")
--
2.26.2
M
M
Marius Bakke wrote on 23 May 2020 21:14
(name . Marcin Karpezo)(address . sirmacik@wioo.waw.pl)
87lfli79bj.fsf@devup.no
Hi Marcin,

Marcin Karpezo <sirmacik@wioo.waw.pl> writes:

Toggle quote (2 lines)
> * gnu/packages/backup.scm (dump): New variable.

Thanks! Can't believe we've gone without this for so long.

[...]
Toggle quote (10 lines)
> +(define-public dump
> + (package
> + (name "dump")
> + (version "0.4b46")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://downloads.sourceforge.net/project/" name "/"
> + name "/" version "/" name "-" version ".tar.gz"))

Please use "mirror://sourceforge" here.

Toggle quote (17 lines)
> + (sha256
> + (base32
> + "15rg5y15ak0ppqlhcih78layvg7cwp6hc16p3c58xs8svlkxjqc0"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:configure-flags
> + `("--sysconfdir=/etc"
> + "--disable-readline"
> + "--disable-rmt")))
> + (native-inputs
> + `(("pkg-config" ,pkg-config)
> + ("autoconf" ,autoconf)
> + ("zlib" ,zlib)
> + ("util-linux" ,util-linux "lib")
> + ("e2fsprogs" ,e2fsprogs)
> + ("automake" ,automake)))

I ran 'guix size dump' and noticed that the package keeps references to
util-linux, zlib and e2fsprogs. Probably they should be "inputs"
instead. Can you confirm and send an updated patch?

Otherwise looks great, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7JdhAACgkQoqBt8qM6
VPrSowf7B08ZSzRvBVkO/0/L5sV2ppG3xcyIA5+aYa69VDrQOt2QGCSZf5+4f2ev
tiVVqy7++oNJc5FpcS2qGHus1bEEbn5ANAleO6yPovTkHe4/H484TRUpfV37MHbz
OU0VcU81FJunlTFBqlIRBSP/O5+1ctNrxNC0PTjKzJWUW2vU/afPrEMSPTe7A8VD
3JCy2h4Kk/Pz0e2+lDej6YXp1wVY439HGQXZ08hFXz+1KMA10OFq4pjGjbyHSo3f
4j08rAO0OTBWywD8LMDKm5Qw7WeEfkFM6u828YH4Rt4hw4A+fewYuaPVsE/gG4KW
ioOZyAVpM29GWjxEvNhilVwGQJxH0g==
=+iY5
-----END PGP SIGNATURE-----

M
M
Marcin Karpezo wrote on 25 May 2020 18:05
[PATCH v3] gnu/packages/backup.scm (dump): New variable
(address . 41324@debbugs.gnu.org)(name . Marcin Karpezo)(address . sirmacik@wioo.waw.pl)
20200525160528.18143-1-sirmacik@wioo.waw.pl
Hi Marius,

I'm sending updated patch with the changes you requested. Apart from
one, regarding use of mirror://sourceforge. I've tried it several
times and in several ways I've found in other packages included in
guix, but the one presented is the one that wokred to bild package
relaiably.

---
gnu/packages/backup.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 0fe6676cc2..1939f3b72c 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1026,6 +1027,44 @@ stored previously can be read back in full at any time. The program
is format-agnostic, so you can feed virtually any files to it.")
(license license:gpl2+)))

+(define-public dump
+ (package
+ (name "dump")
+ (version "0.4b46")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://downloads.sourceforge.net/project/" name "/"
+ name "/" version "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15rg5y15ak0ppqlhcih78layvg7cwp6hc16p3c58xs8svlkxjqc0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ `("--sysconfdir=/etc"
+ "--disable-readline"
+ "--disable-rmt")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (inputs
+ `(("openssl" ,openssl-1.0)
+ ("zlib" ,zlib)
+ ("util-linux" ,util-linux "lib")
+ ("e2fsprogs" ,e2fsprogs)))
+ (home-page "https://dump.sourceforge.io/")
+ (synopsis "Linux Ext2/3/4 filesystem dump/restore utilities")
+ (description "Dump examines files in a filesystem, determines which ones
+need to be backed up, and copies those files to a specified disk, tape or
+other storage medium. Subsequent incremental backups can then be layered on
+top of the full backup. The restore command performs the inverse function of
+dump; it can restore a full backup of a filesystem. Single files and
+directory subtrees may also be restored from full or partial backups in
+interractive mode.")
+ (license license:bsd-3)))
+
(define-public burp
(package
(name "burp")
--
2.26.2
M
M
Marius Bakke wrote on 25 May 2020 23:50
(name . Marcin Karpezo)(address . sirmacik@wioo.waw.pl)
877dwz7kfw.fsf@gnu.org
Marcin Karpezo <sirmacik@wioo.waw.pl> writes:

Toggle quote (8 lines)
> Hi Marius,
>
> I'm sending updated patch with the changes you requested. Apart from
> one, regarding use of mirror://sourceforge. I've tried it several
> times and in several ways I've found in other packages included in
> guix, but the one presented is the one that wokred to bild package
> relaiably.

Great! Constructing those mirror://sourceforge URLs can be surprisingly
difficult, I wonder if we could make it easier somehow.

I managed to find a working URL and applied the patch with the unused
'autoconf' and 'automake' inputs removed (missed that in the previous
review). I also removed 'Linux' from the synopsis as it does not
actually run in kernel-space. ;-)

Thank you!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7MPcMACgkQoqBt8qM6
VPoepAf+K5wjoo811oig7R6Zv4LjOSj5GKAEx50wvnH9MO3vwqlkM+MiHXVM/0GZ
Sc6RFxFQ0CQ39/jClcXOrzNHJjyQA7kLBb2ew1GvtJyqY6dwY02doKEo5jk2jDjP
69PXQe1nabpoonNowlgCEMOjP+hLMOH5IrM1y5Ni34z2sDl2d4BgMXINBrcGOE7F
O8hYgdf1BdvcI5UAUfnAo0FlwImvoBDUf0Naf7lOROEc26skdLgZ90TkGjhncXhs
l7ZQm+Vhtl+zrfNAU6yeVKOsTZ7RtF+Qvr2+SvX/jbCo/8Zv+Sc9mCJ/OqkfdyPK
MRQYXaieu1vQ1N4x7Ht7xu8b39lXWg==
=UTyz
-----END PGP SIGNATURE-----

Closed
?