[PATCH] gnu: icedove: Add a desktop file.

  • Done
  • quality assurance status badge
Details
4 participants
  • Ricardo Wurmus via web
  • Jonathan Brielmaier
  • Nicolas Goaziou
  • Marius Bakke
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal
J
J
Jonathan Brielmaier wrote on 14 May 2020 13:49
(address . guix-patches@gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200514114953.4457-1-jonathan.brielmaier@web.de
Thunderbird upstream doesn't provide any desktop file. So we have
to create it downstream. I filed an upstream bug:

* gnu/packages/gnuzilla.scm (icedove)[phases]: Add install-desktop-file phase.
---
gnu/packages/gnuzilla.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 8a926681e0..7bf9850e97 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1344,6 +1344,32 @@ standards of the IceCat project.")
(lambda _ (invoke "./mach" "build")))
(replace 'install
(lambda _ (invoke "./mach" "install")))
+ ;; Thunderbird doesn't provide any .desktop file.
+ ;; See https://bugzilla.mozilla.org/show_bug.cgi?id=1637575
+ (add-after 'install 'install-desktop-file
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (apps (string-append out "/share/applications")))
+ (mkdir-p apps)
+ (with-output-to-file (string-append apps "/icedove.desktop")
+ (lambda _
+ (format #t
+ "[Desktop Entry]~@
+ Name=Icedove~@
+ Exec=~a/bin/icedove~@
+ Icon=icedove~@
+ GenericName=Mail/News Client~@
+ Categories=Network;Email;~@
+ Terminal=false~@
+ StartupNotify=true~@
+ MimeType=x-scheme-handler/mailto;~@
+ Type=Application~@
+ Actions=ComposeMessage;~@
+ [Desktop Action ComposeMessage]~@
+ Name=Write new message~@
+ Exec=~@*~a/bin/icedove -compose~%"
+ out))))
+ #t))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
--
2.26.2
R
R
Ricardo Wurmus via web wrote on 14 May 2020 14:50
(address . 41256@debbugs.gnu.org)
7f41efd29560.101e2b8fb1797f28@guile.gnu.org
This looks good to me!
J
J
Jonathan Brielmaier wrote on 15 May 2020 10:56
07536394-a6a9-d6d0-461d-1c208559cd6d@web.de
so is this good for push? I cannot do that myself.

On 14.05.20 14:50, Ricardo Wurmus via web wrote:
Toggle quote (5 lines)
> This looks good to me!
>
>
>
>
M
M
Marius Bakke wrote on 23 May 2020 21:16
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
87imgm797g.fsf@devup.no
Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:

Toggle quote (6 lines)
> Thunderbird upstream doesn't provide any desktop file. So we have
> to create it downstream. I filed an upstream bug:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1637575
>
> * gnu/packages/gnuzilla.scm (icedove)[phases]: Add install-desktop-file phase.

Applied, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7JdqMACgkQoqBt8qM6
VPrHOAgAzkwAU5abUu8buufFU7DqFb89McAVuqLHgn5CP6YMuQ5C2Tz9yDqYbrzz
Lr2tu6sypAV7QtjyAiTIWyIjsfQkXnZBKn3VZAMb3OJkyK9jsLdF0g9Lg/MtcY+Q
xx+T2H2sQ15xNs9mkVCFwAc62uXM5Os6XZkegZpmp9zfZ4l2jxhdHXsiL8exJMKX
PizI7cuiXUtJj9kTjtaEFONXJyUQ2ISGIbZ9AzC1d0q35alMtu/zgTp+vTfw9zLR
KVtkDS42hIZAMk+Q97P2jjw7crh/B1K5SoqEjETSKahjiMQrG21VAg2N1Fhl97Pb
6WtJd5xywSjn8xajiKY8LYRhH5yJ+w==
=JypY
-----END PGP SIGNATURE-----

Closed
N
N
Nicolas Goaziou wrote on 23 May 2020 21:56
Re: bug#41256: [PATCH] gnu: icedove: Add a desktop file.
(address . 41256@debbugs.gnu.org)
87pnaubf2w.fsf@nicolasgoaziou.fr
Hello,

Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (9 lines)
> Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:
>
>> Thunderbird upstream doesn't provide any desktop file. So we have
>> to create it downstream. I filed an upstream bug:
>> https://bugzilla.mozilla.org/show_bug.cgi?id=1637575
>>
>> * gnu/packages/gnuzilla.scm (icedove)[phases]: Add
>> install-desktop-file phase.

I'm a bit late at the party, but would it make sense to use
make-desktop-entry-file instead?

Regards,

--
Nicolas Goaziou
M
M
Marius Bakke wrote on 23 May 2020 22:18
(address . jonathan.brielmaier@web.de)
878shi76c2.fsf@devup.no
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (16 lines)
> Hello,
>
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:
>>
>>> Thunderbird upstream doesn't provide any desktop file. So we have
>>> to create it downstream. I filed an upstream bug:
>>> https://bugzilla.mozilla.org/show_bug.cgi?id=1637575
>>>
>>> * gnu/packages/gnuzilla.scm (icedove)[phases]: Add
>>> install-desktop-file phase.
>
> I'm a bit late at the party, but would it make sense to use
> make-desktop-entry-file instead?

Probably, yes. :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7JhS0ACgkQoqBt8qM6
VPrcxAf/VQoaDPw/D863kd1bCcDUZA8v5qAVmqHk4lIirqqBEYUxL/ZDIQ9lxbpt
e4cUF+Tyh81Ii1kX3dnCaBj2F0OWc2VGUlc6F+2UPOi5Bh34Fr+o+QrO87VKzz26
WI7XP2B3uehxERMPK+bd8ZeZj6PD7XpSec/6HO+D8NpYuFMIuhwwgFGEwKHOYs1N
ADOkv9YbasJQHbD9+X82Zyfxq3Yg4Kl5kyDF8fimDqDquBxg20PirIlOkY8gLemk
es7Zj5TwrMqkyOysizkjO8To5ihLzo96yE/YFSt6swagXXsA7XA1irIK3jSUV+hP
uwaW3kazVp/fyo8Z3byw/Ltuo+sZmg==
=aQIM
-----END PGP SIGNATURE-----

J
J
Jonathan Brielmaier wrote on 23 May 2020 23:47
(address . mbakke@fastmail.com)
9660323d-6b9f-5094-e01d-d3f923aea6f7@web.de
On 23.05.20 21:56, Nicolas Goaziou wrote:
Toggle quote (5 lines)
>>> * gnu/packages/gnuzilla.scm (icedove)[phases]: Add
>>> install-desktop-file phase.
>
> I'm a bit late at the party, but would it make sense to use
> make-desktop-entry-file instead?
Oh Nicolas that is a good catch. I didn't know this nice function :P

But I wonder how to archive the compose action:
```
[Desktop Action ComposeMessage]~@
Name=Write new message~@
Exec=~@*~a/bin/icedove -compose~%"
```

With the field `actions` but how?
?