[PATCH] gnu: Add python-selenium

  • Done
  • quality assurance status badge
Details
2 participants
  • Edouard Klein
  • Ludovic Courtès
Owner
unassigned
Submitted by
Edouard Klein
Severity
normal
E
E
Edouard Klein wrote on 12 May 2020 13:29
(address . guix-patches@gnu.org)
875zd1ie80.fsf@alice.lan
---
gnu/packages/python-web.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9be92053b1..32a4d2b756 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3746,3 +3746,26 @@ in Python with a focus on correctness and simplicity.
Built on top of @code{asyncio}, Python's standard asynchronous I/O framework,
it provides an elegant coroutine-based API.")
(license license:bsd-3)))
+
+(define-public python-selenium
+ (package
+ (name "python-selenium")
+ (version "3.141.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "selenium" version))
+ (sha256
+ (base32
+ "039hf9knvl4s3hp21bzwsp1g5ri9gxsh504dp48lc6nr1av35byy"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-urllib3" ,python-urllib3)))
+ (home-page
+ "https://github.com/SeleniumHQ/selenium/")
+ (synopsis "Python bindings for Selenium")
+ (description "Selenium enables web browser automation.
+Selenium specifically provides infrastructure for the W3C WebDriver specification
+— a platform and language-neutral coding interface compatible with all
+major web browsers.")
+ (license license:asl2.0)))
--
2.26.2
L
L
Ludovic Courtès wrote on 15 May 2020 12:25
(name . Edouard Klein)(address . edk@beaver-labs.com)(address . 41206-done@debbugs.gnu.org)
875zcxtrzn.fsf@gnu.org
Hi,

Edouard Klein <edk@beaver-labs.com> skribis:

Toggle quote (4 lines)
> ---
> gnu/packages/python-web.scm | 23 +++++++++++++++++++++++
> 1 file changed, 23 insertions(+)

[...]

Toggle quote (6 lines)
> + (synopsis "Python bindings for Selenium")
> + (description "Selenium enables web browser automation.
> +Selenium specifically provides infrastructure for the W3C WebDriver specification
> +— a platform and language-neutral coding interface compatible with all
> +major web browsers.")

I added a commit log that follows our convention and committed.

Thanks!

Ludo’.
Closed
?