[PATCH] gnu: tigervnc-server: Update to 1.10.1-1.920d9c4.

  • Done
  • quality assurance status badge
Details
2 participants
  • Oleg Pykhalov
  • Marius Bakke
Owner
unassigned
Submitted by
Oleg Pykhalov
Severity
normal
O
O
Oleg Pykhalov wrote on 10 May 2020 17:03
(address . guix-patches@gnu.org)(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
20200510150310.3184-1-go.wigust@gmail.com
* gnu/packages/vnc.scm (%tigervnc-version, %tigervnc-revision,
%tigervnc-commit): New variables.
(tigervnc-client): Update to 1.10.1-1.920d9c4.
(tigervnc-server)[version]: Update to 1.10.1-1.920d9c4.
[arguments]<#:phases>[patch-xserver]: Fix format procedure call.
[native-inputs]: Use tigervnc-client package source.
---
gnu/packages/vnc.scm | 45 +++++++++++++++++++++-----------------------
1 file changed, 21 insertions(+), 24 deletions(-)

Toggle diff (77 lines)
diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index 2b5adb899a..aceb62767e 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -42,21 +42,25 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages xorg))
+(define %tigervnc-version "1.10.1")
+(define %tigervnc-revision "1")
+(define %tigervnc-commit "920d9c4d6562ecabf79497bc901d50522d4bc661")
+
(define-public tigervnc-client
(package
(name "tigervnc-client")
- (version "1.10.1")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/TigerVNC/tigervnc.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "001n189d2f3psn7nxgl8188ml6f7jbk26cxn2835y3mnlk5lmhgr"))))
+ (version (git-version %tigervnc-version %tigervnc-revision
+ %tigervnc-commit))
+ (source (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/TigerVNC/tigervnc.git")
+ (commit %tigervnc-commit)))
+ (sha256
+ (base32
+ "1lp6mxl5dqlkrzx0q145jzgpbwvhsni3fj6x9ngf8v5s63x82q1p"))
+ (file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; Tests that do exists are not automated.
@@ -103,17 +107,10 @@ application which is needed to connect to VNC servers.")
(package
(inherit xorg-server)
(name "tigervnc-server")
- (version "1.10.1")
+ (version (git-version %tigervnc-version %tigervnc-revision
+ %tigervnc-commit))
(native-inputs
- `(("tigervnc-src" ,(origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/TigerVNC/tigervnc.git")
- (commit "v1.9.0")))
- (sha256
- (base32
- "0b47fg3741qs3zdpl2zr0s6jz46dypp2j6gqrappbzm3ywnnmm1x"))))
+ `(("tigervnc-src" ,(package-source tigervnc-client))
("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
@@ -183,9 +180,9 @@ application which is needed to connect to VNC servers.")
(list-head (string-split xorg-server-version
#\.)
2)))
- (fn (format "~a/unix/xserver~a.patch" tvnc-src patch-num)))
+ (fn (format #f "~a/unix/xserver~a.patch" tvnc-src patch-num)))
(when (not (file-exists? fn))
- (error (format "Patch file, ~a,
+ (error (format #f "Patch file, ~a,
corresponding to the input xorg-server version, does not exist. Installation
will fail. " fn)))
--
2.26.2
M
M
Marius Bakke wrote on 10 May 2020 22:51
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
87o8qv1pkh.fsf@devup.no
Oleg Pykhalov <go.wigust@gmail.com> writes:

Toggle quote (7 lines)
> * gnu/packages/vnc.scm (%tigervnc-version, %tigervnc-revision,
> %tigervnc-commit): New variables.
> (tigervnc-client): Update to 1.10.1-1.920d9c4.
> (tigervnc-server)[version]: Update to 1.10.1-1.920d9c4.
> [arguments]<#:phases>[patch-xserver]: Fix format procedure call.
> [native-inputs]: Use tigervnc-client package source.

[...]
Toggle quote (4 lines)
> +(define %tigervnc-version "1.10.1")
> +(define %tigervnc-revision "1")
> +(define %tigervnc-commit "920d9c4d6562ecabf79497bc901d50522d4bc661")

It would be good to leave a comment that this is not actually 1.10.1,
but a snapshot of the 'master' branch.

It would be even better to take the required patches and add it on the
1.10.1 tag.

Otherwise LGTM, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl64aU4ACgkQoqBt8qM6
VPr+CQgAkKVJp+YAhiwEnNTFKzIL/dy8EmPgrHKTkhq3c9INnuHYunbMbIOv+Tqk
0kCyJr04tvUrULEQIASqAtBFB8hpc0GTzOtlCD/3lCC1AFw8nRbe28Q2qEf00mYL
xAUfide+BpR2zsNfTfOXmMagltGTvm2bpE9d1gj2b8+F5mAYjKZ5Dyc5iSDitMl7
2oboLctPMHprty+W0bvNWmyXXBU8rd5TaqxjxyN4QbYSS9n8LLH/tNN+yqMUUUrH
+0mJcLm0Wha2BuEfv5OR5w0lpdpXM4ktB6PwGV+jpyeIVknK2H+WHFEqT5mltLCz
BtOIP8vmOClAT6SbcEwmmppnZItGlQ==
=kbg2
-----END PGP SIGNATURE-----

O
O
Oleg Pykhalov wrote on 11 May 2020 11:21
(address . 41175-done@debbugs.gnu.org)
87mu6eyghk.fsf@gmail.com
First of all thank you for review.


I'm not sure Marius's suggestion about patches is easily applicable,
because it would be a big list of patches and ‘which-patch’ procedure in
‘tigervnc-server’ package should be modified to work with an archive
produced by “origin source” with patches.

Instead I moved ‘%tigervnc-*’ variables to ‘tigervnc-client’ package and
use it as ‘(package-version tigervnc-client)’ in ‘tigervnc-server’.


Also comment about version could be omitted, because as I see we have a
practice to use ‘(commit version)’ in ‘git-reference’ in case we
strictly use release version, and ‘(let ((commit "GIT_HASH")) (package
...))’ in case we use a specific commit.


Pushed to master as d58c9574b3ea91bd796e6072d2ee2ba941abb9c7


Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAl65GQcACgkQFn+OpQAa
+pyncw/7B5C5zs1z2M67jEOutFg3Q7qLLqPET3RfqOy+cqXiYEooxJlHTBvYU60S
Kj1EO1dud0EdsTwnbhMIJ9MT9bl8wDeziTZ5zzL5/D1Itm6oWiJ3cirAR6eG72nz
kyyxPbT6IGjlxdKHj9nRkNqFw5ZKG2OLFlxeCM3rSJbSaITv4CUVnwOIAr3V6YHO
/GZ3RG0+W5z4f3Zbt0oTdRYcgLqhzteZ0bXesESJr3t/Pc56klYn8RbOt5efVFtb
3EDqm7OZOu0e8VS3uaMLqacs2DeOM2Kr1+O0gOni/7kJOTSpzR1NoDC2AjOOHMpn
FIlmssLO5BGMxtKzEkRW6BP7jJ+7W96Y615OC5MIP7lbf2gNFgCF8R/srYqWByaj
B+TDj4BOSU+nMyoj5MkRTqVRYCAmtYYwLz7DxtT9TswdJ8bMoGUvFF4vUGZ0phNI
KIroqTJK9jU4TzlKJcl5tdx7ir3fKiFhD0cSgnkG5SblJAm7CowYk8HpRYcf8neD
dfcvteG9i30qH3MB6NHBA7heGBCrcHTJqbx82MLsZaBMZSA06zUGJ9k7eVq+rcRs
IIIootOpin1F3oGQOBMrvuDl2xWEanP/He+SlFEa0SFNDY06cgAh+KULDwVwxtY0
wWNuxMdEws9O2n/UsCFlVzTycj3f5htj4j/WpcvEem9R+HRmx6Q=
=0NcW
-----END PGP SIGNATURE-----

Closed
?