[PATCH] Add cachefilesd

  • Done
  • quality assurance status badge
Details
2 participants
  • Jean-Baptiste Note
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Jean-Baptiste Note
Severity
normal
J
J
Jean-Baptiste Note wrote on 9 May 2020 15:19
(name . guixpatch)(address . guix-patches@gnu.org)
87eert6ybb.fsf@m4x.org
Dear guix maintainers,

Please find attached a patch to add a package for the cachefilesd
daemon, mostly used for read caching of NFS data. I've put in into
linux.scm as it's tightly coupled to the fscache linux module and is
being developed on git.kernel.org.

There's a lint warning for Software Heritage; however i've followed the
convention of using snapshot tarballs from kernel.org (we could also
directly go through git, but this seems less common).

A service will follow as soon as I understand how to correctly write
one.

Kind regards,
Jean-Baptiste
From 82a2807bd06abf88e8d01272e72635df9a077132 Mon Sep 17 00:00:00 2001
From: Jean-Baptiste Note <jean-baptiste.note@m4x.org>
Date: Fri, 8 May 2020 20:26:02 +0000
Subject: [PATCH] gnu: Add cachefilesd.

* gnu/packages/linux.scm (cachefilesd): New public variable.
---
gnu/packages/linux.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2d31444ea6..418b868698 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6802,3 +6802,38 @@ utilities. Using @code{kexec}, it is possible to boot directly into a new
kernel from the context of an already-running kernel, bypassing the normal
system boot process.")
(license license:gpl2)))
+
+(define-public cachefilesd
+ (package
+ (name "cachefilesd")
+ (version "0.10.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://git.kernel.org/pub/scm/linux/kernel/git/dhowells"
+ "/cachefilesd.git/snapshot/cachefilesd-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0g40ljjnn3wzh9gp6il21c95f977298qrrkrxfnwfl3k3asfmnbi"))))
+ (build-system gnu-build-system)
+ (outputs '("out"))
+ (arguments
+ `(#:tests? #f ; there are no tests
+ ; we emulate PREFIX with available variables
+ #:make-flags (let ((pfxdir (lambda (var dir)
+ (string-append var "=" %output "/" dir))))
+ (list "CC=gcc"
+ (pfxdir "SBINDIR" "sbin/")
+ (pfxdir "ETCDIR" "etc/")
+ (pfxdir "MANDIR" "share/man/")))
+ #:phases (modify-phases %standard-phases (delete 'configure))))
+ (home-page "https://people.redhat.com/~dhowells/cachefs/")
+ (synopsis "Backend daemon for the linux fscache")
+ (description "cachefilesd is a userspace daemon that implements the only
+cache backend currently available for FS-Cache, the linux caching system for
+network filesystems (such as NFS). It does the real work of caching by using
+files in a directory nominated by the administrator to store the data given to
+it. The contents of the cache, which should be stored locally, are persistent
+over reboots.")
+ (license license:gpl2+)))
--
2.26.2
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEPxcq3dp4FVY5UpckkC0pVsuz75YFAl62rcgACgkQkC0pVsuz
75a2yg//eAnEiEqdjsmGZ3wZvx4EcpkWcvD9PgYImIlCCnktQXp/zNwWTXOo/FqB
rkOZtiSa8pL32Bt/yrQjgQ3yjO5dU8IslgcW6Rfl5u6JpV0Tkr3XNQ1aA4NGGA+e
gszlHY4BETTnp4bdjjyauSZCA6/LISqYmGpNsawVixfTUsGMIdRiRXQtWDMX0Ln0
VP7tm4NTp8V69zTbkKAjRF4ebA7EoajVpk/sbzE1XfCx4/OqroStcN5S7bG/C/sy
o/A98Y4va0ubeClSrHSvF66fsXXEgtFoSB7336979AgDWQSK1dPWUbZ8er70LMW+
4g42t4vOJYSzm73IsHjgMddWZKf3S6nBSXjSTwneolDDMuodTqjSqxCJ9Fe863jb
qXCS3N0HkO40iNf6qiuoj0O4yi5mrkJNeQ+FcWoEOYfyAYycKLVLHG/DL+SBnTgB
5o2UL3cHwo/SdksE7wpwDtobGp4QaH9btP500+yWVgQfVxaFoUd+VnAQQhfNEbIm
v4901h4RUuylB+MyrttPlorgkb3SOYrv+S4z9a7KusgNnCDZdXw/qjzLjzcDZZPJ
kthOqq8pbGXpuk/RnopECxnugjQdp5LHQMrcTa9O1/hnJpwNZJInVwGb09gy5ycT
DsawKYXe6hGBsNZqaJxwsczUHDJoA4Q0uy1BIjh+8+zLu4mnEf0=
=ASy0
-----END PGP SIGNATURE-----

M
M
Mathieu Othacehe wrote on 10 May 2020 09:53
(name . Jean-Baptiste Note)(address . jean-baptiste.note@m4x.org)(address . 41149-done@debbugs.gnu.org)
87eersi5tb.fsf@gmail.com
Hello Jean-Baptiste,

Thanks for this patch! I fixed cross-compilation, adapted the synopsis
and description fields and pushed.

We will be happy to help write the associated service :)

Mathieu
Closed
?