emacs-guix: unrecognized keyword error

  • Done
  • quality assurance status badge
Details
4 participants
  • Christopher Howard
  • Ludovic Courtès
  • Maxim Cournoyer
  • Michael Rohleder
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal
C
C
Christopher Howard wrote on 3 May 2020 22:50
(address . bug-guix@gnu.org)
d38d4ee3848c092fca81399f1f3c6da3acb56790.camel@qlfiles.net
If I attempt to install a package in emacs-guix, process dies with
error

'''
scheme@(emacs-guix)> (process-package-actions "/var/guix/profiles/per-
user/christopher/guix-profile" #:install '((139934396296288 "out"))
#:upgrade '() #:remove '() #:use-substitutes? #t #:dry-run? #f)
The process begins ...
The following package will be installed:
pioneers 15.5

emacs-guix/actions.scm:118:8: In procedure process-package-actions:
Unrecognized keyword: #:use-substitutes?

Entering a new prompt. Type `,bt' for a backtrace or `,q' to continue.
scheme@(emacs-guix) [1]> ,bt
In emacs-guix/actions.scm:
118:8 0 (process-package-actions _ #:install _ #:upgrade _
#:remove _ #:use-substitutes? _ #:dry-run? _)
'''

I have attempted running the same command in the shell, remiving the
#:use-substitutes flag, but mysteriously get the same error.

System info:

christopher@nightshade ~$ guix describe
Generation 20 Apr 30 2020 05:34:14 (current)
guix f03e5ca
commit: f03e5ca59f2f099693def2c8e6ff409e5b4ed40a
christopher@nightshade ~$ neofetch
christopher@nightshade
----------------------
OS: Guix System f03e5ca59f2f099693def2c8e6ff409e5b4ed40a x86_64
Host: GA-880GM-UD2H
Kernel: 5.4.36-gnu
Uptime: 1 hour, 8 mins
Packages: 55 (guix-system), 136 (guix-user)
Shell: bash 5.0.7
Resolution: 1920x1200
DE: GNOME
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: .gnome-terminal
CPU: AMD Athlon II X3 455 (3) @ 3.300GHz
GPU: NVIDIA GeForce 8400 GS Rev. 3
Memory: 1000MiB / 7960MiB
christopher@nightshade ~$ emacs --version
GNU Emacs 26.3
Copyright (C) 2019 Free Software Foundation, Inc.
GNU Emacs comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GNU Emacs
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.

--
Christopher Howard
p: +1 (907) 374-0257
gpg: ADDEAADE5D607C8D (keys.gnupg.net)
L
L
Ludovic Courtès wrote on 5 May 2020 11:28
(name . Christopher Howard)(address . christopher.howard@qlfiles.net)
87sggen32m.fsf@gnu.org
Hi Christopher,

Christopher Howard <christopher.howard@qlfiles.net> skribis:

Toggle quote (14 lines)
> If I attempt to install a package in emacs-guix, process dies with
> error
>
> '''
> scheme@(emacs-guix)> (process-package-actions "/var/guix/profiles/per-
> user/christopher/guix-profile" #:install '((139934396296288 "out"))
> #:upgrade '() #:remove '() #:use-substitutes? #t #:dry-run? #f)
> The process begins ...
> The following package will be installed:
> pioneers 15.5
>
> emacs-guix/actions.scm:118:8: In procedure process-package-actions:
> Unrecognized keyword: #:use-substitutes?

This probably has to do with this API change:


I see it’s already reported upstream:


Thanks,
Ludo’.
M
M
Michael Rohleder wrote on 31 Jul 2020 09:20
(name . Ludovic Courtès)(address . ludo@gnu.org)
87k0ykduaw.fsf@rohleder.de
Ludovic Courtès <ludo@gnu.org> writes:
Toggle quote (11 lines)
>> emacs-guix/actions.scm:118:8: In procedure process-package-actions:
>> Unrecognized keyword: #:use-substitutes?
>
> This probably has to do with this API change:
>
> https://git.savannah.gnu.org/cgit/guix.git/commit/?id=65ffb9388c1c3d870cb07e4cb3ef12c9ac06a161
>
> I see it’s already reported upstream:
>
> https://gitlab.com/emacs-guix/emacs-guix/-/issues/18

This is fixed with the latest (gitlab) version:
From 1c58fd7f2de4623bb051e7f8472e703290663e64 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Fri, 31 Jul 2020 08:33:43 +0200
Subject: [PATCH] gnu: emacs-guix: Update to latest gitlab version.

* gnu/packages/emacs-xyz.scm (emacs-guix): Update to a 0.5.2 snapshot.
[source] changes to git-getch.
[snippet] removed.
[native-inputs] added tools to build.
---
gnu/packages/emacs-xyz.scm | 73 +++++++++++++++++++-------------------
1 file changed, 36 insertions(+), 37 deletions(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 04bb534ce7..ba16c84402 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2566,46 +2566,45 @@ type, for example: packages, buffers, files, etc.")
(license license:gpl3+)))
(define-public emacs-guix
- (package
- (name "emacs-guix")
- (version "0.5.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://emacs-guix.gitlab.io/website/"
- "releases/emacs-guix-" version ".tar.gz"))
- (sha256
- (base32
- "0yz64c0z4ygi2k4af18k4r1ncgys18jb8icywkp2g5pgmpn5l7ps"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Add support for Guile 3.0. Remove for versions > 0.5.2.
- (substitute* "configure"
- (("\"2\\.2 2\\.0\"")
- "\"3.0 2.2 2.0\""))
- #t))))
- (build-system gnu-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("emacs" ,emacs-minimal)))
- (inputs
- `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
- ("guix" ,guix)))
- (propagated-inputs
- `(("geiser" ,emacs-geiser)
- ("guile-gcrypt" ,guile-gcrypt)
- ("dash" ,emacs-dash)
- ("bui" ,emacs-bui)
- ("edit-indirect" ,emacs-edit-indirect)
- ("magit-popup" ,emacs-magit-popup)))
- (home-page "https://emacs-guix.gitlab.io/website/")
- (synopsis "Emacs interface for GNU Guix")
- (description
- "Emacs-Guix provides a visual interface, tools and features for the GNU
+ (let ((commit "df1fc5d8885959fd2bb83a443137d21c6850dd74")
+ (revision "1"))
+ (package
+ (name "emacs-guix")
+ (version (git-version "0.5.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/emacs-guix/emacs-guix")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14rn02ay1b8zl0pg54pkqpyzh948c4qiqlvl35627shx7zw5acqh"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)
+ ("emacs" ,emacs-minimal)))
+ (inputs
+ `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
+ ("guix" ,guix)))
+ (propagated-inputs
+ `(("geiser" ,emacs-geiser)
+ ("guile-gcrypt" ,guile-gcrypt)
+ ("dash" ,emacs-dash)
+ ("bui" ,emacs-bui)
+ ("edit-indirect" ,emacs-edit-indirect)
+ ("magit-popup" ,emacs-magit-popup)))
+ (home-page "https://emacs-guix.gitlab.io/website/")
+ (synopsis "Emacs interface for GNU Guix")
+ (description
+ "Emacs-Guix provides a visual interface, tools and features for the GNU
Guix package manager. Particularly, it allows you to do various package
management tasks from Emacs. To begin with, run @code{M-x guix-about} or
@code{M-x guix-help} command.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-build-farm
(package
--
2.28.0
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl8jxlcACgkQfHr/vv7y
yyW/IggAs+VlGrhyxUbc0hscbmxBoI2Db0EbF1pSwwy+QIoPuteyJqUVLlGWY3Zp
zJoriHjooaQinK7Fww0lUgYEBT9olY7eXo7U2rmNennm2Cj4cC9ixj5PZIDwB916
sV/0R1tvIlHdgdAbego82HADJAO45iCioD7aHf2fMkFvMA0ju0w3RqGp1m0Rq9y+
SH3zBFSwqbpgQGmyQBj8GRgl/o1llW72D06moXhjk1EtDD08sDrV1UVwC4RqHRKH
EIhj60qjPqxhh5jn/qW4hiGZd9T9HR8VuXx02GoDaZb8uRX20fduNcFGPMOp26A5
tI+L6JnHp7pBwdDbdjaZxapMp2yFGA==
=1GjO
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 3 Aug 2020 17:04
(name . Michael Rohleder)(address . mike@rohleder.de)
87bljrsrdn.fsf@gnu.org
Hi Michael,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (15 lines)
>
> This is fixed with the latest (gitlab) version:
>
> From 1c58fd7f2de4623bb051e7f8472e703290663e64 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Fri, 31 Jul 2020 08:33:43 +0200
> Subject: [PATCH] gnu: emacs-guix: Update to latest gitlab version.
>
> * gnu/packages/emacs-xyz.scm (emacs-guix): Update to a 0.5.2 snapshot.
> fix https://issues.guix.gnu.org/41063
> [source] changes to git-getch.
> [snippet] removed.
> [native-inputs] added tools to build.

Awesome. Applied, thanks!

Ludo’.
Closed
L
L
Ludovic Courtès wrote on 25 Aug 2020 11:50
(name . Michael Rohleder)(address . mike@rohleder.de)
87d03fyrzk.fsf@gnu.org
Hi Michael,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (25 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>>> emacs-guix/actions.scm:118:8: In procedure process-package-actions:
>>> Unrecognized keyword: #:use-substitutes?
>>
>> This probably has to do with this API change:
>>
>> https://git.savannah.gnu.org/cgit/guix.git/commit/?id=65ffb9388c1c3d870cb07e4cb3ef12c9ac06a161
>>
>> I see it’s already reported upstream:
>>
>> https://gitlab.com/emacs-guix/emacs-guix/-/issues/18
>
> This is fixed with the latest (gitlab) version:
>
> From 1c58fd7f2de4623bb051e7f8472e703290663e64 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Fri, 31 Jul 2020 08:33:43 +0200
> Subject: [PATCH] gnu: emacs-guix: Update to latest gitlab version.
>
> * gnu/packages/emacs-xyz.scm (emacs-guix): Update to a 0.5.2 snapshot.
> fix https://issues.guix.gnu.org/41063
> [source] changes to git-getch.
> [snippet] removed.
> [native-inputs] added tools to build.

It’s perhaps not directly related but there’s still something wrong with
this snapshot. If I do:

Toggle snippet (9 lines)
$ guix describe
Generacio 153 Aug 24 2020 10:53:47 (nuna)
guix c687299
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: c6872990b51971922f3064cba54ab752fcdc1559
$ guix environment -E ^TERM --ad-hoc emacs emacs-guix -C -- emacs -nw

and from there:

M-x guix RET p a

I get this error in the Guix REPL:

Toggle snippet (7 lines)
Error in evaluating guile expression: ice-9/boot-9.scm:1669:16: In procedure raise-exception:
Unbound variable: %max-returned-list-size

Entering a new prompt. Type `,bt' for a backtrace or `,q' to continue.
scheme@(emacs-guix) [1]>

Does that ring a bell?

Thanks,
Ludo’.
M
M
Maxim Cournoyer wrote on 1 Sep 2020 06:18
control message for bug #41063
(address . control@debbugs.gnu.org)
87tuwiyvrh.fsf@gmail.com
tags 41063 fixed
close 41063
quit
?