[PATCH] gnu: emacs-ess: Update to 18.10.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Tim Howes
Owner
unassigned
Submitted by
Tim Howes
Severity
normal
T
T
Tim Howes wrote on 3 May 2020 01:54
(address . guix-patches@gnu.org)
20200502235435.2983-1-timhowes@lavabit.com
* gnu/packages/statistics.scm (emacs-ess): Update to 18.10.2.
[source]: Use git-fetch and git-file-name. Fix snippets for removing
julia-mode and removing extra documentation formats. Add snippets for
installing elisp files and stopping installation of info directory.
Remove snippet for old failing test. Add snippet for new failing test.
[arguments]: Remove extra "/".
[native-inputs]: Add r-roxygen2.
---
Hello,
I have a patch for emacs-ess that upgrades the version to 18.10.2.
I switched the download mechanism to git-fetch since there was a
warning about using Github's automatically generated release files.
Additionally, there are a couple fixes applied to the Makefiles and
one of the tests.
Thanks,
Tim

gnu/packages/statistics.scm | 45 +++++++++++++++++++++++--------------
1 file changed, 28 insertions(+), 17 deletions(-)

Toggle diff (91 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 00b648a54c..0ead92dedf 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
+;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5786,42 +5787,51 @@ Java package that provides routines for various statistical distributions.")
(define-public emacs-ess
(package
(name "emacs-ess")
- (version "17.11")
+ (version "18.10.2")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/emacs-ess/ESS/archive/v"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-ess/ESS")
+ (commit (string-append "v" version))))
(sha256
(base32
- "0cbilbsiwvcyf6d5y24mymp57m3ana5dkzab3knfs83w4a3a4c5c"))
- (file-name (string-append name "-" version ".tar.gz"))
+ "1yq41l2bicwjrc0b731iic20cpcnz6ppigri1jn621qv2qv22vy3"))
+ (file-name (git-file-name name version))
(modules '((guix build utils)))
(snippet
'(begin
;; Stop ESS from trying to bundle an external julia-mode.el.
(substitute* "lisp/Makefile"
- (("^\tjulia-mode.elc\\\\\n") "")
- (("^dist: all julia-mode.el")
- "dist: all"))
- ;; No need to build docs in so many formats. Also, skipping
- ;; pdf lets us not pull in texlive.
+ (("^ess-julia.elc: julia-mode.elc") "")
+ (("^all: julia-mode.el")
+ "all:"))
+ ;; Include *.el files in install target.
+ (substitute* "lisp/Makefile"
+ (("\t\\$\\(INSTALL) \\$\\(ELC\\) \\$\\(LISPDIR\\)" elc)
+ (string-append "\t$(INSTALL) $(ELS) ess-autoloads.el "
+ "$(LISPDIR)\n" elc)))
+ ;; Only build docs in info format.
(substitute* "doc/Makefile"
- (("all : info text html pdf")
+ (("all : info text")
"all : info")
(("install: install-info install-other-docs")
"install: install-info"))
- ;; Test fails upstream
+ ;; Stop install-info from trying to update the info directory.
+ (substitute* "doc/Makefile"
+ ((".*\\$\\(INFODIR\\)/dir.*") ""))
+ ;; Fix roxygen preview test.
(substitute* "test/ess-r-tests.el"
- (("ert-deftest ess-r-namespaced-eval-no-srcref-in-errors ()")
- "ert-deftest ess-r-namespaced-eval-no-srcref-in-errors () :expected-result :failed"))
+ (("Add together two numbers.\n")
+ "Add together two numbers. ")
+ (("##' add\\(10, 1\\)") "add(10, 1)"))
#t))))
(build-system gnu-build-system)
(arguments
(let ((base-directory "/share/emacs/site-lisp"))
`(#:make-flags (list (string-append "PREFIX=" %output)
- (string-append "ETCDIR=" %output "/"
+ (string-append "ETCDIR=" %output
,base-directory "/etc")
- (string-append "LISPDIR=" %output "/"
+ (string-append "LISPDIR=" %output
,base-directory))
#:phases
(modify-phases %standard-phases
@@ -5840,6 +5850,7 @@ Java package that provides routines for various statistical distributions.")
("r-minimal" ,r-minimal)))
(native-inputs
`(("perl" ,perl)
+ ("r-roxygen2" ,r-roxygen2)
("texinfo" ,texinfo)))
(propagated-inputs
`(("emacs-julia-mode" ,emacs-julia-mode)))
--
2.26.2
M
M
Marius Bakke wrote on 5 May 2020 19:16
875zdaz4id.fsf@devup.no
Tim Howes via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (15 lines)
> * gnu/packages/statistics.scm (emacs-ess): Update to 18.10.2.
> [source]: Use git-fetch and git-file-name. Fix snippets for removing
> julia-mode and removing extra documentation formats. Add snippets for
> installing elisp files and stopping installation of info directory.
> Remove snippet for old failing test. Add snippet for new failing test.
> [arguments]: Remove extra "/".
> [native-inputs]: Add r-roxygen2.
> ---
> Hello,
> I have a patch for emacs-ess that upgrades the version to 18.10.2.
> I switched the download mechanism to git-fetch since there was a
> warning about using Github's automatically generated release files.
> Additionally, there are a couple fixes applied to the Makefiles and
> one of the tests.

Applied, thanks! This was not an easy patch, so kudos. :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6xn2oACgkQoqBt8qM6
VPoB1gf/akMljrsBV6gpPixb74jmmY0oUV4zeLbpxORBldf8sMfnglHYn0V1skTB
7Fqe9BDsSQmBx7F1a++OAvkqGnN3b+dVPsBJ/ie8Y56lRLh3LjcUVWmhhGRJb0cU
X7FRU2Py4AbaP8MGFO4iJxm701sEhtylC+Uw5VyKOxNt59fatVoJoNDgASIgIg6X
rm52ggps+qeq6aEeu00sOxGLEMVr4/LzKUZxKVRqGGw2fFYc55BCRRhs6WhUFwWp
ilfWRm42Y+ChYPCVU0Spr2Mf/UOPhAlFZflEb2TlsFCIEiDx4QGaMMJW1jH+O6bT
zQEmc7+Yrm0wr6xW5AJQFm4Cd5+8Cg==
=u7Lz
-----END PGP SIGNATURE-----

Closed
?