[PATCH] Add gccmakedep util

  • Done
  • quality assurance status badge
Details
2 participants
  • Jean-Baptiste Note
  • Marius Bakke
Owner
unassigned
Submitted by
Jean-Baptiste Note
Severity
normal
J
J
Jean-Baptiste Note wrote on 1 May 2020 22:53
(name . guixpatch)(address . guix-patches@gnu.org)
87d07nbcmy.fsf@m4x.org
Dear Guix maintainers,

I'm attempting to package x2go, and gccmakedep from the xorg utils is
required for the build.

This is therefore an attempt to package it -- so as to be able to use it
as native-input -- even though it is a deprecated tool.

There are two flavors of the patch:

- a -tar version which relies on a standard xorg mirror for download,
and does not need the maintainer tools to build. Unfortunately guix
lint reports a problem in that the tarball is not mirrored on software
heritage.

- a -git version which is a bit more convoluted to build (requires
maintainer tools as native-inputs: autoconf, automake, xorg macros),
but with no failure in guix lint.

Please also note that /some/ elements from this xorg subdirectory are
prefixed with util- -- i've chosen not to include it here.

Please pick your choose, and let me know how to proceed!

Kind regards,
Jean-Baptiste
From 900a831cc775ab35b1d728da2a06d69c5c03b838 Mon Sep 17 00:00:00 2001
From: Jean-Baptiste Note <jean-baptiste.note@m4x.org>
Date: Fri, 1 May 2020 14:15:07 +0000
Subject: [PATCH] xorg: Add gccmakedep.

* gnu/packages/xorg.scm (gccmakedep): New variable.
---
gnu/packages/xorg.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 80158b1cab..7ef09aca51 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6562,3 +6562,37 @@ Thai).")
a configuration file reusable by xcursorgen.")
(home-page "https://github.com/eworm-de/xcur2png")
(license license:gpl3+)))
+
+(define-public gccmakedep
+ (let ((commit "5787c2f5459e19bb7206c98116dbdec54da7bcc0")
+ (revision "1"))
+ (package
+ (name "gccmakedep")
+ (version (git-version "1.0.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/xorg/util/gccmakedep.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "034gp7b1f625gr1991ynkf2fj6lrg0k4980fpq655i3rzhdnjznm"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'autogen
+ (lambda _
+ (setenv "NOCONFIGURE" "t")
+ (invoke "sh" "autogen.sh"))))))
+ (native-inputs
+ `(("util-macros" ,util-macros)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (synopsis "Create dependencies in makefiles using 'gcc -M'")
+ (description
+ "The gccmakedep program calls 'gcc -M' to output makefile rules
+describing the dependencies of each sourcefile, so that make knows which
+object files must be recompiled when a dependency has changed.")
+ (home-page "https://gitlab.freedesktop.org/xorg/util/gccmakedep")
+ (license license:x11))))
--
2.26.2
From 92a05aa14cd74f2d5a4faa62cc34b29c5cc79c18 Mon Sep 17 00:00:00 2001
From: Jean-Baptiste Note <jean-baptiste.note@m4x.org>
Date: Fri, 1 May 2020 14:15:07 +0000
Subject: [PATCH] xorg: Add gccmakedep.

* gnu/packages/xorg.scm (gccmakedep): New variable.
---
gnu/packages/xorg.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 80158b1cab..738e98164e 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6562,3 +6562,23 @@ Thai).")
a configuration file reusable by xcursorgen.")
(home-page "https://github.com/eworm-de/xcur2png")
(license license:gpl3+)))
+
+(define-public gccmakedep
+ (package
+ (name "gccmakedep")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://xorg/individual/util/gccmakedep-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "1r1fpy5ni8chbgx7j5sz0008fpb6vbazpy1nifgdhgijyzqxqxdj"))))
+ (build-system gnu-build-system)
+ (synopsis "Create dependencies in makefiles using 'gcc -M'")
+ (description
+ "The gccmakedep is a deprecated program which calls 'gcc -M' to output
+makefile rules describing the dependencies of each sourcefile, so that make
+knows which object files must be recompiled when a dependency has changed.")
+ (home-page "https://gitlab.freedesktop.org/xorg/util/gccmakedep")
+ (license license:x11)))
--
2.26.2
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEPxcq3dp4FVY5UpckkC0pVsuz75YFAl6sjEUACgkQkC0pVsuz
75YVZw//YpQNLCLfd2YDkl+iRV9qElCAmkh92Do+W0CRHMmr99zLVL5092aajT1S
wAviCGpbI1agjBrRxnMcWtk6vKhqQIfR0LI2eugoR2AUfNY6S4MlN9vDAZIHBvvb
b3AsgFjruvTKTd92OVHmlpFjFd40xthEx05DYSJgBHeGNB04vcB57rxDB3bWhJcQ
K3zOKUeSoP3+Aynd1hDbmHc+3RHd56w0THSH/WhnQMoIlCQ9AIKjyMEvv5fPSp0S
QWiDEnT1f4jZ2v3GogDtWFdffh1WVoP7ztlTmcWyMDol/OAQfPucLwp5V4Cowwva
2FYO7rVFkTvl0a4+bsummK587uJKaGU5fp5FgdY9sQ4HhFbS2lbHes6/Z97Oe+aZ
xVfYZYoFK95bbfjrZ/XJpd5WNUZCABt+MdekE6kh+NQebzCSHjbC+BUQt87+F9Of
BNrrtfXbQNqBwnkz12QAzg5+Zuktdv6Xi7lsX+tl1ixIDolR45S9PKbIF7I3jNZQ
6sVncrprJIWNjuSsS2ZlUaIcztT/THNG/nNVgK9BNJdY/7NQQ5JquwbxkSwycSof
YEgTuD/DH75ikuqdrasFYn2zXyppAaPiuSix1wxj5vdSaPL5+k+Aft86ZZU4SrOf
20pZXbL0me6a3ZYFDwtgLK/Gigc4iE5r51IfNLNroQSJWSsAjcc=
=zFR1
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 5 May 2020 19:13
878si6z4mx.fsf@devup.no
Jean-Baptiste Note <jean-baptiste.note@m4x.org> writes:

Toggle quote (24 lines)
> Dear Guix maintainers,
>
> I'm attempting to package x2go, and gccmakedep from the xorg utils is
> required for the build.
>
> This is therefore an attempt to package it -- so as to be able to use it
> as native-input -- even though it is a deprecated tool.
>
> There are two flavors of the patch:
>
> - a -tar version which relies on a standard xorg mirror for download,
> and does not need the maintainer tools to build. Unfortunately guix
> lint reports a problem in that the tarball is not mirrored on software
> heritage.
>
> - a -git version which is a bit more convoluted to build (requires
> maintainer tools as native-inputs: autoconf, automake, xorg macros),
> but with no failure in guix lint.
>
> Please also note that /some/ elements from this xorg subdirectory are
> prefixed with util- -- i've chosen not to include it here.
>
> Please pick your choose, and let me know how to proceed!

Thanks! I applied the bootstrapped variant, with minor cosmetic changes
to the description and fixed indentation of the source section.

Software Heritage can currently only archive Git repositories, so the
lint warning is arguably misleading.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6xnsYACgkQoqBt8qM6
VPro9wf5AaHMoG2FwOeTqaHr/75wSJNkv9c4KmAnAgOVXne/Ygy2hcyqLbUwGP/1
/dEze4d0waHBt1+zKffJ5/dion+ppsHOVHNd/c7Z7qgxUMdZnbQQ1U2UNS5YZ5Ne
+vkn6bTpSHZFBBxXspwWrlsTw15EKN6levjphlmZejqIqNUOL+l1JrgXvTAtRxSa
ClRAEZjoRPD2OpGE/ctJlgFP228tQf/Ra2gJXTV8sOa5Q1caX5/gwXV9vGXoQQUT
W2EJ6mYyhqHiK/WxAHMCwxqr4AqrqXBVdtSEPdIocSXn8P8uOVRpIojJ/AH6SInH
o8OmTrs8DkuQ22tRfwCW/g+Ib4q/jA==
=U2wW
-----END PGP SIGNATURE-----

Closed
?