[PATCH] services: syslog: Simplify 'start' method.

  • Done
  • quality assurance status badge
Details
2 participants
  • Diego Nicola Barbato
  • Ludovic Courtès
Owner
unassigned
Submitted by
Diego Nicola Barbato
Severity
normal
D
D
Diego Nicola Barbato wrote on 28 Apr 2020 15:22
(address . guix-patches@gnu.org)
87tv13hhhp.fsf@GlaDOS.home
Hey Guix,

This patch simplifies the 'start' method of 'syslog-service-type' by
setting the umask using the new #:file-creation-mask parameter of
'make-forkexec-constructor', which was introduced in version 0.8.0 of
the Shepherd, instead of wrapping the constructor in a lambda.

Regards,

Diego
From 5ac4af21427afb8ef498b0de7151f116a6f7d9eb Mon Sep 17 00:00:00 2001
From: Diego Nicola Barbato <dnbarbato@posteo.de>
Date: Tue, 28 Apr 2020 13:31:54 +0200
Subject: [PATCH] services: syslog: Simplify 'start' method.

This is a followup to d7113bb655ff80a868a9e624c913f9d23e6c63ad and
e3358a831e7d5d9e8dc614340e49ea5aeb11a7ff.

* gnu/services/base.scm (syslog-service-type): Change 'start' method to set
umask using the #:file-creation-mask parameter of
'make-forkexec-constructor' introduced in version 0.8.0 of the Shepherd.
---
gnu/services/base.scm | 18 +++++++-----------
1 file changed, 7 insertions(+), 11 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 2913478e4a..0f119cc2f9 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -1316,17 +1316,13 @@ Service Switch}, for an example."
(documentation "Run the syslog daemon (syslogd).")
(provision '(syslogd))
(requirement '(user-processes))
- (start #~(let ((spawn (make-forkexec-constructor
- (list #$(syslog-configuration-syslogd config)
- "--rcfile"
- #$(syslog-configuration-config-file config))
- #:pid-file "/var/run/syslog.pid")))
- (lambda ()
- ;; Set the umask such that file permissions are #o640.
- (let ((mask (umask #o137))
- (pid (spawn)))
- (umask mask)
- pid))))
+ (start #~(make-forkexec-constructor
+ (list #$(syslog-configuration-syslogd config)
+ "--rcfile"
+ #$(syslog-configuration-config-file config))
+ ;; Set the umask such that file permissions are #o640.
+ #:file-creation-mask #o137
+ #:pid-file "/var/run/syslog.pid"))
(stop #~(make-kill-destructor))))))
;; Snippet adapted from the GNU inetutils manual.
--
2.26.0
L
L
Ludovic Courtès wrote on 1 May 2020 23:59
(name . Diego Nicola Barbato)(address . dnbarbato@posteo.de)(address . 40937-done@debbugs.gnu.org)
87lfmbb9lg.fsf@gnu.org
Hi,

Diego Nicola Barbato <dnbarbato@posteo.de> skribis:

Toggle quote (12 lines)
>>From 5ac4af21427afb8ef498b0de7151f116a6f7d9eb Mon Sep 17 00:00:00 2001
> From: Diego Nicola Barbato <dnbarbato@posteo.de>
> Date: Tue, 28 Apr 2020 13:31:54 +0200
> Subject: [PATCH] services: syslog: Simplify 'start' method.
>
> This is a followup to d7113bb655ff80a868a9e624c913f9d23e6c63ad and
> e3358a831e7d5d9e8dc614340e49ea5aeb11a7ff.
>
> * gnu/services/base.scm (syslog-service-type): Change 'start' method to set
> umask using the #:file-creation-mask parameter of
> 'make-forkexec-constructor' introduced in version 0.8.0 of the Shepherd.

Perfect! Applied, thanks.

Ludo’.
Closed
?