[PATCH] Add tarsplitter

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Lars-Dominik Braun
Owner
unassigned
Submitted by
Lars-Dominik Braun
Severity
normal
L
L
Lars-Dominik Braun wrote on 26 Apr 2020 18:58
(address . guix-patches@gnu.org)
20200426165808.GA206869@noor.fritz.box
Hi,

the attched patch adds the software tarsplitter. I wasn’t sure about the
file compression.scm, but all the file archive related software seems to
be in there too.

Cheers,
Lars
From 15496c335e1642339194b58a50b98f3241357d1f Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <lars@6xq.net>
Date: Sun, 26 Apr 2020 17:54:54 +0200
Subject: [PATCH] gnu: Add tarsplitter

* gnu/packages/compression.scm (tarsplitter): New variable
---
gnu/packages/compression.scm | 38 ++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 33801d201d..e8ddddf696 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -27,6 +27,7 @@
;;; Copyright � 2019 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright � 2020 Bj�rn H�fling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright � 2020 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright � 2020 Lars-Dominik Braun <lars@6xq.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -52,6 +53,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
@@ -2131,3 +2133,39 @@ independent. Supported formats are 7z, ARJ, bzip2, gzip, LHA, lzma, lzop,
RAR, RPM, DEB, tar, and ZIP. It cannot perform functions for archives, whose
archiver is not installed.")
(license license:gpl2+)))
+
+(define-public tarsplitter
+ (package
+ (name "tarsplitter")
+ (version "2.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AQUAOSOTech/tarsplitter.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17qkg95r97kcrs17b0mcqswx99280ni47j5yx8xa7nl3bdhm6325"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/AQUAOSOTech/tarsplitter"
+ #:install-source? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-documentation
+ (lambda* (#:key import-path outputs #:allow-other-keys)
+ (let* ((source (string-append "src/" import-path))
+ (out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version)))
+ (with-directory-excursion source
+ (install-file "README.md" doc))
+ #t))))))
+ (home-page "https://github.com/AQUAOSOTech/tarsplitter")
+ (synopsis
+ "Multithreaded tar utility")
+ (description
+ "Archive huge numbers of files, or spilt massive tar archives into smaller
+ chunks.")
+ (license license:expat)))
+
--
2.26.2
E
E
Efraim Flashner wrote on 26 Apr 2020 20:09
(name . Lars-Dominik Braun)(address . lars@6xq.net)(address . 40875-done@debbugs.gnu.org)
20200426180916.GF5243@E5400
Looks great. And I can't believe you found a go package without any
dependencies! (I joke). Patch pushed.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl6lzkwACgkQQarn3Mo9
g1HXZxAApPT8nV2JvtYhDHPmtZIgF+0O6QIXU6mmAs02t3LkawB9fndTZb36JYNT
YIG+Wet1fk2f8DU06UrraajZj80nCFTWHWZu1w2rrWFOYo7fSxi45FfammHCJ2Vc
YB8UBsQ+Vt61UdQFL2KS3Nd1U8HIPi9uMAaDdY2aD3Dra8OJ17dtCg03jxF1FrnG
m5T+KV9kLgBKAzddrnjVHjwezTDmPMD6TdPNMKvChHWCiuBQzrsSUhNlZ1Q3M1ft
qFPoHBYhrPgAhYiHmMOvgYceP8Az0gUV7G4rf6Nn/U7ldl0WCFn6IAjJHU/H0FWs
uMO+9enV2BpKKpqf/Z5pVhMmIRp3Ot7NMFpPcUlQJp1luMM2jMGJUeGeNjrukGWh
jrS5jfuhgRWEs32HbyCbYgen2IZgJ1Xf+vUvZYQwNHmRL7MAlQND3r1YS6rsGZ1q
JE1CntE9cnnQFg2GHpDw8FacScb6Gphcmt0zjES+2ckhfeLW0ZKTkpxRCbMXyM51
OCMhI33Po0nBjKrLyQ3Arg8C9bLt5XdgwSSOLKqqUswy4eJhz9xDlRnbww6bqF6b
HcQB0WtH3zGCPk5b9p5RB+k5lXnPfKmCSMQnKV4yTJLbzRLLTUICyZTtsU36EJaL
vApeQkDQc+KxD7ZAr0zKS7cBuvVuTLRr2QPrcgPl0wSrWwsFDdQ=
=uCQx
-----END PGP SIGNATURE-----


Closed
?