[PATCH] gnu: add wf-recorder

  • Done
  • quality assurance status badge
Details
One participant
  • Alex McGrath
Owner
unassigned
Submitted by
Alex McGrath
Severity
normal
A
A
Alex McGrath wrote on 16 Apr 2020 17:28
(address . guix-patches@gnu.org)(name . Alex McGrath)(address . amk@amk.ie)
20200416152831.28634-1-amk@amk.ie
---
gnu/packages/video.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 62cc423c09..5f2246616b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3920,3 +3920,33 @@ work-in-progress, aiming to support video-on-demand and live streaming
applications. It only supports Intel-compatible CPUs (x86).")
(home-page "https://github.com/OpenVisualCloud/SVT-AV1")
(license license:bsd-2)))
+
+(define-public wf-recorder
+ (package
+ (name "wf-recorder")
+ (version "0.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ammen99/wf-recorder.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cw6kpcbl33wh95pvy32xrsrm6kkk1awccr3phyh885xjs3b3iim"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("pulseaudio" ,pulseaudio)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)
+ ("libx264" ,libx264)))
+ (home-page "https://libgit2.github.com/")
+ (synopsis "Screen recorder for wlroots-based compositors")
+ (description
+ "wf-recorder is a utility program for screen recording of wlroots-based
+compositors (more specifically, those that support wlr-screencopy-v1 and
+xdg-output)")
+ (license license:mit)))
--
2.26.0
A
A
Alex McGrath wrote on 17 Apr 2020 21:46
close 40664
(name . control)(address . control@debbugs.gnu.org)
E1jPWwE-0006Md-Di@rmmprod06.runbox
close 40664
?