[PATCH] gnu: Add bchoppr.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Christopher Baines
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 10 Apr 2020 14:38
(name . Guix patches)(address . guix-patches@gnu.org)
a51e992c201a13e3f8f3bf43bf0f935c63e7b27a.camel@zrythm.org
Hi,

These patches add 3 new LV2 plugins by the same author as bsequencer:
bchoppr
bshapr
bjumblr

Thanks,
Alex
From 31fd828bc4a5bdec19770671ec55c5e2ec36af90 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 10 Apr 2020 13:36:23 +0100
Subject: [PATCH 3/3] gnu: Add bjumblr.

* gnu/packages/music.scm (bjumblr): new variable.
---
gnu/packages/music.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index d3936de348..1d570bc79a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5464,3 +5464,28 @@ B.Choppr is the successor of B.Slizr.")
(description "B.Shapr is a beat/envelope shaper LV2 plugin")
(home-page "https://github.com/sjaehn/BShapr")
(license license:gpl3+)))
+
+(define-public bjumblr
+ (package
+ (inherit bsequencer)
+ (name "bjumblr")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sjaehn/BJumblr.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14z8113zkwykbhm1a8h2xs972dgifvlfij92b08jckyc7cbz84ys"))))
+ (inputs
+ `(("cairo", cairo)
+ ("libsndfile", libsndfile)
+ ("lv2", lv2)))
+ (synopsis "Pattern-controlled audio stream/sample re-sequencer LV2 plugin")
+ (description "B.Jumblr is a pattern-controlled audio stream / sample
+re-sequencer LV2 plugin.")
+ (home-page "https://github.com/sjaehn/BJumblr")
+ (license license:gpl3+)))
--
2.26.0
From 46def2c5a6bb112375640e836ba426928d5e6a99 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 10 Apr 2020 13:35:49 +0100
Subject: [PATCH 2/3] gnu: Add bshapr.

* gnu/packages/music.scm (bshapr): new variable.
---
gnu/packages/music.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index fb8c0445bb..d3936de348 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5444,3 +5444,23 @@ sequence of up to 16 chops. Each chop can be leveled up or down (gating).
B.Choppr is the successor of B.Slizr.")
(home-page "https://github.com/sjaehn/BChoppr")
(license license:gpl3+)))
+
+(define-public bshapr
+ (package
+ (inherit bsequencer)
+ (name "bshapr")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sjaehn/BShapr.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jlq5rjicc4fxlpk869dg0l5bwwz8k9aj2wfk9v89b0qw8l8kaxl"))))
+ (synopsis "Beat/envelope shaper LV2 plugin")
+ (description "B.Shapr is a beat/envelope shaper LV2 plugin")
+ (home-page "https://github.com/sjaehn/BShapr")
+ (license license:gpl3+)))
--
2.26.0
From cb765aeba81d505a103203d6bfdf917fdf0b5bab Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 10 Apr 2020 13:34:17 +0100
Subject: [PATCH 1/3] gnu: Add bchoppr.

* gnu/packages/music.scm (bchoppr): new variable.
---
gnu/packages/music.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5257d9463a..fb8c0445bb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5422,3 +5422,25 @@ plugin and a standalone JACK application.")
offers an LV2 version ported by moddevices.")
(home-page "http://tap-plugins.sourceforge.net/")
(license license:gpl2))))
+
+(define-public bchoppr
+ (package
+ (inherit bsequencer)
+ (name "bchoppr")
+ (version "1.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sjaehn/BChoppr.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qq1bg1p4qawhwdag0j8hvf6kdsxkyn8gdjd9pbx00p1i314mp6r"))))
+ (synopsis "Audio stream-chopping LV2 plugin")
+ (description "B.Choppr cuts the audio input stream into a repeated
+sequence of up to 16 chops. Each chop can be leveled up or down (gating).
+B.Choppr is the successor of B.Slizr.")
+ (home-page "https://github.com/sjaehn/BChoppr")
+ (license license:gpl3+)))
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6QaL8ACgkQAi6uQjE9
cPPQ3gf6ArAEUg7/S/hh8Rvan7JhTM2Kpyx96dmP/qhldlvUvbni2OBIga00GYzU
sIefqq7IJHvZVBsuG+hxuMKfoRv25RFTreT11AnJsB70BbRCUbayU5U9v8mDlGTt
EvMiRtLpOsaC65dwvgYrPRPWfs0SGBzEs+azV2ijAvKcCOVpsTJFlaxcvG/kdOPk
I/Ler5SgYtjZwJITKcscEISRykWxIb+qjdJPYzwUjNSw4cvBQF9YGTFdy9LThvKD
iAKqPF9HMSGzXXF+DqUv3cBZQIMM6MotT/bQvuuA+gFthPDif5MaiSgHaFz7KtZL
CikRa7KDQGBAavabRmqJyvsZ4v48jQ==
=CuqF
-----END PGP SIGNATURE-----


A
A
Alexandros Theodotou wrote on 11 Apr 2020 18:15
(address . 40537@debbugs.gnu.org)
a401109b6c714c4aae69ad3ed54a6607672fae1c.camel@zrythm.org
Please use this patch instead for bchoppr (updated version to 1.4.2).
The author fixed a bug that was causing a crash in Zrythm.

Thanks,
Alex
From cb765aeba81d505a103203d6bfdf917fdf0b5bab Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 10 Apr 2020 13:34:17 +0100
Subject: [PATCH 1/3] gnu: Add bchoppr.

* gnu/packages/music.scm (bchoppr): new variable.
---
gnu/packages/music.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5257d9463a..fb8c0445bb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5422,3 +5422,25 @@ plugin and a standalone JACK application.")
offers an LV2 version ported by moddevices.")
(home-page "http://tap-plugins.sourceforge.net/")
(license license:gpl2))))
+
+(define-public bchoppr
+ (package
+ (inherit bsequencer)
+ (name "bchoppr")
+ (version "1.4.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sjaehn/BChoppr.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ympx0kyn3mkb23xgd44rlrf4qnngnlkmikz9syhayklgax7ijgm"))))
+ (synopsis "Audio stream-chopping LV2 plugin")
+ (description "B.Choppr cuts the audio input stream into a repeated
+sequence of up to 16 chops. Each chop can be leveled up or down (gating).
+B.Choppr is the successor of B.Slizr.")
+ (home-page "https://github.com/sjaehn/BChoppr")
+ (license license:gpl3+)))
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6R7TcACgkQAi6uQjE9
cPN+TQf9H3OYW2KfUgZDRni3JKEwoaJjxK4NzI+tRAzijpcEkax4wjJknymVd5sk
pGK8nNMU46V3uj5WrztSSD28OIAeZrlFepo1dvsGtbpHeOxPiJN0b6AYaZJ/XSAO
SQkRTzeSztLcQi2srkz9XNtquzLwCSEP0PkxZvZDEGHDr1O9kgSrtwsmNBr4rhkw
wSc2ykCVgU0rXPnnzgD/r89Wq9RsqNasbte+tzPBVTdhoLHP0nLT8tBJVvFrXGzB
vtkh6uae4YTnEkys+fbkpd2E4d33J83zM7u/59jGER8Ob6/zO+zOqelx7vYpTE02
gxQrIPGQ6+i1wFWtfBJyXHdx9KCnww==
=5LBT
-----END PGP SIGNATURE-----


C
C
Christopher Baines wrote on 14 Apr 2020 21:06
Re: [bug#40537] [PATCH] gnu: Add bchoppr.
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40537@debbugs.gnu.org)
878six7upd.fsf@cbaines.net
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (5 lines)
> These patches add 3 new LV2 plugins by the same author as bsequencer:
> bchoppr
> bshapr
> bjumblr

I've got a couple of comments. It looks to me like it would be clearer
to not have the packages inherit from bsequencer. Some copying in the
package definitions is fine if there are similarities between packages.

The second thing is that I'd try to avoid adding package definitions at
the end of files, just because it can lead to more merge conflicts.

Would you be able to send some updated patches?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl6WCc5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xc5TBAAtAoQlq740ohHRz/dvpVAbq4HlLzcR1/kLgjOHQE3w54ka/2ZHOVwAl0O
wBtGggOgvzFwV2Pd6T9OyMDSCtVaQVoB7VjNRxvuqXH/FWIjcK1JfpnU1i7Akyuc
7gAUAv8wukfVb2iXjAUbQMTivEUQWunDUMsN6Pz7QyAd9YZYCxjzVh3N+EgOhrwQ
iwNhz+ZANfY+hAcT3TQNSGsj96mnrpquC4Dx94few4ZwwmB5rImmy25sKtY3gXOy
q4RssTFPLxw+3M18PmJR++uGK8Khk/H2XZjDIVoy+R5dtpt7yqh7dIULPU921BQF
TmSPLSBzjROKEkU9L9QEE2hs0NZNC6WQrSsrZMtjiBbbqg1kisBotbzxvntwrFsP
EHChJaEjULPfw+eM2LUVgf8j2gj+oci5QJx0DLY3IMHlwNQwZ6sith2PG2Zh7Jj3
Zh6+1GjiBE7tBGUgbwJ31/saO/fDdEsF72GmZhRdg+tSDiksC65473JWB4fY0gBF
M98u1lR2kjQNZygwr6rWAOozwmSOzQHDsMDdi38StdBh0YDr7RfE9WhrcOlIejOl
6TEf1UOezK87stS5zUGBwwxQgMkkXGrWPEUghY6zClBm5daAQdsUqJdO0cz/oW1n
46+Dbh+1sMqv6W3yssuokqxJ/xWz+V0B/gmpjvQ7K8DNTkIPoTc=
=Yuxs
-----END PGP SIGNATURE-----

A
A
Alexandros Theodotou wrote on 28 Apr 2020 17:11
(name . Christopher Baines)(address . mail@cbaines.net)(address . 40537@debbugs.gnu.org)
81ab17c59752d69849e8ef41491ba3ad7bbb57d7.camel@zrythm.org
Hi Chris,

I think these should inherit from bsequencer since these are plugins by
the same author and it's reasonable that they follow the same build
procedure. We already to do this for other similar situations and it
also makes maintenance easier and DRY. Perhaps moving them below
bsequencer would be a better solution?

Toggle quote (4 lines)
> The second thing is that I'd try to avoid adding package definitions
> at
> the end of files, just because it can lead to more merge conflicts.

I'll keep this in mind for future patches.

Thanks,
Alex


On Tue, 2020-04-14 at 20:06 +0100, Christopher Baines wrote:
Toggle quote (23 lines)
> Alexandros Theodotou <alex@zrythm.org> writes:
>
> > These patches add 3 new LV2 plugins by the same author as
> > bsequencer:
> > bchoppr
> > bshapr
> > bjumblr
>
> I've got a couple of comments. It looks to me like it would be
> clearer
> to not have the packages inherit from bsequencer. Some copying in the
> package definitions is fine if there are similarities between
> packages.
>
> The second thing is that I'd try to avoid adding package definitions
> at
> the end of files, just because it can lead to more merge conflicts.
>
> Would you be able to send some updated patches?
>
> Thanks,
>
> Chris
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6oR48ACgkQAi6uQjE9
cPOlbgf/fXk5DHelcp8fmFUEw6ttMYGPp9Xz22NoPhnuId8mBKnkOCu7IZvMc0of
tSIdxKitqtALKy9mdDwuA3d+TGv9Fcz1FJG9N+wOckzUdyZgdwjJAMUhgzTwaeMW
/Yam8C0UHdA4X47Xx7oYbiPBFWLcxRIU7dN9JApFdtMVXZMiiTaFE/U6Q40UZS5W
aOrOqMAnE5dEE7XDImT1qGd7lnt3UB1zAtm1W84urJnSriJaB/K1zEwVaZvOeqWn
8rgS1JLzGccx7y97lnadFlhplUi43ljqzPHFwfNBG8VKYR0Izub5E0m9J+skJ8pl
F3YTCFMEdulFowuDhw5dnv3l/y5SwA==
=/ylv
-----END PGP SIGNATURE-----


C
C
Christopher Baines wrote on 3 May 2020 12:19
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40537-done@debbugs.gnu.org)
875zddmibf.fsf@cbaines.net
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (6 lines)
> I think these should inherit from bsequencer since these are plugins by
> the same author and it's reasonable that they follow the same build
> procedure. We already to do this for other similar situations and it
> also makes maintenance easier and DRY. Perhaps moving them below
> bsequencer would be a better solution?

Sorry for the slow reply. In terms of maintenance going forward, the
cost of inheritance is that it means that changes to one package
definition can effect others. So the question should be, should changes
to bsequencer like the inputs or arguments be applied to bchoppr as
well.

Anyway, these things become clearer with time. I've gone ahead and
pushed this (the 1.4.2 version) as
d5aee5003422c1cc4f3adfe016a24cc1b9c35881. I've moved the package up from
the bottom of the file, and tweaked the commit message (capital N in
new).

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl6umsRfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcOmQ//dkabc90sz7GWBIZ9X9Ubgo36edAmxtnQqbtqNlqtVLbmpOuFqpbM4jBA
VQojfncRRAAtWrvddsAq1KPFvQw+mmgYVh5Ity1YPZuIn50ZS+he+YA+HIMX6Yz1
K46Ldp7VOL63RGcelgCoh4K6AMqSd0oNTLYQogEXk2llIs/G+hnMjyXvRd39AFqE
K8mW3IQ2nU2Hj7BA8o7kVL86jQq/E2EJn6QIzMoF8SvcksFSZ/gYY6+3wsm39lqX
qqukVN72btSPMnoReHuhhlphDDvWReBvhTAlVKVBlFM39iR7DJaJD4ibq2xQ/JM5
zvLb2Qacr8kObnYMkSzwJhL+7uXH5r6XfbiWxUdV+AeHeBUnQhcuF8SDcjX21J8z
WdT88F1vnvI1pQGpmpDhUcZLgDvwe2Y0b8q8ljo4W3wrbw8TRweTPyWEOcSbvDzj
52SrPWJTyPuFZ05DyCJiHFH2TxpNKIsbduBsUQuvY4rU8U62Vwq5cp0PL4S1NKnW
bQJBZ5+YJpgem27fXiMskdE8eTnHSb3066mSMtIMFuKELJ8YQWzZT9WfiOJGOadB
xOCoYylXsB8kcw78iFSPSq/og+iY1Q+mUfEXOzeRAbq9iwRrJBoQXzBtNquMFn3b
7bGnpzGwFfWh3BFvjN/hxBkXKhCsfQO7sSfgNMqaIamVH13BZ6k=
=l/5n
-----END PGP SIGNATURE-----

Closed
?