[PATCH staging] gnu: ghc-7: Clean up package definition.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jakub K?dzio?ka
  • Marius Bakke
Owner
unassigned
Submitted by
Jakub K?dzio?ka
Severity
normal
J
J
Jakub K?dzio?ka wrote on 8 Apr 2020 12:21
(address . guix-patches@gnu.org)
20200408102142.3011-1-kuba@kadziolka.net
* gnu/packages/haskell.scm (ghc-7)[modules, imported-modules]: Remove
the unused rpath module.
[phases]: Use invoke instead of system*.
---
gnu/packages/haskell.scm | 13 +++++--------
1 file changed, 5 insertions(+), 8 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8db650e6ae..40490cbbb6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -183,11 +183,8 @@ top of CLISP.")
#:modules ((guix build gnu-build-system)
(guix build utils)
- (guix build rpath)
(srfi srfi-26)
(srfi srfi-1))
- #:imported-modules (,@%gnu-build-system-modules
- (guix build rpath))
#:configure-flags
(list
(string-append "--with-gmp-libraries="
@@ -214,7 +211,7 @@ top of CLISP.")
(with-directory-excursion ".."
(copy-file (assoc-ref inputs "ghc-testsuite")
"ghc-testsuite.tar.xz")
- (system* "tar" "xvf" "ghc-testsuite.tar.xz"))
+ (invoke "tar" "xvf" "ghc-testsuite.tar.xz"))
(substitute*
(list "testsuite/timeout/Makefile"
"testsuite/timeout/timeout.py"
@@ -233,7 +230,7 @@ top of CLISP.")
(with-directory-excursion ghc-bootstrap-path
(copy-file (assoc-ref inputs "ghc-binary")
"ghc-bin.tar.xz")
- (zero? (system* "tar" "xvf" "ghc-bin.tar.xz"))))
+ (invoke "tar" "xvf" "ghc-bin.tar.xz")))
(alist-cons-before
'install-bin 'configure-bin
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -265,7 +262,7 @@ top of CLISP.")
(setenv "LD_LIBRARY_PATH" gmp-lib)
;; The binaries have "/lib64/ld-linux-x86-64.so.2" hardcoded.
(for-each
- (cut system* "patchelf" "--set-interpreter" ld-so <>)
+ (cut invoke "patchelf" "--set-interpreter" ld-so <>)
binaries)
;; The binaries include a reference to libtinfo.so.5 which
;; is a subset of libncurses.so.5. We create a symlink in a
@@ -284,7 +281,7 @@ top of CLISP.")
(setenv "PATH"
(string-append (getenv "PATH") ":"
ghc-bootstrap-prefix "/bin"))
- (system*
+ (invoke
(string-append (getcwd) "/configure")
(string-append "--prefix=" ghc-bootstrap-prefix)
(string-append "--with-gmp-libraries=" gmp-lib)
@@ -294,7 +291,7 @@ top of CLISP.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(with-directory-excursion
(string-append ghc-bootstrap-path "/ghc-7.8.4")
- (zero? (system* "make" "install"))))
+ (invoke "make" "install")))
%standard-phases)))))))
(native-search-paths (list (search-path-specification
(variable "GHC_PACKAGE_PATH")
--
2.26.0
M
M
Marius Bakke wrote on 8 Apr 2020 12:38
87v9majm8n.fsf@devup.no
Jakub K?dzio?ka <kuba@kadziolka.net> writes:

Toggle quote (4 lines)
> * gnu/packages/haskell.scm (ghc-7)[modules, imported-modules]: Remove
> the unused rpath module.
> [phases]: Use invoke instead of system*.

This LGTM, but there have been a few changes to GHC on 'core-updates' so
I'd prefer to hold this patch until core-updates is merged to avoid
needless conflicts.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6NqagACgkQoqBt8qM6
VPrsaQgAqwjom/9ZwWBB24g2D8jiIxh4T99OmT9xVpaOCqaec3xks2L/jiehVafP
7Qg7Lb8kJWSDEiEEW2kI8PAnu29BBX7/XaNRiS7UMwewf2KJhHPTrzbcEVqQhvAE
2mNEF7T2lFJBS+qn42na8akWNHl4f8GCtVTSSr091U6YscWcBiWt4D6y9FkKIRPR
o7a4fvq8WvuMYxHtOmVEKnPnqBhUkdiU7EM28gEZD2WWuR7qN3ujra5DRz9ab7/J
d+LxvYxzSil9YmhX2VgF0VBNS7BnKwMdbaBFZi7/FrFg34QZkxW0K45tCaRMtVLJ
8qiSQewS6WDonUIBMYxlJvUunola0g==
=bpUt
-----END PGP SIGNATURE-----

J
J
Jakub K?dzio?ka wrote on 1 Jun 2020 17:45
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 40503-done@debbugs.gnu.org)
20200601154520.3tnnq5lbzjfxayux@gravity
On Wed, Apr 08, 2020 at 12:38:32PM +0200, Marius Bakke wrote:
Toggle quote (10 lines)
> Jakub K?dzio?ka <kuba@kadziolka.net> writes:
>
> > * gnu/packages/haskell.scm (ghc-7)[modules, imported-modules]: Remove
> > the unused rpath module.
> > [phases]: Use invoke instead of system*.
>
> This LGTM, but there have been a few changes to GHC on 'core-updates' so
> I'd prefer to hold this patch until core-updates is merged to avoid
> needless conflicts.

Following the core-updates merge, I have committed the change to staging
as commit f20d1cfb51ed14f325da000406807076323f70bc.

Regards,
Jakub K?dzio?ka
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl7VIo8ACgkQ4xWnWEYT
FWR9/A//WHV3jCFfpE52m2iL+JYqg532V/uWcx/FWDmlnyJ1umCsTthjbCdA8bQk
74KwDZNuE3Y1Z8Kg6AHHXVO6V7VyehVFwAHqSkc19j0qENDqcfGZsbThSwA0CutG
DtCIjWv9ZJJpre2DOHdhSm9nv1HQzqxk3tGImlSv54DX5zDjaGgkC51q5zHXaQhK
RQVqHBOvSrw3BBE16z9xWJti8Ze7EskkN9xhhKiDZThPfkGYJo3LYoixqNlbsoAC
Xlku3iLMKwH2DummmaOMztdbj750ty0q8AEJ8QQQenS7bR2GBgI8ao3kBwvLIREb
tGrlSw6GhTuh5lmr64WdZjvnQ4hBvCHX6/ZI6cIRANyzubBw46TmTismJEx739SV
a8Z5ehAIUS+9vB1ckMU08coPS+P6RsVJzU5Vz3/0et7D+GcfiOF7ppKOAHriGLuG
sC8N/ZaCC3k+Rk4CNnRMaZkBMJcSF6to/yI7+d45VPmN8PZrwaGc83NWyEejF1oj
Pf0f3LoGdYibgfNzrQV0izeCWfSH1rKol40vKU15KiVNDvHsYRugJoPc3mKHd+8/
4xiqhjxTKYary/CFUEKoX1EfN9kicOo6LJoXKCp2rP9qIVEisZoA64jnui999hjs
9KJ+fzs3JQCYpDw33OO9FJ/a8A/rHVoIds8XfUvCUqzDvd7Msp8=
=bIg0
-----END PGP SIGNATURE-----


Closed
?