[PATCH] gnu: Add jsonrpc-glib.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 4 Apr 2020 22:47
(name . Guix patches)(address . guix-patches@gnu.org)
e4f85156b306ed70bfa07b8f3764f841e6f8aad3.camel@zrythm.org
Hi,

I was trying to build GNOME builder but it was failing. Anyway, here is
one of its dependencies, would be useful when someone tries to package
it again.

Thanks,
Alex
From 85f9832d560fbb4ea032c291bf98f73e3ac74b1f Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 4 Apr 2020 21:45:50 +0100
Subject: [PATCH] gnu: Add jsonrpc-glib.

* gnu/packages/gnome.scm (jsonrpc-glib): New variable.
---
gnu/packages/gnome.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f93dd2649c..edd7caa4ad 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
+;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3402,6 +3403,36 @@ various wrappers for the complex data types employed by JSON, such as arrays
and objects.")
(license license:lgpl2.1+)))
+(define-public jsonrpc-glib
+ (package
+ (name "jsonrpc-glib")
+ (version "3.32.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/jsonrpc-glib.git")
+ (commit version)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0mjr4g6jm3nwsjw0mnwnxr7ndnzaq2b2pr92xk1dmnca5znmal34"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("glib" ,glib)
+ ("json-glib" ,json-glib)
+ ("gobject-introspection" ,gobject-introspection)
+ ("vala" ,vala)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://gitlab.gnome.org/GNOME/jsonrpc-glib")
+ (synopsis "JSON-RPC library for GLib")
+ (description "Jsonrpc-GLib is a library to communicate with JSON-RPC
+based peers in either a synchronous or asynchronous fashion. It also
+allows communicating using the GVariant serialization format instead of
+JSON when both peers support it. You might want that when communicating
+on a single host to avoid parser overhead and memory-allocator fragmentation.")
+ (license license:lgpl2.1+)))
+
(define-public libxklavier
(package
(name "libxklavier")
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6I8m8ACgkQAi6uQjE9
cPON2wf/elasnivEWupYzzHaSiXBn464i+naM9SjSsJv6cb5Umdx1bbKettIBSgm
hCuIWcVXs28zGhCk5bs1a0K+nfYCImIeefrbo84eDdEJYTEDRXd8wsqmDy8ZXn1+
LWj9OegLCyzgLCa9sY6I9AwN9hGXISR6ChWOpvN5FuPsiWKeRserGEiq/arH8HfA
PLuJJfc+c+V8TZbeKrjPTTLmjWjZWmmS7y1kXeNbH9D6WKxVKGl3rBwy+1KKtHNG
J3guoYa7OcFL1bC30euTlorGchp6IFHql04+p4wEgxP+q0F9dp1AeurzOa05JVeX
naEUZdbWGeYsEiKWnkl/bFEDrM9QaQ==
=c+Bi
-----END PGP SIGNATURE-----


M
M
Mathieu Othacehe wrote on 5 Apr 2020 11:04
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40438-done@debbugs.gnu.org)
87369itib7.fsf@gmail.com
Hello Alexandros,

I pushed this one with the following modifications:

Toggle diff (55 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 30a897971e..5954b8cf7c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9962,29 +9962,29 @@ audio files.")
(define-public jsonrpc-glib
(package
(name "jsonrpc-glib")
- (version "3.32.0")
+ (version "3.34.0")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.gnome.org/GNOME/jsonrpc-glib.git")
- (commit version)))
- (file-name (string-append name "-" version "-checkout"))
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
(sha256
- (base32
- "0mjr4g6jm3nwsjw0mnwnxr7ndnzaq2b2pr92xk1dmnca5znmal34"))))
+ (base32
+ "0j05x4xv2cp3cbmp30m68z8g4rdw7b030ip4wszyfj9ya15v5kni"))))
(build-system meson-build-system)
(inputs
- `(("glib" ,glib)
+ `(("json-glib" ,json-glib)
+ ("glib" ,glib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("glib:bin" ,glib "bin") ; for glib-genmarshal, etc.
("gobject-introspection" ,gobject-introspection)
- ("json-glib" ,json-glib)
("vala" ,vala)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
(home-page "https://gitlab.gnome.org/GNOME/jsonrpc-glib")
(synopsis "JSON-RPC library for GLib")
- (description "Jsonrpc-GLib is a library to communicate with JSON-RPC
-based peers in either a synchronous or asynchronous fashion. It also
-allows communicating using the GVariant serialization format instead of
-JSON when both peers support it. You might want that when communicating
-on a single host to avoid parser overhead and memory-allocator fragmentation.")
+ (description "Jsonrpc-GLib is a library to communicate with JSON-RPC based
+peers in either a synchronous or asynchronous fashion. It also allows
+communicating using the GVariant serialization format instead of JSON when
+both peers support it. You might want that when communicating on a single
+host to avoid parser overhead and memory-allocator fragmentation.")
(license license:lgpl2.1+)))

Thanks,

Mathieu
Closed
?