[PATCH] gnu: Add jsonrpc-glib.

  • Done
  • quality assurance status badge
Details
3 participants
  • Alexandros Theodotou
  • Efraim Flashner
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 3 Apr 2020 01:47
(name . Guix patches)(address . guix-patches@gnu.org)
3867326c930f269acf52e72bc93e49f2af53fbcc.camel@zrythm.org
Hi,

I tried building gnome-builder but I was having unknown problems so I
gave up. Anyway, this is one of its dependencies so it would make the
life of whoever tries to package gnome builder later easier.

Thanks,
Alex
From 4d96ac7b836f1c1029d79c1fa632d4cc16cb7e9c Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 3 Apr 2020 00:44:07 +0100
Subject: [PATCH] gnu: Add jsonrpc-glib.

* gnu/packages/gnome.scm: (jsonrpc-glib) New variable.
---
gnu/packages/gnome.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b29acf3225..8d461330de 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9942,3 +9942,33 @@ to.")
environment. Its main purpose is the manual transcription of spoken
audio files.")
(license license:gpl3+))))
+
+(define-public jsonrpc-glib
+ (package
+ (name "jsonrpc-glib")
+ (version "3.32.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/jsonrpc-glib.git")
+ (commit version)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0mjr4g6jm3nwsjw0mnwnxr7ndnzaq2b2pr92xk1dmnca5znmal34"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("glib" ,glib)
+ ("gobject-introspection" ,gobject-introspection)
+ ("json-glib" ,json-glib)
+ ("vala" ,vala)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://gitlab.gnome.org/GNOME/jsonrpc-glib")
+ (synopsis "JSON-RPC library for GLib")
+ (description "Jsonrpc-GLib is a library to communicate with JSON-RPC
+based peers in either a synchronous or asynchronous fashion. It also
+allows communicating using the GVariant serialization format instead of
+JSON when both peers support it. You might want that when communicating
+on a single host to avoid parser overhead and memory-allocator fragmentation.")
+ (license license:lgpl2.1+)))
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6GeZsACgkQAi6uQjE9
cPMC2AgAqo5F2ugdjtbimLSwJXKfSx43+c+DAGfD21KFRrjA8SRfR31+4+r92VAe
s4+izTsOWvA7TcKtLPurpUvsZvHexVXHbFa5f2MPA/LXxsPgz5Tx6YAtGHwOvr+q
2sCzFh4q8lfHF8wF7dYJYiHGuotflC9EQ5UFXsajrWL58m6U1xXGfnaM5N6t/vLR
52owVWNtT81OxAdeV6txUaYlkXvqFW0iDDbMzpkQY5PhYForVpYDFBrja1jDGeoA
jtZGdZMpcFjy7JoFruS1AQUnhCQMM9H2BBx2kcI36ExQtKaxNjMhTZQNP2DktXIB
86Vd8I1dA8kidbqKZ+uuXi7YI85Qhw==
=Jpsc
-----END PGP SIGNATURE-----


M
M
Mathieu Othacehe wrote on 5 Apr 2020 11:06
control message for bug #40398
(address . control@debbugs.gnu.org)
87zhbqs3mm.fsf@gmail.com
close 40398
quit
E
E
Efraim Flashner wrote on 19 Apr 2020 20:44
Re: [bug#40398] [PATCH] gnu: Add jsonrpc-glib.
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40398-done@debbugs.gnu.org)
20200419184441.GA962@E5400
It looks like this patch was applied, closing the bug

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl6cnBcACgkQQarn3Mo9
g1Fzew//ZJBPb1TnLJZ20brGKXxfX/ZOFP5GWYhCD2zHtFj9/S4A3RFhySHrWZho
tu3b4yn4ZRRn9zvPcnI558/7QIitGxooTlSE15xEMK30dNcbWGAvT4kOqBHVoGl/
2uiCu8nL/6ypvZgfVAip3RaLUDRC9UPSt99bqSSGZEjRibP412+vbt/fx0jXrd2i
bfBsmQ7iWSw4QaM/I3KGeilVPo79O9PghYw7y9alBTw7sNJ7lS50Ic2evdkLos9c
7y/jpe+HKCaqAcZGw7vOW+H7DkLCYBByKJ2bsr7kUvuYPLfW5TgqLi/gDj2A777a
/X8TaTKTXNGjs6V2izNysOWlvoK5STalmX4OurP+xjrrZoJn1nga/qzg1okqLUOG
1tIAtx1sbP1S9CmmWRzXWLTtQ75WSBeG1pDB4mdrkN/Nsw7ck60NPue7on++6yBw
3tOW29V2ftnXB9tp6pB/jW1eV30ZcI/zX5Ws1bUnpqygLv9ayvHIWg6w6cSw18PC
w1TdY4jXK9a9h8TrjoPLU2n/7ql8ZTcR8/HfzoIvVL/OhK/JWFPBUCBKR3pv4cyN
3OngpTEkMST7+fg8FaBPNY+4qeQOel9mLoQQqeIXVrSW9zqIJ1I0EeumriAJe/rW
Ah4xLiep+0+Ot5FpMejfie9gGM6t/2P6kJc70hZikDU1EVQsIrM=
=rzk8
-----END PGP SIGNATURE-----


Closed
?