[PATCH] gnu: Add emacs-racer.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
John Soo
Severity
normal
J
J
John Soo wrote on 29 Mar 2020 03:14
(address . guix-patches@gnu.org)
87eetc2c94.fsf@asu.edu
Hi Guix,

I don't write a lot of rust but racer provides excellent completion for
emacs.

Thanks,

John
Toggle quote (1 lines)
>From 2d61455ba198cfd02a6056170889f274a6ed577e Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 24 Mar 2020 08:18:34 -0700
Subject: [PATCH] gnu: Add emacs-racer.

* gnu/packages/emacs-xyz.scm (emacs-racer): New variable.
---
gnu/packages/emacs-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d40b8019e..9dfdb120ce 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21776,3 +21777,37 @@ enables modal editing and composition of commands, too. It combines ideas of
other Editors like Vim or Kakoune and tries to align them with regular Emacs
conventions.")
(license license:gpl3+)))
+
+(define-public emacs-racer
+ (package
+ (name "emacs-racer")
+ (version "1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/racer-rust/emacs-racer")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xj5iki10cg8j8vvqjlw6lfx97k3agwirhchcjnzbnkry48x9qi6"))))
+ (inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-pos-tip" ,emacs-pos-tip)
+ ("emacs-rust-mode" ,emacs-rust-mode)
+ ("emacs-s" ,emacs-s)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/racer-rust/emacs-racer")
+ (synopsis "Racer support for Emacs")
+ (description
+ "This is the official Emacs package for Racer. Features:
+
+@itemize
+@item Completion
+@item Find Definitions
+@item Describe Functions and Types
+@end itemize")
+ (license license:expat)))
--
2.26.0
N
N
Nicolas Goaziou wrote on 30 Mar 2020 15:02
(name . John Soo)(address . jsoo1@asu.edu)(address . 40302-done@debbugs.gnu.org)
87h7y6807n.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (3 lines)
> I don't write a lot of rust but racer provides excellent completion for
> emacs.

I activated tests, reworded the description and applied this as
ea5a3a43f87c639751a692651c367cdae9fc0e36.

Thank you!

Regards,

--
Nicolas Goaziou
Closed
?