[PATCH] Add emacs-evil-escape

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
John Soo
Severity
normal
J
J
John Soo wrote on 29 Mar 2020 00:56
(address . guix-patches@gnu.org)
87v9mo2fun.fsf@asu.edu
Hi Guix,

evil-escape provides an easy way to always get to evil's normal from
many modes.

Thanks,

John
Toggle quote (1 lines)
>From d6f2e25d38ac27ade84d023c5ea73e62152aa116 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:50:08 -0700
Subject: [PATCH] gnu: Add emacs-evil-escape.

* gnu/packages/emacs-xyz.scm (emacs-evil-escape): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d40b8019e..b91b662ac6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21776,3 +21777,28 @@ enables modal editing and composition of commands, too. It combines ideas of
other Editors like Vim or Kakoune and tries to align them with regular Emacs
conventions.")
(license license:gpl3+)))
+
+(define-public emacs-evil-escape
+ (package
+ (name "emacs-evil-escape")
+ (version "3.14")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/syl20bnr/evil-escape")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0s8lmmm25qabicwaj9jybpbd8mkc62yl7jnhk1lpablydjkv3w2i"))))
+ (inputs
+ `(("emacs-evil" ,emacs-evil)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/syl20bnr/evil-escape")
+ (synopsis "Escape from insert state and everything else in Emacs")
+ (description
+ "Customizable key sequence to escape from insert state and everything
+else in Emacs.")
+ (license license:gpl3+)))
--
2.26.0
N
N
Nicolas Goaziou wrote on 30 Mar 2020 15:01
(name . John Soo)(address . jsoo1@asu.edu)(address . 40296-done@debbugs.gnu.org)
87lfni80aa.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (3 lines)
> evil-escape provides an easy way to always get to evil's normal from
> many modes.

Applied as 9a69218a1636ebdf5b456fc8025a8ad234b9f2f1.

Thank you!

Regards,

--
Nicolas Goaziou
Closed
?