[PATCH] gnu: Add lv2toweb.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 21 Mar 2020 20:41
(name . Guix patches)(address . guix-patches@gnu.org)
e182b319fa8017a5d150d6e5572405509e6f0c97.camel@zrythm.org
Hi,

This patch adds lv2toweb, an HTML document generator for lv2 plugins
based on their metadata.

Thanks,
Alex
From aca67249cab61ef85ad164c8f87d7eb4f68b98b3 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 21 Mar 2020 19:38:41 +0000
Subject: [PATCH] gnu: Add lv2toweb.

* gnu/packages/audio.scm (lv2toweb): New variable.
---
gnu/packages/audio.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f3edd21c69..bad6f4a18d 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -78,6 +78,7 @@
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
+ #:use-module (gnu packages man)
#:use-module (gnu packages maths)
#:use-module (gnu packages mp3) ;taglib
#:use-module (gnu packages multiprecision)
@@ -4081,3 +4082,39 @@ given plugin and its UI(s) match up with the provided metadata and adhere
to well-known best practices.")
(home-page "https://open-music-kontrollers.ch/lv2/lv2lint/")
(license license:artistic2.0)))
+
+(define-public lv2toweb
+ (package
+ (name "lv2toweb")
+ (version "0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/x42/lv2toweb")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "007aysqvgkf25za8nkmyd5g9kp1zla460dcpidlj5xg1zc3fcdfi"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("jalv", jalv)
+ ("lilv", lilv)))
+ (native-inputs
+ `(("help2man", help2man)
+ ("pkg-config", pkg-config)))
+ (synopsis "Documentation generator for LV2 plugins")
+ (description
+ "lv2toweb allows the user to create an xhtml page with information
+about the given LV2 plugin, provided that the plugin and its UI(s) match up
+with the provided metadata and adhere to well-known best practices.")
+ (home-page "https://github.com/x42/lv2toweb")
+ (license (list license:isc license:gpl2))))
--
2.25.1
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl52bfIACgkQAi6uQjE9
cPPV1Qf/e8yRVlvBSex1n4zhWQtWliAOdasCBBmzCSU7p6M4Grki7uVZlCthc1uz
GWjOWCclWCPlowjswlYLvQf6KQkp0k7tiGmntAKNCc++QDaEd6sRAXjUQnVo113h
WpN2jPBCdeUQ0JsIkPPMFfGaIFNNSjeXCfTQlrWpr4KlC/5zimFXnacYW6RgxGW3
3IW0TEN74u1mrZu1sNndlSMht9Qw3bnY0Q5d2bzdswJeVx2EH2kbPphtbirIqEFa
iL0hIvkBwu8sQlemcPKe5Q9Ymq7YdnINChu2LTNkbkksn/KcHBTPl6KmBoYFYfC6
Uy+K14V/i/2LIaJ5BYEsbaoy33DEwQ==
=VXVW
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 23 Mar 2020 10:45
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40171-done@debbugs.gnu.org)
87y2rrquag.fsf@gnu.org
Hi Alexandros,

Alexandros Theodotou <alex@zrythm.org> skribis:

Toggle quote (7 lines)
> From aca67249cab61ef85ad164c8f87d7eb4f68b98b3 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Sat, 21 Mar 2020 19:38:41 +0000
> Subject: [PATCH] gnu: Add lv2toweb.
>
> * gnu/packages/audio.scm (lv2toweb): New variable.

Applied, thanks!

Ludo’.
Closed
?