[PATCH] hydra: Display the IRC logs in reverse chronological order.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 20 Mar 2020 22:43
(address . guix-patches@gnu.org)(address . rekado@elephly.net)
3b38c211b2c959077385c0267ed3b1875d396bfc.1584740629.git.leo@famulari.name
I think that people usually want to read the latest logs, which
currently requires a lot of scrolling.

* hydra/goggles.scm (index): Reverse the list of log files.
---
hydra/goggles.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (19 lines)
diff --git a/hydra/goggles.scm b/hydra/goggles.scm
index 169b3c3..884c8df 100644
--- a/hydra/goggles.scm
+++ b/hydra/goggles.scm
@@ -181,9 +181,9 @@ freenode." channel))
(ul
,@(map (lambda (file)
`(li (a (@ (href ,(string-append "/" channel "/" file))) ,file)))
- (or (scandir (string-append %log-root "/#" channel "/")
- (lambda (name)
- (not (member name '("." ".." "index.html")))))
+ (or (reverse (scandir (string-append %log-root "/#" channel "/")
+ (lambda (name)
+ (not (member name '("." ".." "index.html"))))))
'()))))))
(define %controller
--
2.25.1
R
R
Ricardo Wurmus wrote on 22 Mar 2020 12:43
(name . Leo Famulari)(address . leo@famulari.name)(address . guix-patches@gnu.org)
87lfnslimo.fsf@elephly.net
Hi Leo,

Toggle quote (5 lines)
> I think that people usually want to read the latest logs, which
> currently requires a lot of scrolling.
>
> * hydra/goggles.scm (index): Reverse the list of log files.

Looks good, thank you. I’ve applied it. We’ll have to wait for the
next reconfiguration to see the effects on logs.guix.gnu.org.

--
Ricardo
L
L
Leo Famulari wrote on 22 Mar 2020 18:41
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 40157-done@debbugs.gnu.org)
20200322174130.GA1459@jasmine.lan
On Sun, Mar 22, 2020 at 12:43:43PM +0100, Ricardo Wurmus wrote:
Toggle quote (8 lines)
> > I think that people usually want to read the latest logs, which
> > currently requires a lot of scrolling.
> >
> > * hydra/goggles.scm (index): Reverse the list of log files.
>
> Looks good, thank you. I’ve applied it. We’ll have to wait for the
> next reconfiguration to see the effects on logs.guix.gnu.org.

Thanks!
Closed
?