[PATCH] gnu: subversion: Support running the tests in parallel.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 6 Feb 2020 09:42
(address . guix-patches@gnu.org)
20200206084207.15195-1-mail@cbaines.net
This drops the time to build the package on my machine from ~14 minutes to ~5
minutes.

* gnu/packages/version-control.scm (subversion)[arguments]: Add set-PARALLEL
phase to set the PARALLEL environment variable.
---
gnu/packages/version-control.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (17 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 20db6b4b08..140eccb7ec 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1434,6 +1434,10 @@ following features:
(substitute* "subversion/tests/libsvn_repos/repos-test.c"
(("#!/bin/sh") (string-append "#!" (which "sh"))))
#t))
+ (add-before 'check 'set-PARALLEL
+ (lambda _
+ (setenv "PARALLEL" (number->string (parallel-job-count)))
+ #t))
(add-after 'install 'install-perl-bindings
(lambda* (#:key outputs #:allow-other-keys)
;; Follow the instructions from 'subversion/bindings/swig/INSTALL'.
--
2.25.0
L
L
Leo Famulari wrote on 7 Feb 2020 23:57
(name . Christopher Baines)(address . mail@cbaines.net)(address . 39451@debbugs.gnu.org)
20200207225720.GB8706@jasmine.lan
On Thu, Feb 06, 2020 at 08:42:07AM +0000, Christopher Baines wrote:
Toggle quote (3 lines)
> This drops the time to build the package on my machine from ~14 minutes to ~5
> minutes.

Awesome. If it seems reliable for you (doesn't crash due to race
conditions) then please push.
L
L
Ludovic Courtès wrote on 13 Feb 2020 23:26
control message for bug #39451
(address . control@debbugs.gnu.org)
87r1yy15u8.fsf@gnu.org
tags 39451 fixed
close 39451
quit
?