[PATCH] gnu: u-boot-tools: Only run full test suite on x86.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Ludovic Courtès
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal
V
V
Vagrant Cascadian wrote on 29 Apr 2019 05:55
(address . guix-patches@gnu.org)
87ef5lbh38.fsf@ponder
* gnu/packages/bootloaders (u-boot-tools)[check]: Remove x86 tests.
[check-x86]: New phase with x86 tests.
[patch]: Patch test-imagetools.sh to test binaries to be installed.
---
gnu/packages/bootloaders.scm | 23 +++++++++++++++++------
1 file changed, 17 insertions(+), 6 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index b4eabaea48..0cd72fb44c 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -442,6 +442,10 @@ also initializes the boards (RAM etc).")
(("def test_ctrl_c")
"@pytest.mark.skip(reason='Guix has problems with SIGINT')
def test_ctrl_c"))
+ ;; Test against the tools being installed rather than tools built
+ ;; for "sandbox" target.
+ (substitute* "test/image/test-imagetools.sh"
+ (("BASEDIR=sandbox") "BASEDIR=."))
(for-each (lambda (file)
(substitute* file
;; Disable signatures, due to GPL/Openssl
@@ -484,12 +488,19 @@ def test_ctrl_c"))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key make-flags test-target #:allow-other-keys)
- (apply invoke "make" "mrproper" make-flags)
- (setenv "SDL_VIDEODRIVER" "dummy")
- (setenv "PAGER" "cat")
- (apply invoke "make" test-target make-flags)
- (symlink "build-sandbox_spl" "sandbox")
- (invoke "test/image/test-imagetools.sh"))))))
+ (invoke "test/image/test-imagetools.sh")))
+ ;; Only run full test suite on x86 systems, as many tests assume
+ ;; x86.
+ ,@(if (string-match "^(x86_64|i686)-linux"
+ (or (%current-target-system)
+ (%current-system)))
+ '((add-after 'check 'check-x86
+ (lambda* (#:key make-flags test-target #:allow-other-keys)
+ (apply invoke "make" "mrproper" make-flags)
+ (setenv "SDL_VIDEODRIVER" "dummy")
+ (setenv "PAGER" "cat")
+ (apply invoke "make" test-target make-flags))))
+ '()))))
(description "U-Boot is a bootloader used mostly for ARM boards. It
also initializes the boards (RAM etc). This package provides its
board-independent tools.")))
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXMZ1vAAKCRDcUY/If5cW
qlmPAQDBv5y0ZYfGgMj0LIh+ZlAnhnxEDakVWpCiEHdba0ILDAD9FnZFX3SwpPWW
VftsjbyYG99e1fWv3E+pnPdkcpj77AU=
=mKQm
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 30 Apr 2019 01:32
Re: gnu: u-boot-tools: Only run full test suite on x86.
(address . 35483@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
87pnp4wfon.fsf@ponder
I neglected to mention in my initial submission that the test suite has
failed on non-x86 architectures since I started testing u-boot on Guix a
year or so ago...

It blocks working support for veyron-speedy/Asus C201, and that would be
very nice to have fixed for 1.0, of course!

I may need to update the patch to exclude i686-linux from the full test
suite, as it seems with u-boot 2019.04 to also fail with 32-bit x86
making some 64-bit assumptions...

Thanks for the review, if you can!

live well,
vagrant

On 2019-04-28, Vagrant Cascadian wrote:
Toggle quote (50 lines)
> * gnu/packages/bootloaders (u-boot-tools)[check]: Remove x86 tests.
> [check-x86]: New phase with x86 tests.
> [patch]: Patch test-imagetools.sh to test binaries to be installed.
> ---
> gnu/packages/bootloaders.scm | 23 +++++++++++++++++------
> 1 file changed, 17 insertions(+), 6 deletions(-)
>
> diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
> index b4eabaea48..0cd72fb44c 100644
> --- a/gnu/packages/bootloaders.scm
> +++ b/gnu/packages/bootloaders.scm
> @@ -442,6 +442,10 @@ also initializes the boards (RAM etc).")
> (("def test_ctrl_c")
> "@pytest.mark.skip(reason='Guix has problems with SIGINT')
> def test_ctrl_c"))
> + ;; Test against the tools being installed rather than tools built
> + ;; for "sandbox" target.
> + (substitute* "test/image/test-imagetools.sh"
> + (("BASEDIR=sandbox") "BASEDIR=."))
> (for-each (lambda (file)
> (substitute* file
> ;; Disable signatures, due to GPL/Openssl
> @@ -484,12 +488,19 @@ def test_ctrl_c"))
> (delete 'check)
> (add-after 'install 'check
> (lambda* (#:key make-flags test-target #:allow-other-keys)
> - (apply invoke "make" "mrproper" make-flags)
> - (setenv "SDL_VIDEODRIVER" "dummy")
> - (setenv "PAGER" "cat")
> - (apply invoke "make" test-target make-flags)
> - (symlink "build-sandbox_spl" "sandbox")
> - (invoke "test/image/test-imagetools.sh"))))))
> + (invoke "test/image/test-imagetools.sh")))
> + ;; Only run full test suite on x86 systems, as many tests assume
> + ;; x86.
> + ,@(if (string-match "^(x86_64|i686)-linux"
> + (or (%current-target-system)
> + (%current-system)))
> + '((add-after 'check 'check-x86
> + (lambda* (#:key make-flags test-target #:allow-other-keys)
> + (apply invoke "make" "mrproper" make-flags)
> + (setenv "SDL_VIDEODRIVER" "dummy")
> + (setenv "PAGER" "cat")
> + (apply invoke "make" test-target make-flags))))
> + '()))))
> (description "U-Boot is a bootloader used mostly for ARM boards. It
> also initializes the boards (RAM etc). This package provides its
> board-independent tools.")))
> --
> 2.20.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXMeJmAAKCRDcUY/If5cW
qs4FAQCKXNiv9TLg2rclBDH1uyiuDNPcR3z7/ZgOOSQG6HO6pwD+Opfnfin+bJV/
wVR6f1yOYff//8PVGLTDgHHbRpd5MQY=
=myC2
-----END PGP SIGNATURE-----

D
D
Danny Milosavljevic wrote on 30 Apr 2019 19:52
(name . Vagrant Cascadian)(address . vagrant@debian.org)
20190430195254.2a45be31@scratchpost.org
Hi Vagrant,
Hi Ludo,

On Mon, 29 Apr 2019 16:32:40 -0700
Vagrant Cascadian <vagrant@debian.org> wrote:

Toggle quote (13 lines)
> I neglected to mention in my initial submission that the test suite has
> failed on non-x86 architectures since I started testing u-boot on Guix a
> year or so ago...
>
> It blocks working support for veyron-speedy/Asus C201, and that would be
> very nice to have fixed for 1.0, of course!
>
> I may need to update the patch to exclude i686-linux from the full test
> suite, as it seems with u-boot 2019.04 to also fail with 32-bit x86
> making some 64-bit assumptions...
>
> Thanks for the review, if you can!

I've reviewed it and found that also on i686 tests are not succeeding.
So I've changed the check to only enable the respective parts of the tests
for x86_64 and pushed it to guix master as
commit 6f5be83cd7158e678602d62c27f26363df3e1649. Thanks!

I'm not sure whether I should still cherry-pick it for 1.0, so I didn't yet.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlzIi3YACgkQ5xo1VCww
uqVS1gf/Xcqbprz4jOAfL5WJxt1qTCWA5LSCNJ/Jfe9UNwrwzXHBr8UDlhz8SkK0
Zni/zatJLm0VsF/QlAeV0W1Hwdb6mt4DoxQjHqbU9K7cEvLhcSf7ndLU7ok5fV0r
PcItM9xFWdpKEJCoAZ7sXaHvVusyG1zi4a6TWQ9jvNEA5S8JxBd+QhRmIpARQC1E
zRq72utO4SsTUVBsqutN28SAS/XQUvxh2pTBcTV8jPHq5HG4epIsa83we+nLR7gy
fNkzNJ97i9atQWcVxDMrg72bvOvBBiPoyonyIxQnYHFtdoYhtCL2GgVqPyRhXg7g
BF9k5S0KgGTypUE8qpivkA5XFPIaKQ==
=RHVB
-----END PGP SIGNATURE-----


D
D
Danny Milosavljevic wrote on 30 Apr 2019 19:54
(name . Vagrant Cascadian)(address . vagrant@debian.org)
20190430195433.1ac76679@scratchpost.org
Toggle quote (2 lines)
> I've reviewed it and found that also on i686 tests are not succeeding.

... or at least they are succeeding with a lot of very serious warnings,
some of which concerning stack alignment for variable arguments and shifts
that are more than the width of the variable slot (which are undefined
on the assembly level and do "funny" things on i686 if you try anyway).
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlzIi9kACgkQ5xo1VCww
uqWlKQgAgzfH6yZgs2nx+v2LP9QOLAHR+2G4DYsC/tdlW7ABDEaQhrSQv5Oig7jm
kDTDYFZnydwi5HXKyA0Y+0zyvA3D2m4+XzX/hq5rP7ZqtD6OC9TW0zpKNJFEg4t5
gBeFUVS5sFXTgVFSfA8Dqr7ham+O2rBU171Da6B6qC0kwACYeB/IGnA2HKwd99yj
O/6r/A+54cQzQqUmF2SIVgLeURaKqPG1lA+hvXnkdBCR3NCXwkT0uZztDh7zzEVh
6A/jVPPPoVciUh07Xp+odBaQthTmv45V7h2icKSsGL/co+W5kYZRZklKqgpH7whB
9lKe9UOB0BbPkk9KC7l3U0Pm/DdKyw==
=gp1g
-----END PGP SIGNATURE-----


D
D
Danny Milosavljevic wrote on 30 Apr 2019 19:58
(address . 35483@debbugs.gnu.org)
20190430195800.6b87f0eb@scratchpost.org
I'm leaving the bug report open since it's one thing if the tests are not
succeeding because the *tests* are broken and another thing if the tests
are not succeeding because the functionality it is testing is broken.
At least on i686 u-boot-tools, the latter seems to be the case often.

So before closing this bug report, let's bring this up upstream and also
let's disable features in the u-boot configuration that are broken but
we don't need anyway.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlzIjKgACgkQ5xo1VCww
uqVFlwf+OjMc6taSBPbEDkK6HnJWeH1VaxeWfJE4qI5evzBuvBNXW8CcH59GBvmL
tIYOiJXy8ezieGgGStJbsS9h8x/ihXmG7UmNDsbZIs2aUthi3gABT9EX5OnsURFT
OegwXeU4knTTdD+xFTvEH6DACGR1RwKVZQtmva+mvtYF1VpKR7hnzoP2ldueqiBR
9v1vqXPz0b36WS4+E19dLzNYtmPm9aWEEhU0Y2Qriy2eFWdNIdQ85TyBWdUJjpo1
Ft3LVMrplsTM2A4s6uib6eBTvKOR2Eq+FOMe4sowiagtwS2/B/4dv0sl9UbO6vQm
FCfW8/rXKdY6WVmoHlYltonhxMZYzA==
=cMBv
-----END PGP SIGNATURE-----


V
V
Vagrant Cascadian wrote on 30 Apr 2019 23:08
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
87sgtzb3r9.fsf@ponder
On 2019-04-30, Danny Milosavljevic wrote:
Toggle quote (23 lines)
> On Mon, 29 Apr 2019 16:32:40 -0700
> Vagrant Cascadian <vagrant@debian.org> wrote:
>
>> I neglected to mention in my initial submission that the test suite has
>> failed on non-x86 architectures since I started testing u-boot on Guix a
>> year or so ago...
>>
>> It blocks working support for veyron-speedy/Asus C201, and that would be
>> very nice to have fixed for 1.0, of course!
>>
>> I may need to update the patch to exclude i686-linux from the full test
>> suite, as it seems with u-boot 2019.04 to also fail with 32-bit x86
>> making some 64-bit assumptions...
>>
>> Thanks for the review, if you can!
>
> I've reviewed it and found that also on i686 tests are not succeeding.
> So I've changed the check to only enable the respective parts of the tests
> for x86_64 and pushed it to guix master as
> commit 6f5be83cd7158e678602d62c27f26363df3e1649. Thanks!
>
> I'm not sure whether I should still cherry-pick it for 1.0, so I didn't yet.

I got confirmation from serveral people on irc to cherry-pick it for
1.0, and with my newfound powers... have pushed it to the version-1.0.0
branch!


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXMi5OwAKCRDcUY/If5cW
qimNAQDbnhgouk8fqG5SGC4xG/VFJueS6ZK6ICYGiWN57b4wlQEA0KzqGh6e+hK7
p6Rik8kUsjhEAxF5fuzQGE4TRGPJ8gM=
=2Hm8
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 30 Apr 2019 23:46
(name . Vagrant Cascadian)(address . vagrant@debian.org)
87imuvi2sy.fsf@gnu.org
Vagrant Cascadian <vagrant@debian.org> skribis:

Toggle quote (2 lines)
> On 2019-04-30, Danny Milosavljevic wrote:

[...]

Toggle quote (11 lines)
>> I've reviewed it and found that also on i686 tests are not succeeding.
>> So I've changed the check to only enable the respective parts of the tests
>> for x86_64 and pushed it to guix master as
>> commit 6f5be83cd7158e678602d62c27f26363df3e1649. Thanks!
>>
>> I'm not sure whether I should still cherry-pick it for 1.0, so I didn't yet.
>
> I got confirmation from serveral people on irc to cherry-pick it for
> 1.0, and with my newfound powers... have pushed it to the version-1.0.0
> branch!

Cool, thank you!

Ludo’.
L
L
Ludovic Courtès wrote on 3 May 2019 17:40
control message for bug #35483
(address . control@debbugs.gnu.org)
87tveba6mo.fsf@gnu.org
tags 35483 fixed
close 35483
?