[PATCH]: Add Bochs

  • Done
  • quality assurance status badge
Details
3 participants
  • Guy fleury
  • Leo Famulari
  • Ludovic Courtès
Owner
unassigned
Submitted by
Guy fleury
Severity
normal
G
G
Guy fleury wrote on 10 Jan 2019 17:40
(address . Guix-patches@gnu.org)
CAOYpmvoYD7OG4neSH=O31vcnA==CbN8m1VwcxkCP-m+qw0fBJw@mail.gmail.com
hi guix,

this patch add Bochs emulator
Attachment: file
From b6decb68498fe15d813aa8efc21a34a744b79d45 Mon Sep 17 00:00:00 2001
From: guy fleury iteriteka <hoonandon@gmail.com>
Date: Thu, 10 Jan 2019 17:33:30 +0100
Subject: [PATCH] gnu : Add Bochs

---
gnu/packages/virtualization.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 274f827cd..4f40006db 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1058,3 +1059,33 @@ and the user can specify exactly what parts of the filesystem should be visible
in the sandbox. Any such directories specified is mounted nodev by default,
and can be made readonly.")
(license license:lgpl2.0+)))
+
+(define-public bochs
+ (package
+ (name "bochs")
+ (version "2.6.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://sourceforge.net/projects/bochs/files/bochs/"
+ version "/bochs-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1379cq4cnfprhw8mgh60i0q9j8fz8d7n3d5fnn2g9fdiv5znfnzf"))))
+ (outputs '("out"))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ;; no tests exits
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("libxrandr" ,libxrandr)))
+ (home-page "http://bochs.sourceforge.net/")
+ (synopsis "x86 PC emulator")
+ (description
+ "Bochs is an emulator which can emulate Intel x86 CPU, common I/O
+devices, and a custom BIOS. It can also compiled to emulate many different
+x86 CPUs, from early 386 to the most recent x86-64 Intel and AMD processors.
+Bochs can running most Operating Systems inside the emulation including Linux,
+DOS or Microsoft Windows.")
+ (license license:gpl2)))
--
2.19.2
G
G
Guy fleury wrote on 10 Jan 2019 19:18
(address . Guix-patches@gnu.org)
CAOYpmvr83V26bUPjesjCFe98K2H+gaqf51oNLpbwc5h2s1PddA@mail.gmail.com
an updated patch

Le jeu. 10 janv. 2019 à 17:40, Guy fleury <hoonandon@gmail.com> a écrit :

Toggle quote (4 lines)
> hi guix,
>
> this patch add Bochs emulator
>
Attachment: file
From 0380fab2ad7195407fc29afb830a86dbfae03b3f Mon Sep 17 00:00:00 2001
From: guy fleury iteriteka <hoonandon@gmail.com>
Date: Thu, 10 Jan 2019 17:33:30 +0100
Subject: [PATCH] gnu: Add Bochs

---
gnu/packages/virtualization.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 274f827cd..ca775506c 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1058,3 +1059,33 @@ and the user can specify exactly what parts of the filesystem should be visible
in the sandbox. Any such directories specified is mounted nodev by default,
and can be made readonly.")
(license license:lgpl2.0+)))
+
+(define-public bochs
+ (package
+ (name "bochs")
+ (version "2.6.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://sourceforge.net/projects/bochs/files/bochs/"
+ version "/bochs-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1379cq4cnfprhw8mgh60i0q9j8fz8d7n3d5fnn2g9fdiv5znfnzf"))))
+ (outputs '("out"))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ;; no tests exits
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("libxrandr" ,libxrandr)))
+ (home-page "http://bochs.sourceforge.net/")
+ (synopsis "Emulator for x86 PC")
+ (description
+ "Bochs is an emulator which can emulate Intel x86 CPU, common I/O
+devices, and a custom BIOS. It can also compiled to emulate many different
+x86 CPUs, from early 386 to the most recent x86-64 Intel and AMD processors.
+Bochs can running most Operating Systems inside the emulation including Linux,
+DOS or Microsoft Windows.")
+ (license license:lgpl2.0)))
--
2.19.2
L
L
Leo Famulari wrote on 11 Jan 2019 00:42
Re: [bug#34034] [PATCH]: Add Bochs
(name . Guy fleury)(address . hoonandon@gmail.com)(address . 34034@debbugs.gnu.org)
20190110234228.GA28964@jasmine.lan
On Thu, Jan 10, 2019 at 07:18:04PM +0100, Guy fleury wrote:
Toggle quote (5 lines)
> From 0380fab2ad7195407fc29afb830a86dbfae03b3f Mon Sep 17 00:00:00 2001
> From: guy fleury iteriteka <hoonandon@gmail.com>
> Date: Thu, 10 Jan 2019 17:33:30 +0100
> Subject: [PATCH] gnu: Add Bochs

Thank you!

Toggle quote (2 lines)
> + (outputs '("out"))

This is the default, so it's okay to leave it out.

Toggle quote (2 lines)
> + `(#:tests? #f)) ;; no tests exits

"No tests exist"

Toggle quote (5 lines)
> + (inputs
> + `(("glib" ,glib)
> + ("gtk+" ,gtk+)
> + ("libxrandr" ,libxrandr)))

I noticed that it doesn't keep references to glib and gtk+:

------
$ guix gc --references $(./pre-inst-env guix build --no-grafts bochs)
/gnu/store/2dk55i5wdhcbh2z8hhn3r55x4873iyp1-libxext-1.3.3
/gnu/store/3vlscch2sxybd34qx2ianpg92crm9akm-libxdmcp-1.1.2
/gnu/store/4sqps8dczv3g7rwbdibfz6rf5jlk7w90-gcc-5.5.0-lib
/gnu/store/6lwn8v33r2z2l2pgky2dnzim3696dwnn-libbsd-0.9.1
/gnu/store/8baabfjazsr7s4y0jig1sn84xnxf75xa-libx11-1.6.6
/gnu/store/h90vnqw0nwd0hhm1l5dgxsdrigddfmq4-glibc-2.28
/gnu/store/hnj08aavzpsi72wvi4qqrp5dqbyqxqqs-libxcb-1.13
/gnu/store/mawqhgh0bdxpa4gjxs1fjyhwvv6i8w5g-libxau-1.0.8
/gnu/store/mbbj3j86amqls868hip0l85q9lx8gbcn-libxrandr-1.5.1
/gnu/store/x6fyr53k53sd5ghnh3abpnr1mqsy3xig-bochs-2.6.9
/gnu/store/xrvwszmahcb7k2zcyag3vmqwswzrbvcg-libxrender-0.9.10
------

So, I think it's possible to omit those two inputs.

Toggle quote (3 lines)
> + "Bochs is an emulator which can emulate Intel x86 CPU, common I/O
> +devices, and a custom BIOS. It can also compiled to emulate many different

"It can also be compiled to ..."

Toggle quote (3 lines)
> +Bochs can running most Operating Systems inside the emulation including Linux,
> +DOS or Microsoft Windows.")

"Bochs can run most operating systems ..."

Toggle quote (2 lines)
> + (license license:lgpl2.0)))

I checked some of the source files and I think it is lgpl2.0+.

Can you send an updated patch? :)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlw32GEACgkQJkb6MLrK
fwgTGxAApV701nPD63se+WdO3S7xGd7CP7OMaUJymm7ep3ylYHX7ko/7AD2y+paJ
t4GiXOXwwG04jvF6sdtF8ugx+cQiMYJgPgkvUzevdSDZ5+MYJx+UQIjwjz+BUL2N
aaJLYDjnCt+ATLjOLYfU62ImzWbpUC/JR3nwhnuTwQ1RTGkyUaGSp9l8jGmIwQgY
ZMJ4gTf7wktd0Mb5K6AcAqBW3RX5sDJW6/JEufLseVC2zsCKTi0RTDS64sdUHuBS
EEA0tyNdFxfOSfZMcX1ja3ZQtgYJPgbbYsoYK9zgJLljcjaHuYJzXBWCJYT5lIta
aVlvAvLDY5ImoOT1hvpau1D6vHDmmPc7Pxt9+nOsyjHp6gZpEb4YOP7epdy49rme
c9tGQdOQ+inl4YCfeB6Ja0lbGZ6QpdBXEV6htfvxiEb4rsjW+xIbg1F6C5NCIpFL
n5Qxnb4NPwxPtYRO9g/X8kR4s+FOjsbaPOp1BxrrmXsGYQ8xv/IgigYanOPQozIg
edpPE+jJl9ecEPsKQqGRzAhC6Lvz+uRJheKxEI9bakJKGlackwR62dlVOtignhcP
gliNm1q5Ax/dhCyb9Hz4pkN6qE0ahX3MiDcuA6k3inHOddF7BTGH5Ex9q+Updvnb
2dEIEhiwsPJYHkgcqBIsdaeOWVcy8AKzFcawK5MYU5vU0wpDqWg=
=MN2j
-----END PGP SIGNATURE-----


G
G
Guy fleury wrote on 11 Jan 2019 06:52
(name . Leo Famulari)(address . leo@famulari.name)(address . 34034@debbugs.gnu.org)
CAOYpmvpTUv9yv91jymrFDMD7F2FPHANfpGYYTDjc2LNFcya1=w@mail.gmail.com
hi

Le ven. 11 janv. 2019 à 00:42, Leo Famulari <leo@famulari.name> a écrit :

Toggle quote (38 lines)
> On Thu, Jan 10, 2019 at 07:18:04PM +0100, Guy fleury wrote:
> > From 0380fab2ad7195407fc29afb830a86dbfae03b3f Mon Sep 17 00:00:00 2001
> > From: guy fleury iteriteka <hoonandon@gmail.com>
> > Date: Thu, 10 Jan 2019 17:33:30 +0100
> > Subject: [PATCH] gnu: Add Bochs
>
> Thank you!
>
> > + (outputs '("out"))
>
> This is the default, so it's okay to leave it out.
>
> > + `(#:tests? #f)) ;; no tests exits
>
> "No tests exist"
>
> > + (inputs
> > + `(("glib" ,glib)
> > + ("gtk+" ,gtk+)
> > + ("libxrandr" ,libxrandr)))
>
> I noticed that it doesn't keep references to glib and gtk+:
>
> ------
> $ guix gc --references $(./pre-inst-env guix build --no-grafts bochs)
> /gnu/store/2dk55i5wdhcbh2z8hhn3r55x4873iyp1-libxext-1.3.3
> /gnu/store/3vlscch2sxybd34qx2ianpg92crm9akm-libxdmcp-1.1.2
> /gnu/store/4sqps8dczv3g7rwbdibfz6rf5jlk7w90-gcc-5.5.0-lib
> /gnu/store/6lwn8v33r2z2l2pgky2dnzim3696dwnn-libbsd-0.9.1
> /gnu/store/8baabfjazsr7s4y0jig1sn84xnxf75xa-libx11-1.6.6
> /gnu/store/h90vnqw0nwd0hhm1l5dgxsdrigddfmq4-glibc-2.28
> /gnu/store/hnj08aavzpsi72wvi4qqrp5dqbyqxqqs-libxcb-1.13
> /gnu/store/mawqhgh0bdxpa4gjxs1fjyhwvv6i8w5g-libxau-1.0.8
> /gnu/store/mbbj3j86amqls868hip0l85q9lx8gbcn-libxrandr-1.5.1
> /gnu/store/x6fyr53k53sd5ghnh3abpnr1mqsy3xig-bochs-2.6.9
> /gnu/store/xrvwszmahcb7k2zcyag3vmqwswzrbvcg-libxrender-0.9.10
> ------
>
thanks for this tips.

Toggle quote (20 lines)
> So, I think it's possible to omit those two inputs.
>
> > + "Bochs is an emulator which can emulate Intel x86 CPU, common I/O
> > +devices, and a custom BIOS. It can also compiled to emulate many
> different
>
> "It can also be compiled to ..."
>
> > +Bochs can running most Operating Systems inside the emulation including
> Linux,
> > +DOS or Microsoft Windows.")
>
> "Bochs can run most operating systems ..."
>
> > + (license license:lgpl2.0)))
>
> I checked some of the source files and I think it is lgpl2.0+.
>
> Can you send an updated patch? :)
>
Attachment: file
From ed8c4f10dd669de42539dc44437c5729230be59d Mon Sep 17 00:00:00 2001
From: guy fleury iteriteka <hoonandon@gmail.com>
Date: Thu, 10 Jan 2019 17:33:30 +0100
Subject: [PATCH] gnu: Add Bochs

---
gnu/packages/virtualization.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 274f827cd..6deda2e86 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1058,3 +1059,30 @@ and the user can specify exactly what parts of the filesystem should be visible
in the sandbox. Any such directories specified is mounted nodev by default,
and can be made readonly.")
(license license:lgpl2.0+)))
+
+(define-public bochs
+ (package
+ (name "bochs")
+ (version "2.6.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://sourceforge.net/projects/bochs/files/bochs/"
+ version "/bochs-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1379cq4cnfprhw8mgh60i0q9j8fz8d7n3d5fnn2g9fdiv5znfnzf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ;; no tests exit
+ (inputs
+ `(("libxrandr" ,libxrandr)))
+ (home-page "http://bochs.sourceforge.net/")
+ (synopsis "Emulator for x86 PC")
+ (description
+ "Bochs is an emulator which can emulate Intel x86 CPU, common I/O
+devices, and a custom BIOS. It can also be compiled to emulate many different
+x86 CPUs, from early 386 to the most recent x86-64 Intel and AMD processors.
+Bochs can run most Operating Systems inside the emulation including Linux,
+DOS or Microsoft Windows.")
+ (license license:lgpl2.0+)))
--
2.19.2
L
L
Leo Famulari wrote on 11 Jan 2019 23:11
(name . Guy fleury)(address . hoonandon@gmail.com)(address . 34034@debbugs.gnu.org)
20190111221126.GB27583@jasmine.lan
On Fri, Jan 11, 2019 at 06:52:31AM +0100, Guy fleury wrote:
Toggle quote (5 lines)
> From ed8c4f10dd669de42539dc44437c5729230be59d Mon Sep 17 00:00:00 2001
> From: guy fleury iteriteka <hoonandon@gmail.com>
> Date: Thu, 10 Jan 2019 17:33:30 +0100
> Subject: [PATCH] gnu: Add Bochs

Thanks! Pushed as 170436771968dfa272225ea45b63689b900fd317
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlw5FI4ACgkQJkb6MLrK
fwhgPA//WdangtPF8QUQTDd6AdXUvH0YoBTkVjo54hNJLS+ivugU70dyrDsucft4
7SN3HZHNqr+gHmpqQ+J870c1Et0hSACbK+/QNXlpNE3LuS2VyodOa4cI+wPV0tTP
SrX7MtKIi1XE72a01GnhSrw5s56ObqDN4rlm4Qo+ipw8OqmeFLr6TmPhA4gJBsUX
z4ahtgfjlNHcNGtwV2u5wKaZJieYfjSX2jvtjUjOuuIyUUo1jXah6HdP/IsIOyfI
W3h3ZcHfM4vCLI8JgJjjEyPbaFZUh5hE6nbxZu4dU+PRcv1aoLe3jisb+3AVi+pU
9KQjbNg/bcUWCzHVhaax23IFSl1qouTmqr08As0RBjxo5nxcVUxEkEhsVI94MZ8z
GTl8NpTidyzq8rnswhGKBpZjrx2OLpxJjO7BB5iFPhk38q3ahW+Ww9yiALbxHaXy
wTNF3MRBJwWCcMajZ6J1NpS5iWUhy5scLxyoVH9XiQQ+LjWaE0lH/9YxRG+rTOYr
VePER6jSKzLsdKyhuC8JPErY98Z8TAGDhZibRUNCs5KbsWdGa3aFs8OIroRG0mW/
5V9hExqy94Y1YaX68H6wLpsYAIbNHZvWhmn/k0VdrD0dLsuEeOXHuior18HW69d9
4AWi0UX+OphSutsHyq86kNTlL4us2bUhRx4JY8N/0nYDvA/keiw=
=xYPu
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 12 Jan 2019 11:36
control message for bug #34034
(address . control@debbugs.gnu.org)
87r2di6u3z.fsf@gnu.org
tags 34034 fixed
close 34034
?