[PATCH] gnu: Add python-warcio.

  • Done
  • quality assurance status badge
Details
4 participants
  • Ludovic Courtès
  • Maxim Cournoyer
  • swedebugia
  • zimoun
Owner
unassigned
Submitted by
swedebugia
Severity
normal
S
S
swedebugia wrote on 19 Nov 2018 21:41
(address . guix-patches@gnu.org)
4f8816d0-8b47-7299-f31b-a2fa0f592d2d@riseup.net
--
Cheers
Swedebugia
From 537b2b111a464956bdec640ea5f84c4598ea66f9 Mon Sep 17 00:00:00 2001
From: swedebugia <swedebugia@riseup.net>
Date: Mon, 19 Nov 2018 21:37:46 +0100
Subject: [PATCH] gnu: Add python-warcio.

* gnu/packages/python.scm: New variable.
---
gnu/packages/python.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2b7482a3e..24e8c409f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14630,3 +14630,29 @@ on regular expressions.")
"This module implements the PRECIS Framework as described in RFC 8264,
RFC 8265 and RFC 8266.")
(license license:expat)))
+
+(define-public python-warcio
+ (package
+ (name "python-warcio")
+ (version "1.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "warcio" version))
+ (sha256
+ (base32
+ "1nyhghbag1chh5fml848x799mwgkgmz3l3ipv7lr6p0lj1jq8i1r"))))
+ (build-system python-build-system)
+ (inputs `(("python-six" ,python-six)
+ ("python-requests" ,python-requests)
+ ("python-httpbin" ,python-httpbin)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (arguments
+ ;; FIXME: Some tests require network access. 150 out of 1354 fail
+ '(#:tests? #f))
+ (home-page "https://github.com/webrecorder/warcio")
+ (synopsis "Streaming web archival archive (WARC) library")
+ (description
+ "warcio is designed for fast, low-level access to web archival
+content, oriented around a stream of WARC records rather than files.")
+ (license license:asl2.0)))
--
2.18.0
L
L
Ludovic Courtès wrote on 21 Nov 2018 11:21
(name . swedebugia)(address . swedebugia@riseup.net)(address . 33436@debbugs.gnu.org)
87in0qu3xp.fsf@gnu.org
Hello!

swedebugia <swedebugia@riseup.net> skribis:

Toggle quote (6 lines)
>>From 537b2b111a464956bdec640ea5f84c4598ea66f9 Mon Sep 17 00:00:00 2001
> From: swedebugia <swedebugia@riseup.net>
> Date: Mon, 19 Nov 2018 21:37:46 +0100
> Subject: [PATCH] gnu: Add python-warcio.
>
> * gnu/packages/python.scm: New variable.
^
Nitpick: You forgot the variable name here. :-)

Toggle quote (4 lines)
> + (arguments
> + ;; FIXME: Some tests require network access. 150 out of 1354 fail
> + '(#:tests? #f))

Could you investigate a bit further? What do the test logs show?

It would be good to see if these tests can be easily fixed, if they
should definitely be skipped (for instance because they rely on some
external service), or if it’s something else.

Toggle quote (4 lines)
> + (synopsis "Streaming web archival archive (WARC) library")
> + (description
> + "warcio is designed for fast, low-level access to web archival
^^
What about: “warcio is a Python library to read and write the WARC format
commonly used in Web archives. It is designed for…”?

Thank you,
Ludo’.
L
L
Ludovic Courtès wrote on 11 Jan 2019 09:29
(name . swedebugia)(address . swedebugia@riseup.net)(address . 33436@debbugs.gnu.org)
87zhs78un9.fsf@gnu.org
Ping!

ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (33 lines)
> Hello!
>
> swedebugia <swedebugia@riseup.net> skribis:
>
>>>>From 537b2b111a464956bdec640ea5f84c4598ea66f9 Mon Sep 17 00:00:00 2001
>> From: swedebugia <swedebugia@riseup.net>
>> Date: Mon, 19 Nov 2018 21:37:46 +0100
>> Subject: [PATCH] gnu: Add python-warcio.
>>
>> * gnu/packages/python.scm: New variable.
> ^
> Nitpick: You forgot the variable name here. :-)
>
>> + (arguments
>> + ;; FIXME: Some tests require network access. 150 out of 1354 fail
>> + '(#:tests? #f))
>
> Could you investigate a bit further? What do the test logs show?
>
> It would be good to see if these tests can be easily fixed, if they
> should definitely be skipped (for instance because they rely on some
> external service), or if it’s something else.
>
>> + (home-page "https://github.com/webrecorder/warcio")
>> + (synopsis "Streaming web archival archive (WARC) library")
>> + (description
>> + "warcio is designed for fast, low-level access to web archival
> ^^
> What about: “warcio is a Python library to read and write the WARC format
> commonly used in Web archives. It is designed for…”?
>
> Thank you,
> Ludo’.
S
S
swedebugia wrote on 24 Feb 2019 03:01
(name . Ludovic Courtès)(address . ludo@gnu.org)(name . 33436@debbugs.gnu.org)(address . 33436@debbugs.gnu.org)
ae61574a-f769-a78f-71ac-48a57477ba0e@riseup.net
On 2019-01-11 09:29, Ludovic Courtès wrote:
Toggle quote (37 lines)
> Ping!
>
> ludo@gnu.org (Ludovic Courtès) skribis:
>
>> Hello!
>>
>> swedebugia <swedebugia@riseup.net> skribis:
>>
>>>> >From 537b2b111a464956bdec640ea5f84c4598ea66f9 Mon Sep 17 00:00:00 2001
>>> From: swedebugia <swedebugia@riseup.net>
>>> Date: Mon, 19 Nov 2018 21:37:46 +0100
>>> Subject: [PATCH] gnu: Add python-warcio.
>>>
>>> * gnu/packages/python.scm: New variable.
>> ^
>> Nitpick: You forgot the variable name here. :-)
>>
>>> + (arguments
>>> + ;; FIXME: Some tests require network access. 150 out of 1354 fail
>>> + '(#:tests? #f))
>>
>> Could you investigate a bit further? What do the test logs show?
>>
>> It would be good to see if these tests can be easily fixed, if they
>> should definitely be skipped (for instance because they rely on some
>> external service), or if it’s something else.
>>
>>> + (home-page "https://github.com/webrecorder/warcio")
>>> + (synopsis "Streaming web archival archive (WARC) library")
>>> + (description
>>> + "warcio is designed for fast, low-level access to web archival
>> ^^
>> What about: “warcio is a Python library to read and write the WARC format
>> commonly used in Web archives. It is designed for…”?
>>
>> Thank you,
>> Ludo’.
Here comes the log from the build.

I see a lot of "OSError: [Errno 9] Bad file descriptor" and a few
"FileNotFoundError"

Should I report upstream?

--
Cheers Swedebugia
Attachment: file
Attachment: signature.asc
L
L
Ludovic Courtès wrote on 4 Mar 2019 14:43
(name . swedebugia)(address . swedebugia@riseup.net)(name . 33436@debbugs.gnu.org)(address . 33436@debbugs.gnu.org)
878sxusqka.fsf@gnu.org
Hello swedebugia,

swedebugia <swedebugia@riseup.net> skribis:

Toggle quote (2 lines)
> On 2019-01-11 09:29, Ludovic Courtès wrote:

[...]

Toggle quote (6 lines)
>>>> + (arguments
>>>> + ;; FIXME: Some tests require network access. 150 out of 1354 fail
>>>> + '(#:tests? #f))
>>>
>>> Could you investigate a bit further? What do the test logs show?

[...]

Toggle quote (7 lines)
> Here comes the log from the build.
>
> I see a lot of "OSError: [Errno 9] Bad file descriptor" and a few
> "FileNotFoundError"
>
> Should I report upstream?

Yes, please. Perhaps you need to investigate a little bit beforehand
so you can provide them with just the information they need to reproduce
and understand the problem.

Thanks!

Ludo’.
Z
Z
zimoun wrote on 17 Dec 2020 19:33
control message for bug #33436
(address . control@debbugs.gnu.org)
87pn38s2nx.fsf@gmail.com
tags 33436 + moreinfo
quit
M
M
Maxim Cournoyer wrote on 13 Jul 2021 17:23
Re: bug#33436: [PATCH] gnu: Add python-warcio.
(name . Ludovic Courtès)(address . ludo@gnu.org)
87tukyqluh.fsf_-_@gmail.com
Hello,

I've added the 'python-wsgiprox' and 'python-certauth' missing
dependencies as of warcio 1.7.4, managed to get the test suite to run
with only 2 disabled tests (due to networking requirements), and pushed
as 89bd7565e8.

Thanks to both of you!

Closing.

Maxim
Closed
?