[PATCH] New package: python-ilinkedlist

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Luther Thompson
Owner
unassigned
Submitted by
Luther Thompson
Severity
normal
L
L
Luther Thompson wrote on 18 Oct 2018 17:16
(address . guix-patches@gnu.org)
20181018111639.4aa7dc1c@gmail.com
I've written a Python module. Here is my package definition for it.
Please let me know if I can make any improvements.

---BEGIN---
Toggle diff (40 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8261fefd9..59917feb7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14473,3 +14473,28 @@ extend common interfaces like NumPy, Pandas, or Python iterators to
larger-than-memory or distributed environments. These parallel collections
run on top of the dynamic task schedulers. ")
(license license:bsd-3)))
+
+(define-public python-ilinkedlist
+ (package
+ (name "python-ilinkedlist")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ilinkedlist" version))
+ (sha256
+ (base32
+ "063c2gm4jkgkv0nsg7mrc8y0w82ms98l4xchmbrvr68cscglhk69"))))
+ (build-system python-build-system)
+ (native-inputs `(("python-pytest" ,python-pytest)))
+ (inputs `(("python" ,python)))
+ (home-page "https://github.com/luther9/ilinkedlist-py")
+ (synopsis "Immutable linked list library")
+ (description
+ "This is a implementation of immutable linked lists for Python. It
+contains @code{nil} (the empty linked list) and a @code{Pair} class for nodes.
+Since a linked list is treated as immutable, it is hashable, and its length can
+be retrieved in constant time. Some of the terminology is inspired by LISP. It
+is possible to create an improper list by creating a @code{Pair} with a non-list
+@code{cdr}.")
+ (license license:gpl3+)))
---END---

I sent this message last night, but I don't see it in the archives, so I'm
sending it again.

Regards,
Luther Thompson
L
L
Ludovic Courtès wrote on 21 Oct 2018 23:50
control message for bug #33089
(address . control@debbugs.gnu.org)
87in1v6kba.fsf@gnu.org
tags 33089 fixed
close 33089
?