[PATCH 2/6] gnu: Add ghc-array.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Tonton
Owner
unassigned
Submitted by
Tonton
Severity
normal
T
T
Tonton wrote on 11 May 2018 22:34
(name . Tonton)(address . tonton@riseup.net)
20180511203408.29491-1-tonton@riseup.net
* gnu/packages/haskell.scm (ghc-array): New variable.
---
gnu/packages/haskell.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9b26ff56f..67faeb852 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2017, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Tonton <tonton@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9466,4 +9467,27 @@ system dependencies.")
address string against RFC 5322.")
(license license:bsd-3)))
+(define-public ghc-array
+ (package
+ (name "ghc-array")
+ (version "0.5.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://hackage.haskell.org/package/array-0.5.2.0/array-"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "12v83s2imxb3p2crnlzrpjh0nk6lpysw9bdk9yahs6f37csa5jaj"))))
+ (build-system haskell-build-system)
+ (synopsis "Haskell Data.Array module")
+ (description "In addition to providing the Data.Array module as
+specified in the Haskell 2010 Language Report, this package also defines
+the classes IArray of immutable arrays and MArray of arrays mutable
+within appropriate monads, as well as some instances of these classes.")
+ (home-page "https://hackage.haskell.org/package/array")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here
--
2.17.0
L
L
Ludovic Courtès wrote on 14 May 2018 10:27
control message for bug #31419
(address . control@debbugs.gnu.org)
87tvrabq1f.fsf@gnu.org
tags 31419 fixed
close 31419
?