[PATCH 1/2] gnu: Add python-parso.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Fis Trivial
Owner
unassigned
Submitted by
Fis Trivial
Severity
normal
F
F
Fis Trivial wrote on 27 Apr 2018 08:58
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
BLUPR16MB0500BFB454ECE1E7F0C9C1DC928D0@BLUPR16MB0500.namprd16.prod.outlook.com
* gnu/packages/python.scm (python-parso, python2-parso): New variables.
---
gnu/packages/python.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a5d533b1c..e4d9e9baa 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13145,3 +13145,28 @@ in Python. You can simply type pybtex instead of bibtex.")
(description "Python one-time password library for HMAC-based (HOTP) and
time-based (TOTP) passwords.")
(license license:expat)))
+
+(define-public python-parso
+ (package
+ (name "python-parso")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "parso" version))
+ (sha256
+ (base32
+ "0lamywk6dm5xshlkdvxxf5j6fa2k2zpi7xagf0bwidaay3vnpgb2"))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/davidhalter/parso")
+ (synopsis "Python Parser")
+ (description "Parso is a Python parser that supports error recovery and
+round-trip parsing for different Python versions (in multiple Python versions).
+Parso is also able to list multiple syntax errors in your python file.")
+ (license license:expat)))
+
+(define-public python2-parso
+ (package-with-python2 python-parso))
--
2.14.3
F
F
Fis Trivial wrote on 27 Apr 2018 09:03
[PATCH 2/2] gnu: python-jedi: Update to 0.12.0, enable tests.
(name . 31282@debbugs.gnu.org)(address . 31282@debbugs.gnu.org)
BLUPR16MB0500490C569481385747E980928D0@BLUPR16MB0500.namprd16.prod.outlook.com
* gnu/packages/python.scm (jedi): Update to 0.12.0, enable tests.
---
gnu/packages/python.scm | 29 +++++++++++++++++------------
1 file changed, 17 insertions(+), 12 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e4d9e9baa..05ffb9f0d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9357,25 +9357,30 @@ characters, mouse support, and auto suggestions.")
(define-public python-jedi
(package
(name "python-jedi")
- (version "0.9.0")
+ (version "0.12.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "jedi" version))
- (sha256
- (base32
- "0c8x962ynpx001fdvp07m2q5jk4igkxbj3rmnydavphvlgxijk1v"))))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jedi" version))
+ (sha256
+ (base32
+ "1bcr7csx4xil1iwmk03d79jis0bkmgi9k0kir3xa4rmwqsagcwhr"))))
(build-system python-build-system)
(arguments
- ;; FIXME: One test fails (use "py.test" instead of 'setup.py test').
- '(#:tests? #f))
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check (lambda _
+ (invoke "py.test" "-vv"))))))
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-pytest" ,python-pytest)
+ ("python-parso" ,python-parso)
+ ("python-docopt" ,python-docopt)))
(home-page "https://github.com/davidhalter/jedi")
(synopsis
- "Autocompletion for Python that can be used for text editors")
+ "Autocompletion for Python that can be used for text editors")
(description
- "Jedi is an autocompletion tool for Python that can be used for text editors.")
+ "Jedi is an autocompletion tool for Python that can be used for text
+ editors.")
(license license:expat)))
(define-public python2-jedi
--
2.14.3
L
L
Ludovic Courtès wrote on 30 Apr 2018 14:34
Re: [bug#31282] [PATCH 1/2] gnu: Add python-parso.
(name . Fis Trivial)(address . ybbs.daans@hotmail.com)(address . 31282@debbugs.gnu.org)
87efiwzxd4.fsf@gnu.org
Fis Trivial <ybbs.daans@hotmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/python.scm (python-parso, python2-parso): New variables.

Applied with the changes below, thanks!

Ludo'.
Toggle diff (19 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7fe27bd17..f23deb57e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13160,12 +13160,11 @@ time-based (TOTP) passwords.")
(native-inputs
`(("python-pytest" ,python-pytest)))
(build-system python-build-system)
- (home-page
- "https://github.com/davidhalter/parso")
+ (home-page "https://github.com/davidhalter/parso")
(synopsis "Python Parser")
(description "Parso is a Python parser that supports error recovery and
round-trip parsing for different Python versions (in multiple Python versions).
-Parso is also able to list multiple syntax errors in your python file.")
+Parso is also able to list multiple syntax errors in your Python file.")
(license license:expat)))
(define-public python2-parso
L
L
Ludovic Courtès wrote on 30 Apr 2018 14:37
Re: [bug#31282] [PATCH 2/2] gnu: python-jedi: Update to 0.12.0, enable tests.
(name . Fis Trivial)(address . ybbs.daans@hotmail.com)(name . 31282-done@debbugs.gnu.org)(address . 31282@debbugs.gnu.org)
87a7tkzx8o.fsf@gnu.org
Fis Trivial <ybbs.daans@hotmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/python.scm (jedi): Update to 0.12.0, enable tests.

Applied, thanks!

Ludo'.
L
L
Ludovic Courtès wrote on 5 May 2018 22:26
control message for bug #31282
(address . control@debbugs.gnu.org)
87in81rgqc.fsf@gnu.org
tags 31282 fixed
close 31282
?