[PATCH 1/2] gnu: libtorrent-rasterbar: Add CXXFLAGS.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Fis Trivial
Owner
unassigned
Submitted by
Fis Trivial
Severity
normal
F
F
Fis Trivial wrote on 6 Apr 2018 22:06
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
MWHPR16MB006332F2D6608BEBE8DFA3CA92BA0@MWHPR16MB0063.namprd16.prod.outlook.com
* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Add CXXFLAGS.
---
gnu/packages/bittorrent.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index dc051e262..b168f88e0 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -391,7 +391,8 @@ and will take advantage of multiple processor cores where possible.")
(assoc-ref %build-inputs "boost")
"/lib")
"--enable-python-binding"
- "--enable-tests")
+ "--enable-tests"
+ "CXXFLAGS=-std=c++11") ; Use std::chrono instead of boost
#:make-flags (list
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))))
--
2.14.3
F
F
Fis Trivial wrote on 6 Apr 2018 22:16
(name . Fis Trivial)(address . ybbs.daans@hotmail.com)(name . 31083@debbugs.gnu.org)(address . 31083@debbugs.gnu.org)
MWHPR16MB0063CA0717085F418C04C9AA92BA0@MWHPR16MB0063.namprd16.prod.outlook.com
Fis Trivial writes:

Toggle quote (20 lines)
> * gnu/packages/bittorrent.scm (libtorrent-rasterbar): Add CXXFLAGS.
> ---
> gnu/packages/bittorrent.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
> index dc051e262..b168f88e0 100644
> --- a/gnu/packages/bittorrent.scm
> +++ b/gnu/packages/bittorrent.scm
> @@ -391,7 +391,8 @@ and will take advantage of multiple processor cores where possible.")
> (assoc-ref %build-inputs "boost")
> "/lib")
> "--enable-python-binding"
> - "--enable-tests")
> + "--enable-tests"
> + "CXXFLAGS=-std=c++11") ; Use std::chrono instead of boost
> #:make-flags (list
> (string-append "LDFLAGS=-Wl,-rpath="
> (assoc-ref %outputs "out") "/lib"))))

This is for adding qBittorrent.
L
L
Ludovic Courtès wrote on 9 Apr 2018 22:59
(name . Fis Trivial)(address . ybbs.daans@hotmail.com)(address . 31083@debbugs.gnu.org)
873704gkp9.fsf@gnu.org
Hi,

Fis Trivial <ybbs.daans@hotmail.com> skribis:

Toggle quote (17 lines)
> * gnu/packages/bittorrent.scm (libtorrent-rasterbar): Add CXXFLAGS.
> ---
> gnu/packages/bittorrent.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
> index dc051e262..b168f88e0 100644
> --- a/gnu/packages/bittorrent.scm
> +++ b/gnu/packages/bittorrent.scm
> @@ -391,7 +391,8 @@ and will take advantage of multiple processor cores where possible.")
> (assoc-ref %build-inputs "boost")
> "/lib")
> "--enable-python-binding"
> - "--enable-tests")
> + "--enable-tests"
> + "CXXFLAGS=-std=c++11") ; Use std::chrono instead of boost

Does that mean we can remove Boost from the dependencies or is it still
needed for other bits?

Thank you,
Ludo’.
F
F
Fis Trivial wrote on 9 Apr 2018 23:41
(name . Ludovic Courtès)(address . ludo@gnu.org)
MWHPR16MB00638930F01A8EDEEF74120592BF0@MWHPR16MB0063.namprd16.prod.outlook.com
Toggle quote (6 lines)
>
> Does that mean we can remove Boost from the dependencies or is it still
> needed for other bits?
>
> Thank you,
> Ludo’.
L
L
Ludovic Courtès wrote on 10 Apr 2018 22:50
(name . Fis Trivial)(address . ybbs.daans@hotmail.com)(address . 31083@debbugs.gnu.org)
878t9u7pm9.fsf@gnu.org
Fis Trivial <ybbs.daans@hotmail.com> skribis:

Toggle quote (12 lines)
>>
>> Does that mean we can remove Boost from the dependencies or is it still
>> needed for other bits?
>>
>> Thank you,
>> Ludo’.
>
> It's still needed. The solution is adopted from project's issue list:
>
> https://github.com/qbittorrent/qBittorrent/issues/8402
> https://github.com/qbittorrent/qBittorrent/issues/5265

OK, thanks for explaining. Applied, thanks!

Ludo’.
L
L
Ludovic Courtès wrote on 19 Apr 2018 11:42
control message for bug #31083
(address . control@debbugs.gnu.org)
87efjbmt0n.fsf@gnu.org
tags 31083 fixed
close 31083
?