[PATCH] linux: Add omap2plus generic kernel.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Mathieu Othacehe
Severity
normal
M
M
Mathieu Othacehe wrote on 3 Nov 2017 15:16
(address . guix-patches@gnu.org)(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
1509718597-31300-1-git-send-email-m.othacehe@gmail.com
* gnu/packages/linux.scm (linux-libre-arm-omap2plus): New exported variable.
---
gnu/packages/linux.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2ecf6bd..0ee2d60 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -402,6 +402,13 @@ It has been modified to remove all non-free binary blobs.")
#:defconfig "multi_v7_defconfig"
#:extra-version "arm-generic"))
+(define-public linux-libre-arm-omap2plus
+ (make-linux-libre %linux-libre-version
+ %linux-libre-hash
+ '("armhf-linux")
+ #:defconfig "omap2plus_defconfig"
+ #:extra-version "arm-omap2plus"))
+
;;;
;;; Pluggable authentication modules (PAM).
--
2.7.4
L
L
Ludovic Courtès wrote on 5 Nov 2017 21:50
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)(address . 29133@debbugs.gnu.org)
877ev4o3f2.fsf@gnu.org
Mathieu Othacehe <m.othacehe@gmail.com> skribis:

Toggle quote (20 lines)
> * gnu/packages/linux.scm (linux-libre-arm-omap2plus): New exported variable.
> ---
> gnu/packages/linux.scm | 7 +++++++
> 1 file changed, 7 insertions(+)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index 2ecf6bd..0ee2d60 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -402,6 +402,13 @@ It has been modified to remove all non-free binary blobs.")
> #:defconfig "multi_v7_defconfig"
> #:extra-version "arm-generic"))
>
> +(define-public linux-libre-arm-omap2plus
> + (make-linux-libre %linux-libre-version
> + %linux-libre-hash
> + '("armhf-linux")
> + #:defconfig "omap2plus_defconfig"
> + #:extra-version "arm-omap2plus"))

LGTM! Were you able to boot it on an omap system?

Thanks,
Ludo’.
M
M
Mathieu Othacehe wrote on 6 Nov 2017 19:57
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 29133@debbugs.gnu.org)
87po8vme05.fsf@gmail.com
Toggle quote (2 lines)
> LGTM! Were you able to boot it on an omap system?

Not yet, I'm still fighting to build a disk-image on qemu :)

Anyway, pushed as f6948189a940c0bf354672141762c6dacf1395e1, thanks !
M
M
Mathieu Othacehe wrote on 6 Nov 2017 20:04
control message for bug #29133
(address . control@debbugs.gnu.org)
87inenmdno.fsf@gmail.com
tags 29133 fixed
close 29133
?