[PATCH] gnu: Add emacs-robe.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 18 Oct 2017 08:20
(address . guix-patches@gnu.org)
20171018062027.14406-1-mail@cbaines.net
* gnu/packages/emacs.scm (emacs-robe): New variable.
---
gnu/packages/emacs.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 315db18a5..45dde77e0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2124,6 +2124,31 @@ tables.")
mode-line.")
(license license:gpl2+)))
+(define-public emacs-robe
+ (package
+ (name "emacs-robe")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/dgutov/robe/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vp45y99fwj88z04ah4yppz4z568qcib646az6m9az5ar0f203br"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-inf-ruby" ,emacs-inf-ruby)))
+ (home-page "https://github.com/dgutov/robe")
+ (synopsis "Ruby code assistance tool for Emacs")
+ (description
+ "Robe can provide information on loaded classes and modules in Ruby code,
+as well as where methods are defined. This allows the user to jump to method
+definitions, modules and classes, display method documentation and provide
+method and constant name completion.")
+ (license license:gpl3+)))
+
(define-public emacs-rspec
(package
(name "emacs-rspec")
--
2.14.2
R
R
Ricardo Wurmus wrote on 18 Oct 2017 22:31
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28886@debbugs.gnu.org)
87h8uw42qi.fsf@elephly.net
Hi,

Toggle quote (3 lines)
> * gnu/packages/emacs.scm (emacs-robe): New variable.
> ---

Thanks, this looks good.

The website lists a couple of Ruby dependencies:

Toggle snippet (6 lines)
* pry
* pry-doc >= 0.6.0 (on MRI)
* method_source >= 0.8.2 (for compatibility with the latest
Rubinius)

yet, I don’t see them among the inputs of this package. Is this just
something that users are reasonably expected to have on their systems
when they want to use robe, or should these things be among the inputs?

I trust you made the right decision here, but I thought I’d just ask as
it is a bit confusing.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
R
R
Ricardo Wurmus wrote on 25 Oct 2017 16:31
control message for bug #28886
(address . control@debbugs.gnu.org)
E1e7Mip-0008AI-Dm@debbugs.gnu.org
tags 28886 moreinfo
R
R
Ricardo Wurmus wrote on 4 Dec 2017 00:04
Re: [bug#28886] [PATCH] gnu: Add emacs-robe.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28886@debbugs.gnu.org)
87374r4dnh.fsf@elephly.net
Hi again,

some time ago I wrote this:

Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (23 lines)
> Hi,
>
>> * gnu/packages/emacs.scm (emacs-robe): New variable.
>> ---
>
> Thanks, this looks good.
>
> The website lists a couple of Ruby dependencies:
>
> --8<---------------cut here---------------start------------->8---
> * pry
> * pry-doc >= 0.6.0 (on MRI)
> * method_source >= 0.8.2 (for compatibility with the latest
> Rubinius)
> --8<---------------cut here---------------end--------------->8---
>
> yet, I don’t see them among the inputs of this package. Is this just
> something that users are reasonably expected to have on their systems
> when they want to use robe, or should these things be among the inputs?
>
> I trust you made the right decision here, but I thought I’d just ask as
> it is a bit confusing.

“pry” is a ruby debugger, right? It is a runtime dependency, but one
would expect a Ruby developer to provide one version or another,
dependent on their project.

If this is correct I don’t want to block this patch: it looks good to
me.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
C
C
Christopher Baines wrote on 9 Dec 2017 22:14
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 28886-done@debbugs.gnu.org)
87609f7ge4.fsf@cbaines.net
Ricardo Wurmus writes:

Toggle quote (36 lines)
> Hi again,
>
> some time ago I wrote this:
>
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> Hi,
>>
>>> * gnu/packages/emacs.scm (emacs-robe): New variable.
>>> ---
>>
>> Thanks, this looks good.
>>
>> The website lists a couple of Ruby dependencies:
>>
>> --8<---------------cut here---------------start------------->8---
>> * pry
>> * pry-doc >= 0.6.0 (on MRI)
>> * method_source >= 0.8.2 (for compatibility with the latest
>> Rubinius)
>> --8<---------------cut here---------------end--------------->8---
>>
>> yet, I don’t see them among the inputs of this package. Is this just
>> something that users are reasonably expected to have on their systems
>> when they want to use robe, or should these things be among the inputs?
>>
>> I trust you made the right decision here, but I thought I’d just ask as
>> it is a bit confusing.
>
> “pry” is a ruby debugger, right? It is a runtime dependency, but one
> would expect a Ruby developer to provide one version or another,
> dependent on their project.
>
> If this is correct I don’t want to block this patch: it looks good to
> me.

Ok, great. I was planning on trying to use this more, but I haven't got
around to that yet. I've pushed this to master now, maybe that will
help.

Thanks for reviewing :)

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlosUkNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xe68Q//QC5xLD72bRwXXkNKjUx0BNC44BMesAFjMDHtZkzTG+qUi9jCAsmcMaHs
QTwIkrEcTT2l3idWpfnLpGCyPM/rVfQU3L8bf3CV4AgivuMSegbMc3qoj9id68pH
zp8b7mbxueR7zX1bFVr9N9GVV63f9W4k2cijodzqKwL6WKNSAnSfpEG1Gdtn8g1/
n0sDElXF0e8lX+pKCPT6N+EYIyxRNUb5jaf3sppRkwasikBhLZxE083LrlMmwXVe
8HI4CuHZ2xzoqP56D7CNigHDiI7Xi9OxuXBFHBfivkNjnE4aA/SgrxTkr3SRAbFe
l50Ki/rJYWBma7+yasemWCVtbpzc7CmcvZgRJA0sGa1G16Q4VvT0Mb10bvtGgowx
pQhS0cfvVTL72Y+c1l2TNFjobDpU8Bka5Q1oKe4ycCzLwvHS+ojBWVEA/Do91QXA
vD0RWiLNyx/iP1cXaadhugSHmtlFS9aI+tnD3g/4o3xot4lB97+NYALiCdKKyAQm
yV9mQUNUuj6IGlW9nd20BuAKShAMoTRXazhlD/IibQrOwmCboCPoybk33U/u2BvL
PYNa9uKAcgUOXptzHAEDehkYW/RnLCW4VcJr8Hcekht1nCa0SI1+U6wxpUdAr2b3
3ZQ9itHcOx3GvzioSydFtQEEIx3HrEVUCxRm53kGJ7CSpuVgO9c=
=tTaf
-----END PGP SIGNATURE-----

Closed
?