[PATCH] gnu: node: Update to 8.2.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jelle Licht
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jelle Licht
Severity
normal
J
J
Jelle Licht wrote on 27 Jul 2017 17:33
(address . guix-patches@gnu.org)
CAPsKtfJGB058Gz6vYwVnS_kW11bE36=rL_rGhwfdmGK-wq2kfg@mail.gmail.com
It seems the node devs do not expect packagers to run `make check':

Anyway, attached you will find a patch which updates node to its latest
released version while still allowing use to run most of the included test
suite.

At some point in time someone could look into getting node to build
reproducibly. Who knows, it might even be me ;-).

- Jelle
Attachment: file
From f88297638a82858dff61176f646cdc4ddca748cf Mon Sep 17 00:00:00 2001
From: Jelle Licht <jlicht@fsfe.org>
Date: Thu, 27 Jul 2017 17:11:08 +0200
Subject: [PATCH] gnu: node: Update to 8.2.1.

* gnu/packages/node.scm (node): Update to 8.2.1.
(node)[arguments]: Removed broken linter test.
---
gnu/packages/node.scm | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 2cebabbca..4892bc9f0 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -40,14 +40,14 @@
(define-public node
(package
(name "node")
- (version "8.1.2")
+ (version "8.2.1")
(source (origin
(method url-fetch)
(uri (string-append "http://nodejs.org/dist/v" version
"/node-v" version ".tar.gz"))
(sha256
(base32
- "0l92gar1pivzaiwffiiiz2f2m5k39sl5fphlfnvy0ml9hrjb65yp"))
+ "0gwp65mls420x64jk3bkx7xdq75zjnv5mi5mqqb9mbvxpiwi7zk6"))
;; https://github.com/nodejs/node/pull/9077
(patches (search-patches "node-9077.patch"))))
(build-system gnu-build-system)
@@ -78,10 +78,9 @@
(("'/usr/bin/env'")
(string-append "'" (which "env") "'")))
- ;; Having the build fail because of linter errors is insane!
+ ;; Linting is no longer supported in the release tarball
(substitute* '("Makefile")
- ((" \\$\\(MAKE\\) jslint") "")
- ((" \\$\\(MAKE\\) cpplint\n") ""))
+ ((" \\$\\(MAKE\\) lint") ""))
;; FIXME: This test seems to depends on files that are not
;; available in the bundled v8. See
--
2.13.3
L
L
Ludovic Courtès wrote on 28 Jul 2017 21:40
(name . Jelle Licht)(address . jlicht@fsfe.org)(address . 27852@debbugs.gnu.org)
87y3r8l59a.fsf@gnu.org
Jelle Licht <jlicht@fsfe.org> skribis:

Toggle quote (8 lines)
> From f88297638a82858dff61176f646cdc4ddca748cf Mon Sep 17 00:00:00 2001
> From: Jelle Licht <jlicht@fsfe.org>
> Date: Thu, 27 Jul 2017 17:11:08 +0200
> Subject: [PATCH] gnu: node: Update to 8.2.1.
>
> * gnu/packages/node.scm (node): Update to 8.2.1.
> (node)[arguments]: Removed broken linter test.

LGTM!

Toggle quote (7 lines)
> - ;; Having the build fail because of linter errors is insane!
> + ;; Linting is no longer supported in the release tarball
> (substitute* '("Makefile")
> - ((" \\$\\(MAKE\\) jslint") "")
> - ((" \\$\\(MAKE\\) cpplint\n") ""))
> + ((" \\$\\(MAKE\\) lint") ""))

future reference?

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 2 Sep 2017 00:20
(name . Jelle Licht)(address . jlicht@fsfe.org)(address . 27852@debbugs.gnu.org)
873786ysbo.fsf@gnu.org
Jelle, it looks like this fell through the cracks a warm summer
inevitably creates, no? :-)

Ludo’.

ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (24 lines)
> Jelle Licht <jlicht@fsfe.org> skribis:
>
>> From f88297638a82858dff61176f646cdc4ddca748cf Mon Sep 17 00:00:00 2001
>> From: Jelle Licht <jlicht@fsfe.org>
>> Date: Thu, 27 Jul 2017 17:11:08 +0200
>> Subject: [PATCH] gnu: node: Update to 8.2.1.
>>
>> * gnu/packages/node.scm (node): Update to 8.2.1.
>> (node)[arguments]: Removed broken linter test.
>
> LGTM!
>
>> - ;; Having the build fail because of linter errors is insane!
>> + ;; Linting is no longer supported in the release tarball
>> (substitute* '("Makefile")
>> - ((" \\$\\(MAKE\\) jslint") "")
>> - ((" \\$\\(MAKE\\) cpplint\n") ""))
>> + ((" \\$\\(MAKE\\) lint") ""))
>
> Maybe add a link to <https://github.com/nodejs/node/issues/14513> for
> future reference?
>
> Thanks,
> Ludo’.
L
L
Ludovic Courtès wrote on 5 Sep 2017 15:20
control message for bug #27852
(address . control@debbugs.gnu.org)
87wp5dqo2w.fsf@gnu.org
tags 27852 fixed
close 27852
?