[PATCH 2/3] gnu: video: Add libmediainfo.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ethan R. Jones
  • Ludovic Courtès
  • Marius Bakke
Owner
unassigned
Submitted by
Ethan R. Jones
Severity
normal
E
E
Ethan R. Jones wrote on 23 May 2017 22:43
(address . guix-patches@gnu.org)(name . Ethan R. Jones)(address . doubleplusgood23@gmail.com)
20170523204306.25418-2-doubleplusgood23@gmail.com
* gnu/packages/video.scm (libmediainfo): New variable.
---
gnu/packages/video.scm | 54 ++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index bc3fa48b8..b8dc02e2f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2088,3 +2088,57 @@ practically any type of media.")
strings, configuration, bit streams, threading, translation, and cross-platform
operating system functions.")
(license license:bsd-2)))
+
+(define-public libmediainfo
+ (package
+ (name "libmediainfo")
+ (version "0.7.95")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://mediaarea.net/download/source/"
+ name "/" version"/"
+ name "_" version ".tar.bz2"))
+ (file-name (string-append name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1kchh6285b07z5nixv619hc9gml2ysdayicdiv30frrlqiyxqw4b"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("zlib" ,zlib)
+ ("tinyxml2" ,tinyxml2)
+ ("curl" ,curl)
+ ("libzen" ,libzen)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; test currently requires an external video file
+ #:phases
+ ;; build scripts not in root of archive
+ (modify-phases %standard-phases
+ (add-before
+ 'configure 'pre-configure
+ (lambda _
+ (chdir "Project/GNU/Library")))
+ (add-before 'configure 'autogen
+ (lambda _
+ (zero? (system* "./autogen.sh")))))))
+ (home-page "https://mediaarea.net/en/MediaInfo")
+ (synopsis "Library for retrieving media metadata")
+ (description " MediaInfo is a library used for retrieving
+technical information and other metadata about audio or video files.
+A non-exhaustive list of the information MediaInfo can retrieve from media files include:
+ - General: title, author, director, album, track number, date, duration...
+ - Video: codec, aspect, fps, bitrate...
+ - Audio: codec, sample rate, channels, language, bitrate...
+ - Text: language of subtitle
+ - Chapters: number of chapters, list of chapters
+MediaInfo supports the following formats:
+ - Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
+ MPEG-4, DVD (VOB)...
+ - Video Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
+ - Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF...
+ - Subtitles: SRT, SSA, ASS, SAMI...")
+ (license license:bsd-2)))
+
--
2.13.0
M
M
Marius Bakke wrote on 24 May 2017 18:34
(name . Ethan R. Jones)(address . doubleplusgood23@gmail.com)
87mva2w6wv.fsf@fastmail.com
"Ethan R. Jones" <doubleplusgood23@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/video.scm (libmediainfo): New variable.

[...]

Toggle quote (3 lines)
> + (arguments
> + '(#:tests? #f ; test currently requires an external video file

Do they offer a video file for this purpose, or will anything do? Please
add a TODO here, sounds like we can just add some video file as a
native-input and use that.

Toggle quote (27 lines)
> + #:phases
> + ;; build scripts not in root of archive
> + (modify-phases %standard-phases
> + (add-before
> + 'configure 'pre-configure
> + (lambda _
> + (chdir "Project/GNU/Library")))
> + (add-before 'configure 'autogen
> + (lambda _
> + (zero? (system* "./autogen.sh")))))))
> + (home-page "https://mediaarea.net/en/MediaInfo")
> + (synopsis "Library for retrieving media metadata")
> + (description " MediaInfo is a library used for retrieving
> +technical information and other metadata about audio or video files.
> +A non-exhaustive list of the information MediaInfo can retrieve from media files include:
> + - General: title, author, director, album, track number, date, duration...
> + - Video: codec, aspect, fps, bitrate...
> + - Audio: codec, sample rate, channels, language, bitrate...
> + - Text: language of subtitle
> + - Chapters: number of chapters, list of chapters
> +MediaInfo supports the following formats:
> + - Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
> + MPEG-4, DVD (VOB)...
> + - Video Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
> + - Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF...
> + - Subtitles: SRT, SSA, ASS, SAMI...")

Can you convert this list to use "@itemize" instead? Grep around
gnu/packages for some examples.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlkltgAACgkQoqBt8qM6
VPrH+Qf9GFtQOKmYunBREk7bXD+WXgOtNgHO9jooq3uNY8Guw4pM28qA9da4x/To
1kDMg5AaCPs0Rty+5+hn9p7JpVnl34KrVSEAngb+ltC/GZzW9JCh7HSsuDuMKA06
4WRdnSBmcQKAlpE92MCEwwImFVDu7cq4/5pN2TyXPpCd4bBuO31EcHfiKELKFDZc
ceMTLQpLd836+XsDn8YaV9EaREdF+HIdUFs4gCiavED9N8cG4rFSnDI8v1YmcbSh
ysDCVmmKVhfjRquUBJxTdNdiYEREWSAZjcaoT2300IwYj1xlgPXVEqjHRQk1XVME
3NQjrzNrv82V9jQLk8Nsf8YsDz+7MA==
=XtLp
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 31 May 2017 17:52
control message for bug #27045
(address . control@debbugs.gnu.org)
874lw1c9c1.fsf@gnu.org
tags 27045 fixed
close 27045
?