phonon: install Qt extensions, add gstreamer backend.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Marius Bakke
  • Thomas Danckaert
Owner
unassigned
Submitted by
Thomas Danckaert
Severity
normal
T
T
Thomas Danckaert wrote on 2 Mar 2017 11:40
(address . guix-patches@gnu.org)
20170302.114016.2115500609318507651.post@thomasdanckaert.be
Hi,
the first patch installs qt extensions, so qmake projects can use
“CONFIG+=phonon4qt5”. The second patch adds the phonon gstreamer
backend, so phonon can actually play back media :0)
Thomas
From ee8c6f45a8bc67910a279e95bfdc0defe18f37db Mon Sep 17 00:00:00 2001
From: Thomas Danckaert <post@thomasdanckaert.be>
Date: Thu, 2 Mar 2017 09:33:43 +0100
Subject: [PATCH 1/2] gnu: phonon: Install Qt extensions.
* gnu/packages/kde-frameworks.scm (phonon)[arguments]: Add
-DPHONON-INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT configure flag, and patch the
installation directory.
---
gnu/packages/kde-frameworks.scm | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)
Toggle diff (102 lines)
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 36c285156..6ff754b07 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -119,7 +120,18 @@ common build settings used in software produced by the KDE community.")
(arguments
`(#:configure-flags
'("-DCMAKE_CXX_FLAGS=-fPIC"
- "-DPHONON_BUILD_PHONON4QT5=ON")))
+ "-DPHONON_BUILD_PHONON4QT5=ON"
+ "-DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=ON")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'patch-installdir
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((regex (string-append "(INSTALL DESTINATION \")"
+ (assoc-ref inputs "qtbase"))))
+ (substitute* "cmake_install.cmake"
+ ((regex all dest)
+ (string-append dest (assoc-ref outputs "out")))))
+ #t)))))
(home-page "https://phonon.kde.org")
(synopsis "KDE's multimedia library")
(description "KDE's multimedia library.")
--
2.11.1
From 052b821a937a67b83693e2db35149651552e371c Mon Sep 17 00:00:00 2001
From: Thomas Danckaert <post@thomasdanckaert.be>
Date: Thu, 2 Mar 2017 11:20:53 +0100
Subject: [PATCH 2/2] gnu: Add phonon-backend-gstreamer.
* gnu/packages/kde-frameworks.scm (phonon-backend-gstreamer): New variable.
---
gnu/packages/kde-frameworks.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 6ff754b07..778f217e0 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -43,6 +43,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages linux)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -137,6 +138,41 @@ common build settings used in software produced by the KDE community.")
(description "KDE's multimedia library.")
(license license:lgpl2.1+)))
+(define-public phonon-backend-gstreamer
+ (package
+ (name "phonon-backend-gstreamer")
+ (version "4.9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/phonon"
+ name "/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1wc5p1rqglf0n1avp55s50k7fjdzdrhg0gind15k8796w7nfbhyf"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("phonon" ,phonon)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("libxml2" ,libxml2)))
+ (arguments
+ `(#:configure-flags
+ '( "-DPHONON_BUILD_PHONON4QT5=ON")))
+ (home-page "https://phonon.kde.org")
+ (synopsis "Phonon backend which uses GStreamer")
+ (description "Phonon makes use of backend libraries to provide sound.
+Phonon-GStreamer is a backend based on the GStreamer multimedia library.")
+ ;; license: source files mention "either version 2.1 or 3"
+ (license license:lgpl2.1 license:lgpl3)))
+
(define-public gpgmepp
(package
(name "gpgmepp")
--
2.11.1
T
T
Thomas Danckaert wrote on 2 Mar 2017 11:51
(address . 25932@debbugs.gnu.org)
20170302.115158.609616815269416168.post@thomasdanckaert.be
From: Thomas Danckaert <post@thomasdanckaert.be>
Subject: bug#25932: phonon: install Qt extensions, add gstreamer
backend.
Date: Thu, 02 Mar 2017 11:40:16 +0100 (CET)
Toggle quote (7 lines)
> Hi,
>
> the first patch installs qt extensions, so qmake projects can use
> “CONFIG+=phonon4qt5”. The second patch adds the phonon gstreamer
> backend, so phonon can actually play back media :0)
>
> Thomas
Updated patch, please disregard the previous version (I broke it in
the last minute when updating the license field...).
From ee8c6f45a8bc67910a279e95bfdc0defe18f37db Mon Sep 17 00:00:00 2001
From: Thomas Danckaert <post@thomasdanckaert.be>
Date: Thu, 2 Mar 2017 09:33:43 +0100
Subject: [PATCH 1/2] gnu: phonon: Install Qt extensions.
* gnu/packages/kde-frameworks.scm (phonon)[arguments]: Add
-DPHONON-INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT configure flag, and patch the
installation directory.
---
gnu/packages/kde-frameworks.scm | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)
Toggle diff (102 lines)
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 36c285156..6ff754b07 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -119,7 +120,18 @@ common build settings used in software produced by the KDE community.")
(arguments
`(#:configure-flags
'("-DCMAKE_CXX_FLAGS=-fPIC"
- "-DPHONON_BUILD_PHONON4QT5=ON")))
+ "-DPHONON_BUILD_PHONON4QT5=ON"
+ "-DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=ON")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'patch-installdir
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((regex (string-append "(INSTALL DESTINATION \")"
+ (assoc-ref inputs "qtbase"))))
+ (substitute* "cmake_install.cmake"
+ ((regex all dest)
+ (string-append dest (assoc-ref outputs "out")))))
+ #t)))))
(home-page "https://phonon.kde.org")
(synopsis "KDE's multimedia library")
(description "KDE's multimedia library.")
--
2.11.1
From 052b821a937a67b83693e2db35149651552e371c Mon Sep 17 00:00:00 2001
From: Thomas Danckaert <post@thomasdanckaert.be>
Date: Thu, 2 Mar 2017 11:20:53 +0100
Subject: [PATCH 2/2] gnu: Add phonon-backend-gstreamer.
* gnu/packages/kde-frameworks.scm (phonon-backend-gstreamer): New variable.
---
gnu/packages/kde-frameworks.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 6ff754b07..778f217e0 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -43,6 +43,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages linux)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -137,6 +138,41 @@ common build settings used in software produced by the KDE community.")
(description "KDE's multimedia library.")
(license license:lgpl2.1+)))
+(define-public phonon-backend-gstreamer
+ (package
+ (name "phonon-backend-gstreamer")
+ (version "4.9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/phonon"
+ name "/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1wc5p1rqglf0n1avp55s50k7fjdzdrhg0gind15k8796w7nfbhyf"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("phonon" ,phonon)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("libxml2" ,libxml2)))
+ (arguments
+ `(#:configure-flags
+ '( "-DPHONON_BUILD_PHONON4QT5=ON")))
+ (home-page "https://phonon.kde.org")
+ (synopsis "Phonon backend which uses GStreamer")
+ (description "Phonon makes use of backend libraries to provide sound.
+Phonon-GStreamer is a backend based on the GStreamer multimedia library.")
+ ;; license: source files mention "either version 2.1 or 3"
+ (license license:lgpl2.1 license:lgpl3)))
+
(define-public gpgmepp
(package
(name "gpgmepp")
--
2.11.1
T
T
Thomas Danckaert wrote on 2 Mar 2017 12:37
(address . 25932@debbugs.gnu.org)
20170302.123712.967046726856716568.post@thomasdanckaert.be
From: Thomas Danckaert <post@thomasdanckaert.be>
Subject: bug#25932: phonon: install Qt extensions, add gstreamer backend.
Date: Thu, 02 Mar 2017 11:40:16 +0100 (CET)
Toggle quote (7 lines)
> Hi,
>
> the first patch installs qt extensions, so qmake projects can use
> “CONFIG+=phonon4qt5”. The second patch adds the phonon gstreamer
> backend, so phonon can actually play back media :0)
>
> Thomas
Now really with an updated patch, please disregard both previous versions...
From ee8c6f45a8bc67910a279e95bfdc0defe18f37db Mon Sep 17 00:00:00 2001
From: Thomas Danckaert <post@thomasdanckaert.be>
Date: Thu, 2 Mar 2017 09:33:43 +0100
Subject: [PATCH 1/2] gnu: phonon: Install Qt extensions.
* gnu/packages/kde-frameworks.scm (phonon)[arguments]: Add
-DPHONON-INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT configure flag, and patch the
installation directory.
---
gnu/packages/kde-frameworks.scm | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)
Toggle diff (102 lines)
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 36c285156..6ff754b07 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -119,7 +120,18 @@ common build settings used in software produced by the KDE community.")
(arguments
`(#:configure-flags
'("-DCMAKE_CXX_FLAGS=-fPIC"
- "-DPHONON_BUILD_PHONON4QT5=ON")))
+ "-DPHONON_BUILD_PHONON4QT5=ON"
+ "-DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=ON")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'patch-installdir
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((regex (string-append "(INSTALL DESTINATION \")"
+ (assoc-ref inputs "qtbase"))))
+ (substitute* "cmake_install.cmake"
+ ((regex all dest)
+ (string-append dest (assoc-ref outputs "out")))))
+ #t)))))
(home-page "https://phonon.kde.org")
(synopsis "KDE's multimedia library")
(description "KDE's multimedia library.")
--
2.11.1
From 16a578a24ef27139f59fbaf7a3be3131f57d5327 Mon Sep 17 00:00:00 2001
From: Thomas Danckaert <post@thomasdanckaert.be>
Date: Thu, 2 Mar 2017 11:20:53 +0100
Subject: [PATCH 2/2] gnu: Add phonon-backend-gstreamer.
* gnu/packages/kde-frameworks.scm (phonon-backend-gstreamer): New variable.
---
gnu/packages/kde-frameworks.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 6ff754b07..948b9b465 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -43,6 +43,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages linux)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -137,6 +138,41 @@ common build settings used in software produced by the KDE community.")
(description "KDE's multimedia library.")
(license license:lgpl2.1+)))
+(define-public phonon-backend-gstreamer
+ (package
+ (name "phonon-backend-gstreamer")
+ (version "4.9.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/phonon"
+ name "/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1wc5p1rqglf0n1avp55s50k7fjdzdrhg0gind15k8796w7nfbhyf"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("phonon" ,phonon)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("libxml2" ,libxml2)))
+ (arguments
+ `(#:configure-flags
+ '( "-DPHONON_BUILD_PHONON4QT5=ON")))
+ (home-page "https://phonon.kde.org")
+ (synopsis "Phonon backend which uses GStreamer")
+ (description "Phonon makes use of backend libraries to provide sound.
+Phonon-GStreamer is a backend based on the GStreamer multimedia library.")
+ ;; license: source files mention "either version 2.1 or 3"
+ (license (list license:lgpl2.1 license:lgpl3))))
+
(define-public gpgmepp
(package
(name "gpgmepp")
--
2.11.1
L
L
Ludovic Courtès wrote on 11 Mar 2017 22:15
(name . Thomas Danckaert)(address . post@thomasdanckaert.be)(address . 25932@debbugs.gnu.org)
87shmj5xcg.fsf@gnu.org
Hi Thomas,

Thomas Danckaert <post@thomasdanckaert.be> skribis:

Toggle quote (9 lines)
> From ee8c6f45a8bc67910a279e95bfdc0defe18f37db Mon Sep 17 00:00:00 2001
> From: Thomas Danckaert <post@thomasdanckaert.be>
> Date: Thu, 2 Mar 2017 09:33:43 +0100
> Subject: [PATCH 1/2] gnu: phonon: Install Qt extensions.
>
> * gnu/packages/kde-frameworks.scm (phonon)[arguments]: Add
> -DPHONON-INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT configure flag, and patch the
> installation directory.

[...]

Toggle quote (7 lines)
> From 16a578a24ef27139f59fbaf7a3be3131f57d5327 Mon Sep 17 00:00:00 2001
> From: Thomas Danckaert <post@thomasdanckaert.be>
> Date: Thu, 2 Mar 2017 11:20:53 +0100
> Subject: [PATCH 2/2] gnu: Add phonon-backend-gstreamer.
>
> * gnu/packages/kde-frameworks.scm (phonon-backend-gstreamer): New variable.

Applied both, thanks!

BTW, do you have an account on Savannah? If not, could you create one,
add the OpenPGP key you’d use to sign commits there, and let me know so
I can give you commit access? That should help. :-)

Ludo’.
T
T
Thomas Danckaert wrote on 13 Mar 2017 09:56
(address . ludo@gnu.org)(address . 25932@debbugs.gnu.org)
20170313.095636.1204950683619868682.post@thomasdanckaert.be
From: ludo@gnu.org (Ludovic Courtès)
Subject: Re: bug#25932: phonon: install Qt extensions, add gstreamer backend.
Date: Sat, 11 Mar 2017 22:15:27 +0100
Toggle quote (1 lines)
> Applied both, thanks!
thanks!
Toggle quote (3 lines)
> BTW, do you have an account on Savannah? If not, could you create one,
> add the OpenPGP key you’d use to sign commits there, and let me know so
> I can give you commit access? That should help. :-)
Thanks again! :) I've created
Thomas
L
L
Ludovic Courtès wrote on 13 Mar 2017 10:12
(name . Thomas Danckaert)(address . post@thomasdanckaert.be)(address . 25932@debbugs.gnu.org)
87varda6c1.fsf@gnu.org
Hi Thomas!

Thomas Danckaert <post@thomasdanckaert.be> skribis:

Toggle quote (2 lines)
Awesome. I’ve added you to the group. Please read ‘HACKING’ and make
sure to set up commit signing appropriately.

To make sure that you control key
1DD1681FE285E07F11DC0C592E15A6BCD77D54FD, could you reply to this
message with a signed message?

Welcome again and happy hacking! :-)

Ludo’.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEPORkVYqE/cadtAz7CQsRmT2a67UFAljGYm8ACgkQCQsRmT2a
67XT/A/8CCwwX140ODjOZYQywc1VRi3/gfK5EVcKb5z+WzF5hpPTIIbDxqv99jD7
bm6tjAFwEjxDiIpDrn+oYE2uBnCyoi05fiNoQWt/OI0S2Nt6hMUlj6hpxlF5KpCT
W1sFWDlIEInQlJvxsTkJNjAZMMh1Zgf+GfhhmvPCxnsC9QV9LCLC4PHl/kglWoeQ
W3HFswFnvlwQN7926joxgm+S/fcZ3n3NJHO7kvgMnQDVremkHTfaY3d1l8/XArFw
/eRX5zS/zo57+WmBuw/ajllHSR+2Oge/ICLJjZYe+YfSOivgPov7RKoKaq9KAptT
UKGOP9g9x9qgNGri6tFj6+sYimiLMv5rNczimVR3KzokrqPbXoGWMxjcT4frRkbW
PkN5qM8vJDCAMdhmuUwoxsKjIenwKkNyN4fQw+bW0qWl5cuzH6oazJKRJjDZ+sNf
x8yyu/0vZFE5oQugm0YXuxSdXS16z7VUa47U8q3Mgc5WPAWdVS1QHBXLhER4IlpK
U968qLMYAAZ33ErCaX2ei1pdIi+w81qR/bqStVY7Cg488yKyZi78n1xI3nbPR9D5
sNWen95fQTQmojYODcbiLHWGMYcemzToRvmO7fUk1YSBA/qR7dNKTl2FtsugC23Q
A+SjNz0djXh9MVB7GqPmlYtzO9d5neXxj6lMNlPyUW4JFuyMluU=
=MARb
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 13 Mar 2017 14:16
control message for bug #25932
(address . control@debbugs.gnu.org)
87lgs9e2pl.fsf@gnu.org
tags 25932 fixed
close 25932
T
T
Thomas Danckaert wrote on 13 Mar 2017 19:49
Re: bug#25932: phonon: install Qt extensions, add gstreamer backend.
(address . ludo@gnu.org)(address . 25932@debbugs.gnu.org)
20170313.194948.1031749303943182536.post@thomasdanckaert.be
Here it is.
From: ludo@gnu.org (Ludovic Courtès)
Subject: Re: bug#25932: phonon: install Qt extensions, add gstreamer backend.
Date: Mon, 13 Mar 2017 10:12:14 +0100
Toggle quote (16 lines)
> Hi Thomas!
>
> Thomas Danckaert <post@thomasdanckaert.be> skribis:
>
>> https://savannah.gnu.org/users/thomasd
>
> Awesome. I’ve added you to the group. Please read ‘HACKING’ and make
> sure to set up commit signing appropriately.
>
> To make sure that you control key
> 1DD1681FE285E07F11DC0C592E15A6BCD77D54FD, could you reply to this
> message with a signed message?
>
> Welcome again and happy hacking! :-)
>
> Ludo’.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEPSzaWIGcCMKmSdQ9XDsGTHJKVyYFAljG6cwACgkQXDsGTHJK
VyZWrQ/+ME67fMHNEeaifyI7zPj/GBIDAIKBHhOmwgm5P+bztr0Yal4IZf0ZFm8Y
bhIezwNvsWA/qJ1BMiOBTYRJRWQjeS94o+RA0UtSMLj4WWaEuXIwNJZ/YuNUu8Km
5nwj0xs0b2treqCNidgH8soysjdjYimyCTq7a2jkLH9cCVujdLaNDjg4Hbsi++eb
w7ehMZfLnW3Wi8ltC35RCw3nXnJoUMXlgAk55cemP6xWn5ywYR5/LiSthXykVq6/
cYrFWQ28n2d8diLttnhX1CmiKaSSGYWqz+lEx9uiFjAMFMfdKDE+ve7UDKtuTqIi
DhWJ0Lm5/rn2XTb6BelWL8oR9Lk6N4O005J9o9YF4J1QJKpSVVY2ZluC6l/Lds9e
/vW2QotyJrboWWyC83wRL5E8dZsgRSGU3f2vbvOnH9FLKK4N0BsVZ9nJVIwMsoK7
QO1PjlBODcwY5C3i7u+jS8ZHB+NB8kurHPJeTEUgPPnmZ7XaQaYQ+i/RajY3L/lQ
O+zR0+argAE+zHmvlAcfZ2tlthKUTjCmNRVvoK7XaX6lD5/vVNR8xzA60J8jLaM3
yzEdADtZvSv1PmqIeRkNq+iA5zVpI5z//F3u1u4rNyIZNjnpxZU9hDGD98nD7hlu
Ee20tsjBi37pE6h5tifDFHCwansNKWowEx9ar4y1btO6qDmvibk=
=ATLi
-----END PGP SIGNATURE-----


M
M
Marius Bakke wrote on 13 Mar 2017 19:53
(address . 25932@debbugs.gnu.org)
87wpbt3t5b.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Thomas Danckaert <post@thomasdanckaert.be> writes:

Toggle quote (2 lines)
> Here it is.

Yay! Welcome! :)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAljG6rAACgkQoqBt8qM6
VPpJTggApQ3k6e/iUDWwgQac5SRXLy70C9ov29VjNcClkpwvhufp4BNrLh1SIhrB
YYhUbpPMJKMn/kJSmbl6PI6A8ta9CJsOESndGqklr19qCA0Y+ORg8bBQXO5HV7WJ
h31oxGPyOSUQzR7+ExLgCGM7Qr7LNyi6AAUm0okUFmPrHjo2+c6ntTXVrF1Evlu3
5sTRUdc3iX9ZJO1x9e54qbQgQL0/olTOGhfIf8twV1hkduy3uBCy2W7HdJiiQEwp
l5Kc+TnyXY6NPaU7eOlGrT6djd87v56dBwtDQxRqhjTqDrE8h/No/SnxAMIj25xN
xWO2erMpUr/gc+JVz69FGrO3K66NRw==
=WluV
-----END PGP SIGNATURE-----

?