guix lint doesn't actually fail on some errors

  • Done
  • quality assurance status badge
Details
4 participants
  • Danny Milosavljevic
  • Ludovic Courtès
  • Maxim Cournoyer
  • zimoun
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
D
D
Danny Milosavljevic wrote on 27 Jul 2016 00:25
(address . bug-guix@gnu.org)
20160727002502.4acf8f47@scratchpost.org
guix lint doesn't actually fail on some errors.

$ guix lint perl-io-socket-inet6 ; echo $?
;;; note: source file /x/home/dannym/src/guix/gnu/packages/networking.scm
;;; newer than compiled /x/home/dannym/src/guix/gnu/packages/networking.go
;;; note: source file /x/home/dannym/src/guix/gnu/packages/mail.scm
;;; newer than compiled /x/home/dannym/src/guix/gnu/packages/mail.go
;;; note: source file /x/home/dannym/src/guix/gnu/packages/ldc.scm
;;; newer than compiled /x/home/dannym/src/guix/gnu/packages/ldc.go
gnu/packages/networking.scm:437:1: perl-io-socket-inet6-2.72: line 464 is way too long (96 characters)
gnu/packages/networking.scm:437:1: perl-io-socket-inet6-2.72: line 483 is way too long (92 characters)
0
^--- ooops
L
L
Ludovic Courtès wrote on 27 Jul 2016 22:57
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 24083@debbugs.gnu.org)
87mvl2x0ic.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (2 lines)
> guix lint doesn't actually fail on some errors.

It never pretended to exit with non-zero when warnings are emitted. :-)
(These are warnings, not errors.)

Ludo’.
D
D
Danny Milosavljevic wrote on 27 Jul 2016 23:12
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 24083@debbugs.gnu.org)
20160727231222.66849389@scratchpost.org
On Wed, 27 Jul 2016 22:57:15 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (7 lines)
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
> > guix lint doesn't actually fail on some errors.
>
> It never pretended to exit with non-zero when warnings are emitted. :-)
> (These are warnings, not errors.)

Too bad :)

I wrote a little helper script which was supposed to prevent me from posting packages that don't build or lint. Then I found out that the lint actually doesn't fail on warnings. So now my script is only half as useful (the builder does fail on build error).

It would be nice to have a way to also check the lint status.
Z
Z
zimoun wrote on 24 Mar 2021 23:19
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
86tup09ovb.fsf@gmail.com
Hi,

On Wed, 27 Jul 2016 at 23:12, Danny Milosavljevic <dannym@scratchpost.org> wrote:
Toggle quote (17 lines)
> On Wed, 27 Jul 2016 22:57:15 +0200 ludo@gnu.org (Ludovic Courtès) wrote:
>> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>>
>> > guix lint doesn't actually fail on some errors.
>>
>> It never pretended to exit with non-zero when warnings are emitted. :-)
>> (These are warnings, not errors.)
>
> Too bad :)
>
> I wrote a little helper script which was supposed to prevent me from posting
> packages that don't build or lint. Then I found out that the lint actually
> doesn't fail on warnings. So now my script is only half as useful (the builder
> does fail on build error).
>
> It would be nice to have a way to also check the lint status.

The good news is that the initial example ’perl-io-socket-inet6’ now
does not report any linting error. :-)

Well, on the other side, it is still the same behaviour.

Toggle snippet (8 lines)
$ guix lint julia ; echo $?
gnu/packages/julia.scm:301:0: julia@1.5.3: line 301 is way too long (107 characters)
gnu/packages/julia.scm:303:0: julia@1.5.3: line 303 is way too long (106 characters)
gnu/packages/julia.scm:226:13: julia@1.5.3: can be upgraded to 1.6.0
gnu/packages/julia.scm:227:12: julia@1.5.3: source not archived on Software Heritage
0

What do we do. On one hand, «it never pretended to exit with non-zero
when warninf» and on the other hand it could be annoying.

Well, since it is 4 years and 34 weeks, I consider it is not a big deal
and so we can close. WDYT?


All the best,
simon
Z
Z
zimoun wrote on 9 Jun 2021 23:41
(name . Ludovic Courtès)(address . ludo@gnu.org)
86sg1qlnri.fsf@gmail.com
Hi,

On Wed, 27 Jul 2016 at 22:57, ludo@gnu.org (Ludovic Courtès) wrote:
Toggle quote (7 lines)
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
>> guix lint doesn't actually fail on some errors.
>
> It never pretended to exit with non-zero when warnings are emitted. :-)
> (These are warnings, not errors.)

Do we modify the returned code? If not, can we close?

Cheers,
simon
Z
Z
zimoun wrote on 5 Jul 2021 13:08
control message for bug #24083
(address . control@debbugs.gnu.org)
87tul9j9vb.fsf@gmail.com
tags 24083 + moreinfo
quit
Z
Z
zimoun wrote on 13 Jul 2021 11:05
Re: bug#24083: guix lint doesn't actually fail on some errors
(name . Ludovic Courtès)(address . ludo@gnu.org)
86pmvmoa6q.fsf@gmail.com
Hi,

On Wed, 27 Jul 2016 at 22:57, ludo@gnu.org (Ludovic Courtès) wrote:
Toggle quote (7 lines)
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
>> guix lint doesn't actually fail on some errors.
>
> It never pretended to exit with non-zero when warnings are emitted. :-)
> (These are warnings, not errors.)

Because of that, I propose to close without modifying the returned code.
WDYT?

Cheers,
simon
D
D
Danny Milosavljevic wrote on 13 Jul 2021 12:20
(name . zimoun)(address . zimon.toutoune@gmail.com)
20210713122021.258f00f7@scratchpost.org
On Tue, 13 Jul 2021 11:05:49 +0200
zimoun <zimon.toutoune@gmail.com> wrote:

Toggle quote (8 lines)
> On Wed, 27 Jul 2016 at 22:57, ludo@gnu.org (Ludovic Courtès) wrote:
> > Danny Milosavljevic <dannym@scratchpost.org> skribis:
> >
> >> guix lint doesn't actually fail on some errors.
> >
> > It never pretended to exit with non-zero when warnings are emitted. :-)
> > (These are warnings, not errors.)

Sure, it makes sense. I'm just doing " |wc -l" now.

Toggle quote (3 lines)
> Because of that, I propose to close without modifying the returned code.
> WDYT?

Agreed.

But I would suggest to document in the manual that the exit status is
not set, though.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAmDtaOUACgkQ5xo1VCww
uqUG+Qf/RM3wpPg0f3Wpe+DsUwX2zlMc4mDy5+0ysQRcDw30pArq3VJwTTus1AQF
QUlW75yyywSTgzs6Nckehd/h1Ux9K9DMJvqOjnkR6oqZEnubsl1MSDNIbF7E15yK
V19GYO8xz9w1Go0k/mHiC8TgMSYKxWF1IbAvSPjbMH0V2yMlZQ8xlQ+FI39m8AZQ
LDxYW5UmJD374ZJKhGTamTZfNOqxS+b3fLGUjCIUKB06p2pU8m/p7cyFhdgEdVk2
zIALmQ545wnUNw4fD+JfdXhn6PEmph0+BYvq7Wfio1CTI1dt42n4wP7EEgnJvhPO
jtPzDyr2VujTQenjA58tqPAXlcKuDg==
=ED3l
-----END PGP SIGNATURE-----


M
M
Maxim Cournoyer wrote on 31 Mar 2023 18:57
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
87edp4x3iv.fsf@gmail.com
Hi,

Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (21 lines)
> On Tue, 13 Jul 2021 11:05:49 +0200
> zimoun <zimon.toutoune@gmail.com> wrote:
>
>> On Wed, 27 Jul 2016 at 22:57, ludo@gnu.org (Ludovic Courtès) wrote:
>> > Danny Milosavljevic <dannym@scratchpost.org> skribis:
>> >
>> >> guix lint doesn't actually fail on some errors.
>> >
>> > It never pretended to exit with non-zero when warnings are emitted. :-)
>> > (These are warnings, not errors.)
>
> Sure, it makes sense. I'm just doing " |wc -l" now.
>
>> Because of that, I propose to close without modifying the returned code.
>> WDYT?
>
> Agreed.
>
> But I would suggest to document in the manual that the exit status is
> not set, though.

Acting on the proposed and agreed closing action :-).

--
Thanks,
Maxim
Closed
?